RPI 3B+ smartcard

All about WTware on Raspberry. WTware works with Raspberry Pi 4, Raspberry Pi 3B+, Pi 3 and Pi 2 devices
http://www.winterminal.com
Post Reply
geefox
Posts: 65
Joined: Fri Sep 29, 2017 6:43 pm

RPI 3B+ smartcard

Post by geefox »

hi,

we encountered an issue with a smartcard reader omnikey "omni3021" - a week ago we configured following:

Code: Select all

smartcard=omni3021
and installed the safesign software on the server and it recognizes the smartcardreader an also the card. now we wanted to test something else, but we can't get it working anymore.

i've attached you the logfile - thanks
Attachments
log.txt
(42.44 KiB) Downloaded 126 times

akatik
SUPPORT
SUPPORT
Posts: 447
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: RPI 3B+ smartcard

Post by akatik »

Write to config:

smartcard=omni3021,debug

And try to do minimum actions to reproduce wrong behavior. Save log when you see the first wrong behavior.

PS: can you redirect this reader with this card to the same server with the same user from windows computer with mstsc.exe?

geefox
Posts: 65
Joined: Fri Sep 29, 2017 6:43 pm

Re: RPI 3B+ smartcard

Post by geefox »

Hi,
I managed to get it working again, there was a driver issue which caused the problem

geefox
Posts: 65
Joined: Fri Sep 29, 2017 6:43 pm

Re: RPI 3B+ smartcard

Post by geefox »

Hi,
just a quick question - is it possible that the "ask_password" setting can be configured with 2 parameters?
we need the option to bypass the broker and also to disable the smartcard login with "nopin"
so basically the line should look like this "ask_password = on, nopin"

akatik
SUPPORT
SUPPORT
Posts: 447
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: RPI 3B+ smartcard

Post by akatik »

"ask_password = nopin" should ask password for broker and disable smartcard login. "nopin" is "on,nopin". there is no "off,nopin".

Post Reply