RPI 3B+ smartcard

Post a reply

In an effort to prevent automatic submissions, we require that you complete the following challenge.
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen:

BBCode is OFF
Smilies are ON

Topic review

Expand view Topic review: RPI 3B+ smartcard

Re: RPI 3B+ smartcard

by akatik » Tue May 29, 2018 7:49 am

"ask_password = nopin" should ask password for broker and disable smartcard login. "nopin" is "on,nopin". there is no "off,nopin".

Re: RPI 3B+ smartcard

by geefox » Mon May 28, 2018 2:59 pm

just a quick question - is it possible that the "ask_password" setting can be configured with 2 parameters?
we need the option to bypass the broker and also to disable the smartcard login with "nopin"
so basically the line should look like this "ask_password = on, nopin"

Re: RPI 3B+ smartcard

by geefox » Fri May 25, 2018 1:31 pm

I managed to get it working again, there was a driver issue which caused the problem

Re: RPI 3B+ smartcard

by akatik » Wed May 16, 2018 9:23 pm

Write to config:


And try to do minimum actions to reproduce wrong behavior. Save log when you see the first wrong behavior.

PS: can you redirect this reader with this card to the same server with the same user from windows computer with mstsc.exe?

RPI 3B+ smartcard

by geefox » Wed May 16, 2018 2:33 pm


we encountered an issue with a smartcard reader omnikey "omni3021" - a week ago we configured following:

Code: Select all

and installed the safesign software on the server and it recognizes the smartcardreader an also the card. now we wanted to test something else, but we can't get it working anymore.

i've attached you the logfile - thanks
(42.44 KiB) Downloaded 127 times