Wi-Fi roaming (I'm tired)

Topics that doesn't fall into the categories above
Post Reply
laesyar
Posts: 11
Joined: Mon Aug 17, 2020 4:32 pm

Wi-Fi roaming (I'm tired)

Post by laesyar »

Hello,

In our warehouse, we have trucks driving around with terminal screens.
Normally they have Windows installed, but since that is labor sensitive because of Windows Updates, we are looking for different options.
We have tried WTware for a week now and it's looking pretty good.

However, there is one thing that is critical for us, which is Wi-Fi roaming and keeping a connection with the Remote Desktop Services server.
WTware is generally roaming fine, but there are multiple occasions per day that the connection is lost and WTware reports "I'm tired".
You have to imagine that these trucks drive past access points very fast, so I don't think it's strange that WTware gets "tired".

I'd like to know if there is anything I can do or try to make the connection more aggressive.
Maybe we could the suppress "I'm tired" message and just keep trying to (re)connect?
Otherwise things like different drivers or different driver settings could also be something that we can try?

Thanks
akatik
SUPPORT
SUPPORT
Posts: 474
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Wi-Fi roaming (I'm tired)

Post by akatik »

Hello,
We need terminal log to find out what made wtware feel tired: http://wtware.com/logs.html
Send it to supprt@wtware.com
laesyar
Posts: 11
Joined: Mon Aug 17, 2020 4:32 pm

Re: Wi-Fi roaming (I'm tired)

Post by laesyar »

Since last friday we are trying to get the error again.
Of course, the error never appears when you need it :)
So when we get the error I will reply it.

Also, I have been looking for roaming configuration with wpa_supplicant.
That could be set up with a simple argument:

Code: Select all

bgscan="simple:30:-70:3600"
"The above example will cause wpa_supplicant to scan every 30 seconds when the signal is weak (below -70), and every 3600 seconds otherwise. bgscan can be specified either in specific network blocks or globally for all networks." - source: https://wiki.archlinux.org/index.php/wp ... nt#Roaming
I know I can create the wpa_supplicant.conf, but maybe it is cool if this could be configured from WTware Center.
laesyar
Posts: 11
Joined: Mon Aug 17, 2020 4:32 pm

Re: Wi-Fi roaming (I'm tired)

Post by laesyar »

Just after my reply, the error appeared!
I have attached the log (anonymized) to this reply.

I also will try the bgscan argument in wpa_supplicant.conf to see if it works good.
Because now WTware will stay connected until the terminal is too far from the access point, resulting in a very low signal level.

Code: Select all

eth0      IEEE 802.11  ESSID:"mywifissid"  
          Mode:Managed  Frequency:5.18 GHz  Access Point: AA:BB:CC:DD:EE:FF 
          Bit Rate=28.9 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=23/70  Signal level=-87 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:17   Missed beacon:0
Attachments
09-13-58.txt
(239.51 KiB) Downloaded 12 times
laesyar
Posts: 11
Joined: Mon Aug 17, 2020 4:32 pm

Re: Wi-Fi roaming (I'm tired)

Post by laesyar »

We have tried the bgscan argument for a couple of days now and it's looking pretty good.
The "I'm tired" message did not appear anymore, but we will test it more.

This is the wpa_supplicant.conf that we currently use:

Code: Select all

ctrl_interface=/var/run/wpa_supplicant
network={
   ssid="myssid"
   scan_ssid=1
   psk=securepsk
   bgscan="simple:15:-70:90"
}
You can calculate the PSK on this website if you don't want it to be plain text.

If I understand correctly, bgscan will trigger scanning for a better Wi-Fi signal when the signal goes below -70 dBm.
When it can't find a stronger signal, it will scan every 15 seconds.
When the signal is good, it will scan every 90 seconds to find an even better signal.

It is noticable in the logs too!

Code: Select all

[           WPA] [ 2920.637855] eth0: CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-67 noise=9999 txrate=6000
[           WPA] [ 2924.119504] eth0: CTRL-EVENT-SIGNAL-CHANGE above=0 signal=-75 noise=9999 txrate=86700
[           WPA] [ 2924.975511] eth0: SME: Trying to authenticate with aa:aa:aa:aa:aa:aa (SSID='myssid' freq=5220 MHz)
[        KERNEL] [ 2924.978211] eth0: disconnect from AP bb:bb:bb:bb:bb:bb for new auth to aa:aa:aa:aa:aa:aa
(...)
[           WPA] [ 2925.020308] eth0: CTRL-EVENT-SIGNAL-CHANGE above=0 signal=-57 noise=9999 txrate=6000
[           WPA] [ 2925.050901] eth0: CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-54 noise=9999 txrate=6000
[           WPA] [ 2976.046336] eth0: CTRL-EVENT-SIGNAL-CHANGE above=0 signal=-73 noise=9999 txrate=86700
[           WPA] [ 2979.760017] eth0: SME: Trying to authenticate with bb:bb:bb:bb:bb:bb (SSID='myssid' freq=5200 MHz)
[        KERNEL] [ 2979.762756] eth0: disconnect from AP aa:aa:aa:aa:aa:aa for new auth to bb:bb:bb:bb:bb:bb
Keep in mind that your log will be a lot bigger if you roam with the device all day.
laesyar
Posts: 11
Joined: Mon Aug 17, 2020 4:32 pm

Re: Wi-Fi roaming (I'm tired)

Post by laesyar »

We have multiple models of terminal touch screen.

The log in my previous reply is from a model with an Intel Wi-Fi chipset.

Code: Select all

C 02:80 8086:24fd Network controller Network controller Intel Corporation Wireless 8265 / 8275
We have another model with a Broadcom BCM4322 Wi-Fi chipset.

Code: Select all

C 02:80 14e4:432b Network controller Network controller Broadcom Inc. and subsidiaries BCM4322 802.11a/b/g/n Wireless LAN Controller
It seems that bgscan does not work correctly with the Broadcom Wi-Fi chipset, as you can see in this line from the log.

Code: Select all

[           WPA] [17151.212379] bgscan simple: Failed to enable signal strength monitoring
@akatik do you know if the latest Broadcom driver is in WTware?
Is it possible to test the latest driver?

Edit on 23-9-2020: There are at least two options:
  • The latest b43 driver will work good (firmware-b43-installer)
    Debian package
Attachments
README_6.30.223.271.txt
Broadcom STA driver readme
(16.81 KiB) Downloaded 8 times
Last edited by laesyar on Wed Sep 23, 2020 10:21 am, edited 2 times in total.
laesyar
Posts: 11
Joined: Mon Aug 17, 2020 4:32 pm

Re: Wi-Fi roaming (I'm tired)

Post by laesyar »

I tried wpa_supplicant on debian on the same terminal model with the Broadcom BCM4322 chipset and the latest Broadcom b43 driver.
wpa_supplicant is there able to monitor the signal strength successfully.

In the attached log you can see the wpa_supplicant log from the debian installation.
So I think if the latest Broadcom STA drivers were added in WTware, that would solve the roaming problem for this model.
Attachments
wpa_supplicant-debian.txt
(1.26 KiB) Downloaded 8 times
Post Reply