RPI3+ WTWARE 5.8.46 Chrome region?

All about WTware on Raspberry. Wtware works with Raspberry Pi 2 Model B, Pi 3 Model B and Pi 3B+ devices
http://www.winterminal.com
Post Reply
duri3
Posts: 21
Joined: Tue Nov 07, 2017 6:21 pm

RPI3+ WTWARE 5.8.46 Chrome region?

Post by duri3 » Mon Jan 21, 2019 3:21 pm

Good day
I've updated wtware version 5.8.32 to 5.8.46 today. Now Chrome will display Website region in russian. For example Google Search and Outlook OWA shows in russian language. Unfortunately, I have not found a way to adjust this.

Can someone help me?

akatik
SUPPORT
SUPPORT
Posts: 342
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: RPI3+ WTWARE 5.8.46 Chrome region?

Post by akatik » Wed Jan 23, 2019 12:54 pm

If you downgrade back to 5.8.32, will Google return you back or stay in Russia forever?

Also, if uploading config files from TFTP, put this file: http://wtware.com/testing/empty.zip into C:\ProgramData\WTware\Chrome and add:

Code: Select all

chrome_profile=empty.zip
to the terminal config.

If config is stored on SD, put this file: http://wtware.com/testing/empty.zip into configs/ folder on SD and rename to chprf.zip.

If you do it right, after reboot Chrome will complain about broken profile. Profile is empty now, nothing is saved on our computers. What region will Chrome display with broken/empty profile?

duri3
Posts: 21
Joined: Tue Nov 07, 2017 6:21 pm

Re: RPI3+ WTWARE 5.8.46 Chrome region?

Post by duri3 » Wed Jan 23, 2019 3:51 pm

Hello
It did downgrade to 5.8.32 and it's back to normal (no russian language region).
So it's ok for me I stay with this version since there is no changelog anyway, I can't see there is any benefit for a newer version.

I don't have a testing RPI at the moment so im not able to test that provided empty.zip.
If it would be helpful for later versions, I can test it maybe later.

BTW, is the WTWARE licence for lifetime -> can I always upgrade to new version or just as long its 5.8.x? So 5.9.x would need a new licence?

akatik
SUPPORT
SUPPORT
Posts: 342
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: RPI3+ WTWARE 5.8.46 Chrome region?

Post by akatik » Thu Jan 24, 2019 7:01 am

duri3 wrote:
Wed Jan 23, 2019 3:51 pm
If it would be helpful for later versions, I can test it maybe later.
Yes, test it please. Because I'm unable to reproduce this error.
duri3 wrote:
Wed Jan 23, 2019 3:51 pm
BTW, is the WTWARE licence for lifetime
We promise at least one year of free updates. In fact, licenses work since 2004.

duri3
Posts: 21
Joined: Tue Nov 07, 2017 6:21 pm

Re: RPI3+ WTWARE 5.8.46 Chrome region?

Post by duri3 » Tue Jan 29, 2019 6:29 pm

Ok today I found some time to test this again.

As soon I copy that provided file into configs/ folder on SD and rename to chprf.zip it works -> no more russian in Chrome but every time a complain about a broken profile.
As soon I delete that chprf.zip file off the SD it's back to russian :-)

Hope this helps

akatik
SUPPORT
SUPPORT
Posts: 342
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: RPI3+ WTWARE 5.8.46 Chrome region?

Post by akatik » Tue Jan 29, 2019 8:38 pm

Seems like default profile (chprf file in packages/ folder) is bound to Russia (but why???)

Without profile it's not locked to Russia, that's good.

When does profile become locked to region?

Please, try minimal valid profile I saved on my computer connected through VPN to United Kingdom:

http://wtware.com/testing/minimal.zip

The same as before: download, copy to SD and rename. Will it be locked to some country? Russia or UK?

And this is a minimal profile with adblock installed:

http://wtware.com/testing/20190123.zip

If this profile will be OK, I put it as default in the next wtware version.

duri3
Posts: 21
Joined: Tue Nov 07, 2017 6:21 pm

Re: RPI3+ WTWARE 5.8.46 Chrome region?

Post by duri3 » Wed Jan 30, 2019 1:51 pm

I just tried the minimal.zip and it's working now. Chrome shows the MS OWA login in German and Keyboard as the correct de-ch layout too.

So maybe a good idea, to put this profile in the next wtware version as default. :-)

duri3
Posts: 21
Joined: Tue Nov 07, 2017 6:21 pm

Re: RPI3+ WTWARE 5.8.46 Chrome region?

Post by duri3 » Tue Apr 02, 2019 5:25 pm

I updated all our clients now to wtware 5.8.50. Thanks again all working fine now :-)

Post Reply