Wireless WPA2 Enterprise Authentication

All about WTware on Raspberry. Wtware works with Raspberry Pi 3 Model B and Pi 2 Model B devices
http://www.winterminal.com
vincny
Posts: 34
Joined: Tue Nov 01, 2016 9:58 am

Re: Wireless WPA2 Enterprise Authentication

Post by vincny » Mon Nov 14, 2016 7:09 am

Hi Aka,

Yes the Radius server work with static IP.
Yes wireless is important for my deployment. :(
I hope it will work, I will install the test version and let you know.

Thanks,
Ken

vincny
Posts: 34
Joined: Tue Nov 01, 2016 9:58 am

Re: Wireless WPA2 Enterprise Authentication

Post by vincny » Mon Nov 14, 2016 12:30 pm

Hi Aka,

Please refer to attach photos.

1. ifconfig.jpg - The Static IP Address was define here
2. iwconfig.jpg - No IP address is being observer
3.ping.jpg - Ping did not went through the gateway

Will continue with log on next post as maximum only 3 phot allow.

Thanks,
Ken
Attachments
ping.jpg
ping.jpg (180.19 KiB) Viewed 1857 times
iwconfig.jpg
iwconfig.jpg (198.81 KiB) Viewed 1857 times
ifconfig.jpg
ifconfig.jpg (254.52 KiB) Viewed 1857 times

vincny
Posts: 34
Joined: Tue Nov 01, 2016 9:58 am

Re: Wireless WPA2 Enterprise Authentication

Post by vincny » Mon Nov 14, 2016 12:51 pm

Hi Aka,

Please refer to attach photos.

4. all_log1.jpg - Authentication successful has been observer
5. all_log2.jpg - No relevant Wireless log
6. all_log3.jpg - No relevant wireless log

Thanks,
Ken
Attachments
all_long1.jpg
all_long1.jpg (222.78 KiB) Viewed 1857 times
all_long3.jpg
all_long3.jpg (159.59 KiB) Viewed 1857 times
all_long2.jpg
all_long2.jpg (147.42 KiB) Viewed 1857 times

aka
SUPPORT
SUPPORT
Posts: 572
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Wireless WPA2 Enterprise Authentication

Post by aka » Mon Nov 14, 2016 5:17 pm

ifconfig and iwconfig look right. And there is some traffic received/transmitted.
Why are there 1500 seconds since boot? Did you take the photos immediately after boot, without entering setup?

4. all_log1.jpg - CTRL-EVENT-DISCONNECTED, and it knows AP mac. Seems it is not the first connection after reboot. Please, make me photos after boot.

2. iwconfig.jpg - No IP address is being observed - iwconfig should not display IP. It's WiFi configuration.

3.ping.jpg - Ping did not went through the gateway. - Please, ping something LOCAL. In WiFi subnet.

And please disconnect USB mouse Logitech. It disconnects every minute and sends a lot of text to log.

vincny
Posts: 34
Joined: Tue Nov 01, 2016 9:58 am

Re: Wireless WPA2 Enterprise Authentication

Post by vincny » Wed Nov 16, 2016 6:29 am

Hi Aka,

I am sorry for the delay, please refer to the new photo taken.

1. Ping.jpg - I have tried to ping IP address on the same subnet but same result.
2. All_log1.jpg, All_log2.jpg - Hope you can help to find something here.

Thanks,
Ken
Attachments
all_log1.jpg
all_log1.jpg (186.84 KiB) Viewed 1838 times
all_log2.jpg
all_log2.jpg (161.9 KiB) Viewed 1838 times
Last edited by vincny on Wed Nov 16, 2016 2:16 pm, edited 1 time in total.

vincny
Posts: 34
Joined: Tue Nov 01, 2016 9:58 am

Re: Wireless WPA2 Enterprise Authentication

Post by vincny » Wed Nov 16, 2016 6:40 am

Hi Aka,

Continue with all_log3.jpg, all_log4.jpg - Hope it is useful for you to help to make it work.

Thanks,
Ken
Attachments
all_log3.jpg
all_log3.jpg (199.82 KiB) Viewed 1838 times
all_log4.jpg
all_log4.jpg (195.14 KiB) Viewed 1838 times

aka
SUPPORT
SUPPORT
Posts: 572
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Wireless WPA2 Enterprise Authentication

Post by aka » Wed Nov 16, 2016 1:25 pm

Everything is right, as far as I know.
Does Raspbian work with your WiFi?

Send me dmesg, ifconfig, iwconfig output:
dmesg > /tmp/123.log
ifconfig > /tmp/234.log
iwconfig > /tmp/345.log
and wpa_supplicant.conf, if it exists
To support@wtware.com

vincny
Posts: 34
Joined: Tue Nov 01, 2016 9:58 am

Re: Wireless WPA2 Enterprise Authentication

Post by vincny » Wed Nov 16, 2016 2:52 pm

Hi Aka,

It my fault, I have remove the following parameter from the wpa_supplication.conf "phase1="peaplabel=1"" and immediately it started working.

And I am very happy to tell you job well done! :)

Thanks,
Ken

aka
SUPPORT
SUPPORT
Posts: 572
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Wireless WPA2 Enterprise Authentication

Post by aka » Thu Nov 17, 2016 2:29 pm

Great! For we had no more ideas.

Post Reply