Keyboard ja layout

Requests for the next versions.
Post Reply
a-lab
Posts: 17
Joined: Tue Nov 02, 2010 2:22 am

Keyboard ja layout

Post by a-lab » Tue Nov 02, 2010 2:27 am

Is 'ja' keyboard layout supported?
If not, could you please add it?

aka
SUPPORT
SUPPORT
Posts: 620
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Keyboard ja layout

Post by aka » Tue Nov 02, 2010 10:00 am


a-lab
Posts: 17
Joined: Tue Nov 02, 2010 2:22 am

Re: Keyboard ja layout

Post by a-lab » Tue Nov 02, 2010 11:51 am

Unfortunately, several key codes are not assigned properly in my environment.
i.e. Although '\'(backslash) of en layout should be ']' in ja layout, it still assigned as '\'.

http://ascii-table.com/keyboard.php/194

I added 'keyboard = ja' line to *.wtc file and confirmed its setting appeared on
wtware syslog below.

| initrd: Download file "pro\4.6.8/configs/00.1E.C9.7C.B8.9E.wtc" from TFTP server "172.16.0.150".
...
| +--- FILE "/tmp/cfg" -----------------------
...
| | keyboard = ja


Could you please tell me how to solve this problem?

aka
SUPPORT
SUPPORT
Posts: 620
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Keyboard ja layout

Post by aka » Fri Nov 05, 2010 4:01 pm

Sorry, correct link is http://wtware.com/docs46/config.html#keyboard
This is only language mode in "windows login" screen.
a-lab wrote:Unfortunately, several key codes are not assigned properly in my environment.
i.e. Although '\'(backslash) of en layout should be ']' in ja layout, it still assigned as '\'.
http://ascii-table.com/keyboard.php/194
Nice site. Looking on it, please tell me, what is wrong.
You talking about key with Base code U+005C?
Which char this key puts to Notepad while typing through mstsc.exe session?

a-lab
Posts: 17
Joined: Tue Nov 02, 2010 2:22 am

Re: Keyboard ja layout

Post by a-lab » Fri Nov 05, 2010 5:48 pm

Thank you for reply.

> You talking about key with Base code U+005C?

Yes, and some other characters. ('[', ']', ':', etc.)

> Which char this key puts to Notepad while typing through mstsc.exe session?

'\' -> puts '\' thurough mstsc.exe session (key does not respond thru wtware session)
']' -> puts ']' thru tsc ('\' thru wtware)
':' -> puts ':' thru tsc (''' thru wtware)

These results indicate wtware sends 101 keyboard layout in 'ja' config
instead of 106 layout. I confirmed incorrect key events sent
using freeware "SharpKeys".

aka
SUPPORT
SUPPORT
Posts: 620
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Keyboard ja layout

Post by aka » Fri Nov 05, 2010 9:48 pm

Please, install and boot this:
http://pxe.ru/files/testing/201011051150.zip
This build will post scancodes we receive from hardware. You'll see new lines in wtware event viewer every time you press or release any key. Please, put log samples here for every incorrect key and write, which char should appear in notepad. Chars appear incorrectly when you type in ENglish or in JApanese?

a-lab
Posts: 17
Joined: Tue Nov 02, 2010 2:22 am

Re: Keyboard ja layout

Post by a-lab » Sat Nov 06, 2010 4:49 am

Thank you for providing debug program.

> Chars appear incorrectly when you type in ENglish or in JApanese?

In English, which ja imput-method is turned off (= single-byte mode).

> Please, put log samples here for every incorrect key and write, which char should appear in notepad.

Okay. Every key described below is laid out as:
http://ascii-table.com/keyboard.php/194

key 'Size' (shown on left-top corner in http://ascii-table.com/keyboard.php/194)
expected: ja imput-method toggled and no char should appear
incorrect result: '`' (backquote) appears on notepad
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x29 (41), pressed

key 'Shift-2' (U+0022, incorrect char shown in http://ascii-table.com/keyboard.php/194)
expected: '"' (quotation mark) should appear in notepad
incorrect result: '@' appears
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), pressed
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x03 (3), pressed

key 'Shift-6'
expected: '&'
incorrect result: '^'
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), pressed
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x07 (7), pressed

key 'Shift-7'
expected: ''' (apos)
incorrect result: '&'
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), pressed
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x08 (8), pressed

key 'Shift-8'
expected: '('
incorrect result: '*'
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), released
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x09 (9), released

key 'Shift-9'
expected: ')'
incorrect result: '*'
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), pressed
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x0a (10), pressed

key 'Shift-0'
expected: no char should appear
incorrect result: ')'
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), pressed
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x0b (11), pressed

key 'Shift--' (minus sign)
expected: '='
incorrect result: '_'
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), pressed
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x0c (12), pressed

key 'Shift-^' (left of '-' key)
expected: '~'
incorrect result: '+'
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), pressed
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x0d (13), pressed

key 'Shift-\' (U+00A5, right of 'BS' key)
expected: '|' (vertical bar)
incorrect result: no char appears
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), pressed
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x7c (124), pressed
init: video/video_keyboard.c ( 224), keyProcessInDS: -- ERROR -- Unknown character, scancode 0x7c

key '\' (U+00A5, right of 'BS' key)
expected: '\'
incorrect result: no char appears on notepad
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x7c (124), pressed
init: video/video_keyboard.c ( 224), keyProcessInDS: -- ERROR -- Unknown character, scancode 0x7c

key '@' (U+0040)
incorrect result: '['
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x1a (26), pressed

key '[' (U+005B)
incorrect result: ']'
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x1b (27), pressed

key ':' (U+003A)
incorrect result: ''
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x28 (40), pressed

key ']' (U+005D)
incorrect result: ''
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x2b (43), pressed

key '\' (U+005C, left of right-shift key)
incorrect result: no char appears
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x59 (89), pressed

key 'Shift-;'
expected: '+'
incorrect result: ':'
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), pressed
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x27 (39), pressed

key 'Shift-:'
expected: '*'
incorrect result: '"'
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), pressed
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x28 (40), pressed

key 'Shift-@'
expected: '`'
incorrect result: '{'
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), pressed
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x1a (26), pressed

key 'Shift-['
expected: '{'
incorrect result: '}'
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), pressed
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x1b (27), pressed

key 'Shift-]'
expected: '}'
incorrect result: '|'
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), pressed
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x2b (43), pressed

key 'Shift-\' (U+005C, left of right-shift key)
expected: '_'
incorrect result: no char appears
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), pressed
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x59 (89), pressed

key 'Noconv' (shown on bottom middle-left in http://ascii-table.com/keyboard.php/194)
expected: ja imput-method responds 'noconv' and no char should appear
incorrect result: no response
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x5e (94), pressed
init: video/video_keyboard.c ( 224), keyProcessInDS: -- ERROR -- Unknown character, scancode 0x5e

key 'Convert' (shown on bottom middle-right in http://ascii-table.com/keyboard.php/194)
expected: ja imput-method responds 'convert' and no char should appear
incorrect result: no response
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x5c (92), pressed
init: video/video_keyboard.c ( 224), keyProcessInDS: -- ERROR -- Unknown character, scancode 0x5c

key 'Kana' (shown on bottom middle-left in http://ascii-table.com/keyboard.php/194
expected: ja imput-method toggles and no char should appear
incorrect result: no response
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x5d (93), pressed
init: video/video_keyboard.c ( 224), keyProcessInDS: -- ERROR -- Unknown character, scancode 0x5d

aka
SUPPORT
SUPPORT
Posts: 620
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Keyboard ja layout

Post by aka » Sun Nov 07, 2010 10:59 pm

It seems I do not understand, what is "layout".

I have keyboard with 'shift' and with '6'. I have mstsc.exe and original english windows7. I add Japan language, keyboard Japanese and Microsoft IME. In "JA" language, with both keyboards I got ^ when I press Shift-6.
In "RU" language, I got :
In "EN", I got ^, same as in "JA"

What should I do to get & when I press 'Shift-6'?
Attachments
Untitled.png
Untitled.png (16.43 KiB) Viewed 10677 times

a-lab
Posts: 17
Joined: Tue Nov 02, 2010 2:22 am

Re: Keyboard ja layout

Post by a-lab » Sun Nov 07, 2010 11:25 pm

Probably you need to change keyboard driver at the Device Manager to emulate JA layout. Please see attached image.
kbd-drv.chg.png
kbd-drv.chg.png (46.25 KiB) Viewed 10676 times

aka
SUPPORT
SUPPORT
Posts: 620
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Keyboard ja layout

Post by aka » Mon Nov 08, 2010 2:08 am

Successful with local windows.
Unsuccessful with mstsc.exe.

Now I have two windows (winXP sp3 and win7, both english). Both have 106-key keyboard driver installed and three languages (EN, RU, JP). When I select JP, I got & for Shift-6 in both OSes. Locally.

But when I connect with mstsc.exe from one windows to another, I got ^ for Shift-6 in EN and JP.

Where am I wrong?

a-lab
Posts: 17
Joined: Tue Nov 02, 2010 2:22 am

Re: Keyboard ja layout

Post by a-lab » Mon Nov 08, 2010 2:54 am

Please set the Input Language in the Text Service along with attached image.
kbd-layout-chg.png
kbd-layout-chg.png (34.05 KiB) Viewed 10674 times

aka
SUPPORT
SUPPORT
Posts: 620
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Keyboard ja layout

Post by aka » Mon Nov 08, 2010 9:39 pm

Yes!
Thank you.
Now I need some days to do the same in WTware.

aka
SUPPORT
SUPPORT
Posts: 620
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Keyboard ja layout

Post by aka » Fri Nov 12, 2010 4:11 pm

Good news: most of keys fixed. Here it is:

http://pxe.ru/files/testing/201011120723.zip

Specify keyboard=ja in config file. Please, try it.

To fix other keys, I need your assistance. Please contact my terminal server with mstsc.exe from win7 of winxp sp3 over Internet and press five times every key from following list:
a-lab wrote: key 'Shift-\' (U+00A5, right of 'BS' key)
expected: '|' (vertical bar)
incorrect result: no char appears
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), pressed
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x7c (124), pressed
init: video/video_keyboard.c ( 224), keyProcessInDS: -- ERROR -- Unknown character, scancode 0x7c

key '\' (U+00A5, right of 'BS' key)
expected: '\'
incorrect result: no char appears on notepad
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x7c (124), pressed
init: video/video_keyboard.c ( 224), keyProcessInDS: -- ERROR -- Unknown character, scancode 0x7c

key '\' (U+005C, left of right-shift key)
incorrect result: no char appears
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x59 (89), pressed

key 'Shift-\' (U+005C, left of right-shift key)
expected: '_'
incorrect result: no char appears
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x36 (54), pressed
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x59 (89), pressed

key 'Noconv' (shown on bottom middle-left in http://ascii-table.com/keyboard.php/194)
expected: ja imput-method responds 'noconv' and no char should appear
incorrect result: no response
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x5e (94), pressed
init: video/video_keyboard.c ( 224), keyProcessInDS: -- ERROR -- Unknown character, scancode 0x5e

key 'Convert' (shown on bottom middle-right in http://ascii-table.com/keyboard.php/194)
expected: ja imput-method responds 'convert' and no char should appear
incorrect result: no response
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x5c (92), pressed
init: video/video_keyboard.c ( 224), keyProcessInDS: -- ERROR -- Unknown character, scancode 0x5c

key 'Kana' (shown on bottom middle-left in http://ascii-table.com/keyboard.php/194
expected: ja imput-method toggles and no char should appear
incorrect result: no response
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x5d (93), pressed
init: video/video_keyboard.c ( 224), keyProcessInDS: -- ERROR -- Unknown character, scancode 0x5d
Please, send me email at aka@pxe.ru when you have time to do this. So that I could turn on my server, start sniffer and send you server IP.

a-lab
Posts: 17
Joined: Tue Nov 02, 2010 2:22 am

Re: Keyboard ja layout

Post by a-lab » Sat Nov 13, 2010 12:02 am

Great! I confirmed lots of problems except specified above have been fixed.

However, one key 'Size' still does not respond. Please examine it also through sniffer later.

key 'Size' (shown on left-top corner in http://ascii-table.com/keyboard.php/194)
expected: ja imput-method toggled and no char should appear
incorrect result: '`' (backquote) appears on notepad
init: video/video_keyboard.c ( 73), keyProcessInDS: scan 0x29 (41), pressed

> Please, send me email

I will contact you soon.

Post Reply