RDP session crashing when playing sound

All about WTware on Raspberry. WTware works with Raspberry Pi 4, Raspberry Pi 3B+, Pi 3 and Pi 2 devices
http://www.winterminal.com
Post Reply
Muetzenfrosch
Posts: 20
Joined: Tue Mar 06, 2018 1:17 am

RDP session crashing when playing sound

Post by Muetzenfrosch »

Hi guys,

I've just updated to WTWare 6.0.22 on my RPi4 (4GB). And now, when Windows (Win10 20H2) starts playing any sound, the WTWare RDP crashes (I get totally disconnected and end up on the Windows RDP login screen again).

I see this in the logs:
[rdpclient 1219] [ 525.463165] Sound version: 8.
[rdpclient 1219] [ 525.463319] ADPCM sound compression.
[rdpclient 1219] [ 525.463415] Sound redirection: 44100 frames per second.
[rdpclient 1219] [ 525.805000] rdpclient-rdpsnd.cpp ( 424): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[rdpclient 1219] [ 525.805494] Caught signal SIGSEGV.
[ gm] [ 525.806700] TSClientSession.cpp ( 276): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[ gm] [ 525.806814] Main pipe closed.
[ gm] [ 525.806904] TSClientSession.cpp ( 276): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[ gm] [ 525.806993] TSClientSession.cpp ( 297): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[ gm] [ 525.807082] Session is over. Final message: Main pipe closed.

And also this:
[rdpclient 1305] [ 525.839019] RDP Terminal Client, WTware 6.0.22/RPi, pipe 4, pid 1305.
[rdpclient 1305] [ 525.839248] Use /lib/ui32.so.
[rdpclient 1305] [ 525.839993] Redirect sound.
[rdpclient 1305] [ 528.841177] rdpclient-rdpsnd.cpp ( 576): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[rdpclient 1305] [ 528.841356] rdpclient-vchans.cpp ( 67): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[rdpclient 1305] [ 528.841461] Make RDP session with 192.168.1.33, port 3389.

The full log is attached.

It would be really nice, if you could have a look. Thanks a lot!

Best regards
Björn
Attachments
wtware6022log.txt
(135.07 KiB) Downloaded 4 times
akatik
SUPPORT
SUPPORT
Posts: 497
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: RDP session crashing when playing sound

Post by akatik »

There's no device hw:0:1. I see in log

| 16: [ 0- 0]: digital audio playback
| 48: [ 1- 0]: digital audio playback

Please, read our manual about sound configuration and specify correct sound value:

http://wtware.com/docs5/sound.html
Muetzenfrosch
Posts: 20
Joined: Tue Mar 06, 2018 1:17 am

Re: RDP session crashing when playing sound

Post by Muetzenfrosch »

Ohh, you are so right. Don't know, how this got in there.
With sound=on,hw:0:0 all is working now.

Thanks a lot for the quick support! :)
Muetzenfrosch
Posts: 20
Joined: Tue Mar 06, 2018 1:17 am

Re: RDP session crashing when playing sound

Post by Muetzenfrosch »

Sorry, I was a little bit too fast with my answer. The client is not crashing anymore, but I have no sound at all. No matter if I choose hw:0:0 (HDMI) or hw:1:0 (and connect the 3.5mm audio jack), I do not hear anything.

And there are new errors in the log:

[ X02] [ 79.833796] [966:976:1113/141827.997423:ERROR:ssl_client_socket_impl.cc(969)] handshake failed; returned -1, SSL error code 1, net_error -100
[ X02] [ 89.827673] [966:976:1113/141837.991383:ERROR:ssl_client_socket_impl.cc(969)] handshake failed; returned -1, SSL error code 1, net_error -100
[ rdpclient 917] [ 98.417109] Sound version: 8.
[ rdpclient 917] [ 98.419068] ADPCM sound compression.
[ rdpclient 917] [ 98.419120] Sound redirection: 44100 frames per second.
[ rdpsnd] [ 98.693805] ALSA: use device plug:dmixer.
[ rdpsnd] [ 98.702796] ALSA: Hardware rate 44100Hz.
[ rdpsnd] [ 98.707344] ALSA: chunk size 940 frames, 1880 bytes, 21 msec.
[ rdpsnd] [ 98.707412] ALSA: buffer size 15052 bytes, 170 miliseconds.
[ X02] [ 113.734425] [966:976:1113/141901.898039:ERROR:ssl_client_socket_impl.cc(969)] handshake failed; returned -1, SSL error code 1, net_error -100
[ X02] [ 134.558014] [966:976:1113/141922.721678:ERROR:ssl_client_socket_impl.cc(969)] handshake failed; returned -1, SSL error code 1, net_error -100
[ rdpclient 917] [ 143.668736] ./wtvector.h ( 195): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[ rdpclient 917] [ 143.668861] rdpclient-rdpsnd-queue.cpp ( 267): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[ rdpclient 917] [ 143.851092] ./wtvector.h ( 195): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[ rdpclient 917] [ 143.851273] rdpclient-rdpsnd-queue.cpp ( 267): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[ rdpclient 917] [ 144.043530] ./wtvector.h ( 195): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[ rdpclient 917] [ 144.043601] rdpclient-rdpsnd-queue.cpp ( 267): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[ rdpclient 917] [ 144.221983] ./wtvector.h ( 195): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[ rdpclient 917] [ 144.222057] rdpclient-rdpsnd-queue.cpp ( 267): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[ rdpclient 917] [ 144.411871] ./wtvector.h ( 195): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.

Any idea?

Thanks, best regards
Björn
akatik
SUPPORT
SUPPORT
Posts: 497
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: RDP session crashing when playing sound

Post by akatik »

Here is logging manual: https://wtware.com/logs.html

There are no words "remove everything interesting and show only a few lines".
Muetzenfrosch
Posts: 20
Joined: Tue Mar 06, 2018 1:17 am

Re: RDP session crashing when playing sound

Post by Muetzenfrosch »

Sorry, :oops: here is the full log.
Attachments
wtware6022log2.txt
(128.98 KiB) Downloaded 10 times
aka
SUPPORT
SUPPORT
Posts: 862
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: RDP session crashing when playing sound

Post by aka »

Will it play sound with minimal config?

Code: Select all

server=192.168.1.33
sound=on
Two lines, nothing else.
Muetzenfrosch
Posts: 20
Joined: Tue Mar 06, 2018 1:17 am

Re: RDP session crashing when playing sound

Post by Muetzenfrosch »

Yes, with this minimal config, sound is playing. So I tried a little bit more adding and removing lines to and from the config and it turns out, that while this

Code: Select all

server=192.168.1.33
sound=on
is working perfectly fine, the following

Code: Select all

server=192.168.1.33
sound=on
next screen
application=chrome
chrome_url=https://www.google.de
is not. As soon as I add a screen with chrome, the sound stops working. I also tried to remove my custom chrome profile (chprf.zip) but this did not make any difference.
The version I was on before updating was 6.0.6. With that version the sound was playing fine.

Best regards
Björn
Muetzenfrosch
Posts: 20
Joined: Tue Mar 06, 2018 1:17 am

Re: RDP session crashing when playing sound

Post by Muetzenfrosch »

Just to clarify: I don't expect Chrome to have sound. When I add the Chrome screen, the other RDP screen has no sound anymore.
akatik
SUPPORT
SUPPORT
Posts: 497
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: RDP session crashing when playing sound

Post by akatik »

All sessions will try sound (and have no sound if something goes wrong, we'll try to fix this bug, but now it goes wrong):

Code: Select all

sound=on
connection
server=192.168.1.1
connection
application chrome
Only RDP session will use sound, Chrome should not afect:

Code: Select all

connection
sound=on
server=192.168.1.1
connection
application chrome
Muetzenfrosch
Posts: 20
Joined: Tue Mar 06, 2018 1:17 am

Re: RDP session crashing when playing sound

Post by Muetzenfrosch »

Ok, I have tried

Code: Select all

connection
sound=on
server=192.168.1.33
connection
application chrome
and I have no sound in the RDP session. If I remove the chrome app and have only this

Code: Select all

connection
sound=on
server=192.168.1.33
sound is working in the RDP session.

[EDIT] Oh and I just realized: Clicking on "Beep!" in the WTware config section "Test sound" works and gives a beep, also with the first config containing chrome. But no windows sounds, no sound in browsers, no sound from any application running in the RDP session (tested several).
Do you need another log? Seems to be a pretty generic issue, not related to my setup, I guess.
aka
SUPPORT
SUPPORT
Posts: 862
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: RDP session crashing when playing sound

Post by aka »

Muetzenfrosch wrote:
Thu Nov 19, 2020 9:35 pm

Code: Select all

connection
sound=on
server=192.168.1.33
connection
application chrome
and I have no sound in the RDP session.
Please, show me the log.
Muetzenfrosch
Posts: 20
Joined: Tue Mar 06, 2018 1:17 am

Re: RDP session crashing when playing sound

Post by Muetzenfrosch »

Yes, sure. Here it is.
Attachments
wtware6022log3.txt
(64 KiB) Downloaded 9 times
aka
SUPPORT
SUPPORT
Posts: 862
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: RDP session crashing when playing sound

Post by aka »

Muetzenfrosch
Posts: 20
Joined: Tue Mar 06, 2018 1:17 am

Re: RDP session crashing when playing sound

Post by Muetzenfrosch »

Awesome!!! Sound is working now perfectly! Good job! Thanks a lot for the quick support and update! :D :D :D
Post Reply