Linphone not pulling in custom config

Topics that doesn't fall into the categories above
Post Reply
effin_dead_again
Posts: 15
Joined: Tue Dec 18, 2018 10:40 pm

Linphone not pulling in custom config

Post by effin_dead_again » Tue Dec 18, 2018 11:12 pm

All,

I'm trying to get Linphone to pull in a custom config to set some parameters necessary for my SIP server but it doesn't seem to be pulling the file in and setting the settings. The only way I know how to confirm this is to run a command to list a parameter I specifically defined in the linphone config and see that the parameter is undefined according to linphone.

Here's my terminal config line:

Code: Select all

SIP=0000:0000@<HOST_REDACTED>, config:linphone.wtc
Here's whats in my linphone.wtc file:

Code: Select all

[sip]
media_encryption=srtp
use_ipv6=0

[rtp]
audio_rtp_port=5004
video_rtp_port=0
nortp_timeout=0
audio_jitt_comp=60
video_jitt_comp=60
audio_adaptive_jitt_comp_enabled=1
video_adaptive_jitt_comp_enabled=1

[video]
enabled=0
show_local=0

[audio_codec_0]
mime=opus
rate=8000
channels=1
enabled=1

[audio_codec_1]
mime=speex
rate=8000
channels=1
enabled=1

[audio_codec_2]
mime=PCMU
rate=8000
enabled=1

[audio_codec_5]
mime=1015
rate=8000
enabled=1

[sound]
The file has been placed in C:\Program Data\WTWare\Everyone

I see in the log that the file is being downloaded:

Code: Select all

[            gm] [   19.076803] [TFTP] Download config file Everyone/linphone.wtc from <REDACTED>.
/--- FILE "/.linphonerc" -----------------------
| [sip]
| media_encryption=srtp
| use_ipv6=0
| [rtp]
| audio_rtp_port=5004
| video_rtp_port=0
| nortp_timeout=0
| audio_jitt_comp=60
| video_jitt_comp=60
| audio_adaptive_jitt_comp_enabled=1
| video_adaptive_jitt_comp_enabled=1
| [video]
| enabled=0
| show_local=0
| [audio_codec_0]
| mime=opus
| rate=8000
| channels=1
| enabled=1
| [audio_codec_1]
| mime=speex
| rate=8000
| channels=1
| enabled=1
| [audio_codec_2]
| mime=PCMU
| rate=8000
| enabled=1
| [audio_codec_5]
| mime=1015
| rate=8000
| enabled=1
| [sound]
| ringer_dev_id=ALSA: Sennheiser SC60 Control
| playback_dev_id=ALSA: Sennheiser SC60 Control
| capture_dev_id=ALSA: Sennheiser SC60 Control
\----------------------------------------------------
But when I run the command param sip use_ipv6 I get the output:

Code: Select all

current value: (undef)
This means that linphonec never read the value in which means it's not reading the file in. Any ideas?

akatik
SUPPORT
SUPPORT
Posts: 417
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Linphone not pulling in custom config

Post by akatik » Wed Dec 19, 2018 6:02 am

There is no ipv6 in wtware at all. Kernel compiled without ipv6.

effin_dead_again
Posts: 15
Joined: Tue Dec 18, 2018 10:40 pm

Re: Linphone not pulling in custom config

Post by effin_dead_again » Wed Dec 19, 2018 11:48 pm

You've completely missed the point. I am trying to convey that linphonec is not pulling in the configuration that I am specifying in the config file. It is getting downloaded from the server but it is not getting applied to linphonec. The command I ran was a test to see if liphonec was pulling in the value I set in the config file that was specified. It is not using the values in the config file despite clearly downloading them from the server.

aka
SUPPORT
SUPPORT
Posts: 715
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Linphone not pulling in custom config

Post by aka » Thu Dec 20, 2018 11:57 am

Here is the manual about logs: https://wtware.com/logs.html
No words "remove everything interesting and leave only few lines".

effin_dead_again
Posts: 15
Joined: Tue Dec 18, 2018 10:40 pm

Re: Linphone not pulling in custom config

Post by effin_dead_again » Thu Dec 20, 2018 8:48 pm

Attached.

Just an FYI, you are about half of a centimeter away from me buying another solution if you can't get that gnarly attitude under control. Perhaps you should change your auto-response to be something like: "The logs you have provided do not have enough information for us to research your issue. Please review the manual about logs here: https://wtware.com/logs.html and provide the full log output for our review."

It appears to me that linphonec isn't looking for the .linphonerc file in the location you are placing it but I am not familiar enough with the internals of WTWare to know any better. I will await your response.
Attachments
wtware-log.txt
(115.07 KiB) Downloaded 81 times

akatik
SUPPORT
SUPPORT
Posts: 417
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Linphone not pulling in custom config

Post by akatik » Fri Dec 21, 2018 4:51 pm

We'll use your text as auto-response. Thank you.

There are no .linphonerc files other than the one that printed in log. Lot of errors in lines with [ SIP] mark comes from your (what is not gnarly form of the word "incorrect"?) config.

effin_dead_again
Posts: 15
Joined: Tue Dec 18, 2018 10:40 pm

Re: Linphone not pulling in custom config

Post by effin_dead_again » Fri Dec 21, 2018 7:23 pm

I figured out the issue, but it was not because of an error in my config, but rather the lack of one option in the SIP section: ipv6_migration_done=1

Here is the config file that ultimately worked for me:

Code: Select all

[audio_codec_0]
mime=opus
rate=48000
channels=1
enabled=1
[audio_codec_1]
mime=speex
rate=8000
channels=1
enabled=1
[audio_codec_2]
mime=SILK
rate=16000
channels=1
enabled=1
[audio_codec_3]
mime=BV16
rate=8000
channels=1
enabled=1
[audio_codec_4]
mime=GSM
rate=8000
channels=1
enabled=1
[audio_codec_5]
mime=G722
rate=8000
channels=1
enabled=1
[audio_codec_6]
mime=PCMU
rate=8000
channels=1
enabled=1
[audio_codec_7]
mime=PCMA
rate=8000
channels=1
enabled=1
[net]
adaptive_rate_control=1
mtu=0
[sip]
ipv6_migration_done=1
use_ipv6=0
media_encryption=srtp
[rtp]
nortp_timeout=0
[sound]
echocancellation=1
remote_ring=/usr/local/share/sounds/linphone/rings/ringback.wav
local_ring=/usr/local/share/sounds/linphone/rings/oldphone.wav
You can consider this issue resolved.

Post Reply