Wtware on RPi4

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen:

BBCode is OFF
Smilies are ON

Topic review
   

Expand view Topic review: Wtware on RPi4

Re: Wtware on RPi4

by akatik » Fri Aug 16, 2019 10:42 am

Yes, we don't have it for tests and it would be great. Write me to license@wtware.com

Re: Wtware on RPi4

by Fraal » Fri Aug 16, 2019 2:27 am

Hi akatik,

Do you mean you don't have a RPi4 4GB version to test?
If so I have one I can ship you for testing, let me know!

Re: Wtware on RPi4

by akatik » Tue Aug 13, 2019 10:30 pm

Fraal wrote:
Wed Aug 07, 2019 8:11 am
Does the current build of wtware (5.8.62) support the RPi4's 4GB ram?
We have no one to test now. It will run later.

Re: Wtware on RPi4

by jazzldazzl » Mon Aug 12, 2019 9:36 pm

Fraal wrote:
Tue Aug 06, 2019 4:46 pm
One last thing to add, I configure the remote desktop settings to use lossless video setting however I have also configured it to detect network bandwidth and compress based off bandwidth, meaning some client sessions the video is pixelated and goes to lossless when image is static. Not a great experience when watching videos however the end result is a video with audio in sync and no lag\jitter. I will change host config to full lossless and then should see some changes, I'm hoping windows mode videos are perfect lossless with sound in frame sync, full screen yet to comment!
Hi Fraal,

Thanks for testing, can´t be long till I follow in your footsteps :) How did you configure the bandwidth and compress based off bandwidth?

Re: Wtware on RPi4

by Fraal » Wed Aug 07, 2019 8:11 am

Hi team,

Does the current build of wtware (5.8.62) support the RPi4's 4GB ram? Seems it only knows about 770MB, if so will this change in next build?

Cheers.
Attachments
RPi4-4GB.PNG
RPi4-4GB.PNG (104.11 KiB) Viewed 303 times

Re: Wtware on RPi4

by Fraal » Tue Aug 06, 2019 4:46 pm

One last thing to add, I configure the remote desktop settings to use lossless video setting however I have also configured it to detect network bandwidth and compress based off bandwidth, meaning some client sessions the video is pixelated and goes to lossless when image is static. Not a great experience when watching videos however the end result is a video with audio in sync and no lag\jitter. I will change host config to full lossless and then should see some changes, I'm hoping windows mode videos are perfect lossless with sound in frame sync, full screen yet to comment!

Re: Wtware on RPi4

by Fraal » Tue Aug 06, 2019 4:37 pm

Hi all,

Firstly thank you too the wtware guys for their hard work getting this out to us! Initial testing so far the results are a fantastic with a significant improvement over the RPi3 b+.

My test environment is a Windows 2016 pooled session collection, 16CPU's with 32GB of ram, no vGPU.

I configured my clients with fairly default settings as you would expect, network boot, 50ms sound buffer, 200ms redraw_delay, 32bpp, hw sound use a USB sound bar (plugged into the USB3.0 port). I use a mix of combined USB port power (2A max) for some and the official RPi 2.5A 5.1v power supply for most of the other RPi3+'s.


Using the 3 model B+ I could get youtube to play in windowed mode with around 30fps @ 1080p, full screen is unwatchable. Everything else from word processing to basic multimedia and editing is great.


With the RPi4 4GB version booting off SD (will network boot when supported) same settings, booted 30% quicker than RPi3+, no issues. Once in Windows desktop everything was very crisp with zero jitter or artifacts. YouTube played perfectly and yes, full screen works! No problems at all!
Please note I am only using a 2.5A power supply, I assume there was still power available and that the CPU wasn't throttled due to no power warning however a full 3A may improve things down the track.


This basically means I'm replacing all our RPi's with 4's however I'm waiting on the 2GB version to test first, I suspect very close results to the 4GB version. I will test the 1GB version tomorrow and update on experience, I'm not confident on seeing big improvements though!

Re: Wtware on RPi4

by jazzldazzl » Tue Aug 06, 2019 2:14 pm

Gotcha, so all in all it does what it should in terms of being a remote desktop client? Did anyone test it with watching full screen 1080p videos?

Re: Wtware on RPi4

by aka » Mon Aug 05, 2019 11:14 pm

WTware has local chrome. Write "application=chrome" in config and you get chrome without connecting to RDP server. It was broken on Pi4 in wtware 5.8.60.
In wtware 5.8.62, local chrome should run on Raspberry Pi 4.

Re: Wtware on RPi4

by jazzldazzl » Mon Aug 05, 2019 9:39 pm

Awesome! How does it not work with chrome? That you can see all apps, all browsers except for chrome?

Re: Wtware on RPi4

by Muetzenfrosch » Sat Aug 03, 2019 5:14 pm

Wow, good job! Thank you! :-)

Re: Wtware on RPi4

by akatik » Sat Aug 03, 2019 4:30 pm

We've just released 5.8.60 version for Raspberry Pi 4.
It boots and works with dual displays, but not with Chrome yet. Or with Chrome on one display for now.
It's rather hot while working. It would be better to use CPU Cooling Heatsink.
DOESN'T boot by network for now. Raspberry developers promise to fix it.

Re: Wtware on RPi4

by aaronouthier » Thu Jul 18, 2019 2:23 am

Ok, so I don’t think I’ll be able to get them a Pi 4 any time soon. Too many other things demanding my $$. If anyone is interested in trading them a new 4 GB Raspberry Pi 4 for a WTWare license, let them know.

For what it is worth, they have created a US-based forwarding service that you can ship to and it will redeliver to them quickly and securely. Contact the developers for the address if you are interested. I won’t post the address here, of course - too many darned spam bots!!

Re: Wtware on RPi4

by Muetzenfrosch » Sun Jul 14, 2019 7:37 pm

@aaronouthier I was one of the guys, who had sent a Pi 3b+ to wtware. But it took weeks to reach them. I just contacted them, and asked if I should send a Pi 4. But don't expect that to be quicker. It will again take weeks to reach them and then they can begin to work an a version supporting the Pi 4.

Re: Wtware on RPi4

by akatik » Fri Jul 12, 2019 4:23 pm

Yes, we need it, send me e-mail to license@wtware.com

Top