pt-br missing language- RPi

Requests for the next versions.
Post Reply
estefano.peroza
Posts: 10
Joined: Sat Nov 19, 2016 5:11 pm

pt-br missing language- RPi

Post by estefano.peroza » Sat Nov 19, 2016 5:24 pm

Hello there.

I have a 100-raspberries project and i will buy all the licenses from wtware.
Nonetheless, i would need some wtware information (list bellow) to appear on brazilian portuguese (pt-br) language:

1) "Please wait..." screen. When wtware is trying to connect to the server. I would need these to be translated to "Por favor, espere".
2) "User name / Password" screen. When wtware is connected to the server and needs these credentials. I would need translation to "Usuario / Senha".
3) "Press ESC to turn off the computer or press Enter to continue". I would need this to be "Pressione ESC para desligar o computador ou pressione Enter para continuar".

I am not sure if i forgot to mention some screens that would need to be updated, although these ones would be a good beggining.

I've tested the "language" parameter in configuration file to be "pt-br", "pt", "pt-br-int", but none of these seems to work out, as wtware keeps showing messages in english (p.s. the pt-br language for the KEYBOARD works fine)

Also, if it is the best way, i could change these texts by myself, if someone could tell me where they are situated and if i have such a permission.

Any help would be appreciated.

Estéfano

aka
SUPPORT
SUPPORT
Posts: 669
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: pt-br missing language- RPi

Post by aka » Sun Nov 20, 2016 2:25 pm

I have a 100-raspberries project and i will buy all the licenses from wtware.
There's no licenses for RPi.
estefano.peroza wrote:H1) "Please wait..." screen. When wtware is trying to connect to the server. I would need these to be translated to "Por favor, espere".
2) "User name / Password" screen. When wtware is connected to the server and needs these credentials. I would need translation to "Usuario / Senha".
3) "Press ESC to turn off the computer or press Enter to continue". I would need this to be "Pressione ESC para desligar o computador ou pressione Enter para continuar".
You can edit background pictures and add comments.

http://wtware.com/docs5/config.html#skin

Graphic files in C:\ProgramData\WTware\Graphic Copy "sample" folder to Graphic on SD if you store wtware configs on SD.
estefano.peroza wrote:Also, if it is the best way, i could change these texts by myself, if someone could tell me where they are situated and if i have such a permission.
There are thousand kilobytes of text in wtware. Five years ago people from http://www.thinnetworks.com.br/ made brazilian translation for wtware, but a lot of text we have changed since then. And we don't want to release partially translated build.

estefano.peroza
Posts: 10
Joined: Sat Nov 19, 2016 5:11 pm

Re: pt-br missing language- RPi

Post by estefano.peroza » Tue Nov 22, 2016 1:41 pm

Hello aka!

Thank you for your support !

I just created a folder called "sample" inside graphic in sd card, then i inserted all the images there, and set the parameter graphic=sample in config file. It worked fine for most of the images, except for the "saver" image that keeps showing the default one(the black screen "Press Esc to shutdown.."). Any idea for solving it?

Thank you !!

aka
SUPPORT
SUPPORT
Posts: 669
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: pt-br missing language- RPi

Post by aka » Tue Nov 22, 2016 4:00 pm

Are you using the latest wtware version? If so, give me the log, please. How to create log: http://wtware.com/logs.html

estefano.peroza
Posts: 10
Joined: Sat Nov 19, 2016 5:11 pm

Re: pt-br missing language- RPi

Post by estefano.peroza » Sun Dec 04, 2016 4:50 pm

Hello aka!
After updating to the last version, everything works great.
The only thing i am still working on is the "Press Esc to turn off message" that keeps showing up, even with my new company image behind it. I just wish i could eliminate it, or translate it. Any help?
Thank you so much.

aka
SUPPORT
SUPPORT
Posts: 669
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: pt-br missing language- RPi

Post by aka » Tue Dec 13, 2016 3:11 am

Please, try this:

http://pxe.ru/files/testing/201612131345.zip

In config:

turnoffmenu=on, msg:I wanna sleep!

estefano.peroza
Posts: 10
Joined: Sat Nov 19, 2016 5:11 pm

Re: pt-br missing language- RPi

Post by estefano.peroza » Wed Dec 14, 2016 10:46 pm

Hello aka !

Now it works just fine ! Thank you so much.

brunotoira

Re: pt-br missing language- RPi

Post by brunotoira » Thu Sep 21, 2017 10:47 am

could you post again the link?

Post Reply