Problems with OpenVPN version 2.5.1+

All about WTware on Raspberry. WTware works with Raspberry Pi 4, Raspberry Pi 3B+, Pi 3 and Pi 2 devices
http://www.winterminal.com
Post Reply
Overmind
Posts: 6
Joined: Thu May 28, 2020 10:56 am

Problems with OpenVPN version 2.5.1+

Post by Overmind »

Since we have updated our VPN gateway and only the new certificates support the OpenVPN version 2.5.1+, these newly created certificates apparently no longer work with WTWare.
Here the following error message appears in the bootsector (with new certificate for version 2.5.+):

File: initrfConfig.cpp
Line: 442

and in the all.log:
[initrd] [76.134497] +- Errorlevel: 1, output: | Options error: Unrecongnized option or missing or extra parameter(s) in /etc/client.conf:4: data-ciphers (2.4.7) | Use --help for more information.

With the old certificates on the new VPN gateway, the connection does not always work properly, either it is very slow or the error message: "Make sure that terminal service works on this server. Try to connect using mstsc.exe"

tested with 6.0.18-6.0.32-6.0.52/RPi
akatik
SUPPORT
SUPPORT
Posts: 565
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Problems with OpenVPN version 2.5.1+

Post by akatik »

WTware includes OpenVPN 2.4.7. As I understand, OpenVPN 2.4.7 has no "data-ciphers" option, it only appears in OpenVPN 2.5. Sorry, it's not possble to add OpenVPN 2.5 into WTware just now.
Post Reply