Driver needs firmware

All about WTware on Raspberry. WTware works with Raspberry Pi 4, Raspberry Pi 3B+, Pi 3 and Pi 2 devices
http://www.winterminal.com
Post Reply
lmarkus
Posts: 4
Joined: Thu Feb 27, 2020 5:24 pm

Driver needs firmware

Post by lmarkus »

Hello,

I'm trying to configure WTware on Raspberry 400.
When I set up the WiFi, it says Driver needs firmware, go to wtware.com/fw and download brcm\brcmfmac43456-sdio.bin
Unfortunately there is only brcmfmac43455-sdio, tried it but it doesn't work.

Thanks!
akatik
SUPPORT
SUPPORT
Posts: 520
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Driver needs firmware

Post by akatik »

Recent wtware version should work on Raspberry without external firmware.
vive
Posts: 1
Joined: Wed Nov 18, 2020 11:29 am

Re: Driver needs firmware

Post by vive »

I'm having the exact same problem on a Raspberry Pi 400 using WTware v6.0.22, works fine on the Pi 4 so I'm guessing there must be some hardware difference?
aka
SUPPORT
SUPPORT
Posts: 875
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Driver needs firmware

Post by aka »

Ups. Raspberry 400 is not Raspberry 4. Newer WiFi chip needs newer firmware?

Try this: http://wtware.com/testing/202011191726.zip

And show me the log, please.
buzz2912
Posts: 3
Joined: Wed Jan 29, 2020 4:30 pm

Re: Driver needs firmware

Post by buzz2912 »

Hi,

is Pi 400 supported now in stable?

Thanks, S. Schmid
akatik
SUPPORT
SUPPORT
Posts: 520
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Driver needs firmware

Post by akatik »

Don't know. We have no Pi 400.
Post Reply