Unable to connect to TS GW, overloading hosts

All about WTware on Raspberry. WTware works with Raspberry Pi 4, Raspberry Pi 3B+, Pi 3 and Pi 2 devices
http://www.winterminal.com
Post Reply
onatam
Posts: 4
Joined: Mon Apr 29, 2019 10:54 pm

Unable to connect to TS GW, overloading hosts

Post by onatam » Tue Aug 20, 2019 10:54 pm

As the title states, I cannot set WTWare to connect directly to our terminal server gateway, so I have to point them to a terminal server directly and then at login it will get load balanced to a server in the pool.

A quick overview of the environment:
We have 1 gateway
15 host servers (gateway not included)

I try to set the Pi's to connect to different hosts in the network to start the connection. The problem is they are always attaching to the terminal, so its takes up processes and causes issues. Is there a way to either have the Pi connect to the gateway to initiate the login, or at least have WTWare not bind to a server until login credentials are entered and then passed through?

aka
SUPPORT
SUPPORT
Posts: 678
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Unable to connect to TS GW, overloading hosts

Post by aka » Thu Aug 22, 2019 6:39 pm

1. WTware can connect to Remote Desktop Connection Broker: http://wtware.com/docs5/config.html#loadbalanceinfo RDP Connection Broker balance server loads.

2. Add to config:

Code: Select all

ask_password = on
And terminal will ask login and password before it makes TCP connection to any server.

3. If you configure your DNS to have multiple server IP's for the same A DNS record (type "nslookup google.com" and you'll see multiple IPs for the same hostname) and put this DNS name in server= config file option, wtware will initiate connection with them all and work with the fastest one. This method will balance servers load.

Post Reply