Keep RDP session alive

All about WTware on Raspberry. WTware works with Raspberry Pi 4, Raspberry Pi 3B+, Pi 3 and Pi 2 devices
http://www.winterminal.com
Post Reply
greavette
Posts: 28
Joined: Mon Jun 13, 2016 2:26 am

Keep RDP session alive

Post by greavette »

Hello Team,

I have a use case whereby one of my workstations is used my multiple employees under the same profile (user account). I currently use a raspberry Pi and I have a script that automatically logs into a windows virtual machine. I then use Cron to keep the RDP session alive. This is important for us for when we patch the windows VM during our weekend maintenance window. After reboot we want the raspberry Pi thin client to automatically reconnect for us at the workstation.

1. Does wtware have this feature?
2. Does wtware allow me console access to create a script file and add a Cron job myself?

Thank you.

akatik
SUPPORT
SUPPORT
Posts: 450
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Keep RDP session alive

Post by akatik »

1. I don't understand. Did you already try wtware? What does it do? And what should it do?
2. No.

greavette
Posts: 28
Joined: Mon Jun 13, 2016 2:26 am

Re: Keep RDP session alive

Post by greavette »

Hello,

Yes I've installed and tried wtware. I'm not sure what you don't understand for my question #1. What I'm asking for is to have my my wtware Raspberrry Pi automatically reconnect to the RDP session I've set for it.

For example, my wtware Raspberry Pi is connected to a Windows virtual machine and used throughout the day.
In the evening I patch the Windows virtual machine and reboot the VM. This disconnects the wtware Raspberry Pi that was connected to this Windows VM.
I'm not onsite so I can't go to the wtware Raspberry Pi to reconnect it to the Windows virtual machine. So I want the wtware Raspberry Pi to autoconnect to the Windows virtual machine as soon as it comes back from it's reboot.

Is there a way to set wtware to auto-reconnect to an RDP session and to keep trying to connect to this RDP session indefinitely.

Thank you.

aka
SUPPORT
SUPPORT
Posts: 745
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Keep RDP session alive

Post by aka »

greavette wrote:
Tue Sep 03, 2019 7:51 am
In the evening I patch the Windows virtual machine and reboot the VM. This disconnects the wtware Raspberry Pi that was connected to this Windows VM.
I'm not onsite so I can't go to the wtware Raspberry Pi to reconnect it to the Windows virtual machine. So I want the wtware Raspberry Pi to autoconnect to the Windows virtual machine as soon as it comes back from it's reboot.
Reproduce this problem. Boot WTware with your config, connect (let's skip full working day) to this Windows VM, then reboot the VM.

What will wtware display on sccreen?

Save and show me the log after you reboot the VM: https://wtware.com/logs.html

Perhaps

Code: Select all

onerror = 60
will do the task?

greavette
Posts: 28
Joined: Mon Jun 13, 2016 2:26 am

Re: Keep RDP session alive

Post by greavette »

Hello aka and thank you for this reply. I apologize for the delay in responding to your helpful suggestion.

I've now tested auto-connecting to a Windows VM using RDP (where I've saved a user credentials in wtware configuration). The Raspberry Pi thin client auto-connects to the windows VM successfully. I then rebooted the Windows VM. The wtware thin client then loses it's connection to the VM (naturally) and The wtware thin client says "Please Wait" message.

I then receive a warning that says "TCP/IP connection lost. Network failure?"

This messages stays on the screen past the point of the VM finishing it's reboot. I can press OK and the wtware thin client will then autoreconnect to the VM and login.

I would prefer this warning message is not displayed or is only displayed until the VM has successfully come back from it's reboot so the wtware thin client can auto-login once again. How can I disable or not stop the auto-login of wtware when this message is on the screen?

Thank you.

aka
SUPPORT
SUPPORT
Posts: 745
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Keep RDP session alive

Post by aka »

greavette wrote:
Tue Jan 07, 2020 7:19 pm
I would prefer this warning message is not displayed or is only displayed until the VM has successfully come back from it's reboot
WTware doesn't know it is in reboot. WTware will retry connection if there is no answer from RDP server, but windows in reboot answers: it accepts and closes TCP/IP connection. WTware is sure it's an error.

You may try:

onerror = quiet

https://wtware.com/docs5/config.html#onerror

Note it hides ALL errors and only prints errors into log.

greavette
Posts: 28
Joined: Mon Jun 13, 2016 2:26 am

Re: Keep RDP session alive

Post by greavette »

Excellent! Thanks very much for this quick reply. Using onerror = quiet solves my problem. Or perhaps I'll use a countdown instead so if the error is critical the operator can tell me what they see on the screen.

Thank you.

greavette
Posts: 28
Joined: Mon Jun 13, 2016 2:26 am

Re: Keep RDP session alive

Post by greavette »

is there a way to solve topics? Not sure if that's how this forum works or not.

thank you.

Post Reply