Concurrent license not activating

All about WTware on Raspberry. WTware works with Raspberry Pi 4, Raspberry Pi 3B+, Pi 3 and Pi 2 devices
http://www.winterminal.com
Post Reply
ogabrielluiz
Posts: 12
Joined: Wed Apr 03, 2019 5:45 pm

Concurrent license not activating

Post by ogabrielluiz » Fri May 17, 2019 4:27 pm

Here's the scenario:
A terminal has access to the internet when it is logged in but (I'm assuming) it doesn't have when it turns on.
The concurrent license it not activating probably because of this. Is there an alternative?

Static license is not an option due to it being tied to the MAC Address and the client using a wifi adapter to boost the reception. It would need to be tied to the adapter and those things aren't reliable enough for me to dump a license in it.


Thanks for the great software!

akatik
SUPPORT
SUPPORT
Posts: 398
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Concurrent license not activating

Post by akatik » Sat May 18, 2019 8:35 am

Reboot device? I have no better idea. License processed once before starting graphic interface. Concurrent needs internet at processing time.Static is bound to hardware and dies with it (it is replaced on request, but it's a secret).

Large (so not overheating) USB WiFi with external antenna sometimes is reliable enough...

ogabrielluiz
Posts: 12
Joined: Wed Apr 03, 2019 5:45 pm

Re: Concurrent license not activating

Post by ogabrielluiz » Mon May 20, 2019 3:49 pm

I see.

Rebooting doesn't seem to work.
I think we'll bind it to the wireless usb adapter and hope for it not to break.

Do you think it would be possible to somehow force authentication after processing time?
It would save the CLID and check it once the Raspberry and access to internet and every once in a while it would check again while logged in to the server, making it easier to activate it in all scenarios.

Thanks, Akatik!

Post Reply