Pi as a thin client to Terminal Server

All about WTware on Raspberry. Wtware works with Raspberry Pi 3 Model B and Pi 2 Model B devices
http://www.winterminal.com
Post Reply
jjnemmers
Posts: 4
Joined: Fri Feb 09, 2018 10:25 pm

Pi as a thin client to Terminal Server

Post by jjnemmers » Fri Feb 09, 2018 10:29 pm

I currently have this working but have run into a couple issues.

1. When connecting through Ethernet I get a "Connection Rejected" from the terminal server. If I connect with WiFi I get right through.
2. Whether on the login screen, lock screen, or logged in, the screensaver never turns on and the monitor never times out due to inactivity. I verified the screensaver timeout settings are correct. Is there a "Keep alive" or something that causes this to not see idol time?

akatik
SUPPORT
SUPPORT
Posts: 288
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Pi as a thin client to Terminal Server

Post by akatik » Sat Feb 10, 2018 6:23 pm

1. It's sad. Perhaps, you configured something wrong? Can not help because I don't know what you configured at all.
2. The same as before. Don't understand what you are talking about. There are at least two "login screens" - in wtware and in windows interfaces. "screen saver timeout" is absolutely mistic. Writing words is too complicated. Perhaps you better add several photos of screens with issue and configurations?

jjnemmers
Posts: 4
Joined: Fri Feb 09, 2018 10:25 pm

Re: Pi as a thin client to Terminal Server

Post by jjnemmers » Mon Feb 12, 2018 6:02 pm

To simplify what I mean since I don't have screenshots to show...I simply need the monitor to "go to sleep" when the terminal is idol. Currently even when windows server is on the lock screen the monitor stays on and active forever.


jjnemmers
Posts: 4
Joined: Fri Feb 09, 2018 10:25 pm

Re: Pi as a thin client to Terminal Server

Post by jjnemmers » Fri Feb 16, 2018 5:53 pm

OK, I got the monitor to sleep using this configuration. Thank you for the reference!! Now if I could get the first issue solved that'd be great. When I use Ethernet for connecting to my terminal server I get the following error after a long wait... "Server 192.168.110.13, port 3389: connection rejected. Make sure terminal service works on this server. Try to connect using mstsc.exe." My configuration file only has one line Server = 192.168.110.13 When switched to use wireless I connect without issue. All settings in the Raspberry Pi are standard. I changed nothing from normal configuration except monitor resolution.

jjnemmers
Posts: 4
Joined: Fri Feb 09, 2018 10:25 pm

Re: Pi as a thin client to Terminal Server

Post by jjnemmers » Fri Feb 16, 2018 11:10 pm

Figured it out...it was an issue with DHCP. For some reason it was assigning an IP of a machine we already had a reservation for. Not sure why but put in a static IP worked.

Post Reply