Audio Device Not Detected

All about WTware on Raspberry. Wtware works with Raspberry Pi 3 Model B and Pi 2 Model B devices
http://www.winterminal.com
Post Reply
ICBB
Posts: 5
Joined: Sat Dec 16, 2017 8:42 am

Audio Device Not Detected

Post by ICBB » Sat Dec 16, 2017 8:56 am

I'm new to WTware as well as Raspberry Pi. I was unable to find any existing threads with my exact issue, so here we go. RDP works perfectly fine, however I've got not audio. I'm connecting to a virtual Windows 10 desktop. I don't think that really has any basis here, but who knows. When connecting with WTware, no audio devices are detected at all. Device manager shows no audio devices whatsoever. I've tried various things I've found in the forums such as:

sound=on
sound=oss
hdmi_drive=2
*as well as a variety of other things found here and on the url within it
viewtopic.php?t=47371

I've tested the RDP connection another machine and audio redirects just fine. When I kick the Raspberry Pi session in favor of mstsc audio devices magically appear in device manager before my eyes, so this appears to be a WTware issue or the Raspberry Pi itself. I've also tested audio through hdmi and this display successfully with other devices. I'm currently borrowing a friends Raspberry Pi 3b. He never mentioned any audio issues, so I would assume the hardware is good. Has anyone experienced this before?

I'm currently trying this with v5.6.22. Any help would be appreciated.

aka
SUPPORT
SUPPORT
Posts: 628
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Audio Device Not Detected

Post by aka » Sat Dec 16, 2017 12:23 pm


ICBB
Posts: 5
Joined: Sat Dec 16, 2017 8:42 am

Re: Audio Device Not Detected

Post by ICBB » Thu Dec 21, 2017 8:14 am

I double check that I was using 'sound = on', and it appears that I have been. Below are the logs. I've looked through them, but can't find anything related to 'sound' or 'audio' apart from configuration lines. The only errors I've seen seem to be related to wifi, but wifi is working just fine. Any insight would be great. Thanks!

WTware 5.6.22
WTware 5.6.22/RPi supervisor.
[ KERNEL] [ 0.000000] Booting Linux on physical CPU 0x0
[ KERNEL] [ 0.000000] Linux version 4.9.65 (aka@c12) (gcc version 5.4.0 20160609 (Ubuntu/Linaro 5.4.0-6ubuntu1~16.04.4) ) #4 SMP Fri Dec 1 22:25:55 +04 2017
[ KERNEL] [ 0.000000] CPU: ARMv7 Processor [410fd034] revision 4 (ARMv7), cr=10c5383d
[ KERNEL] [ 0.000000] CPU: div instructions available: patching division code
[ KERNEL] [ 0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[ KERNEL] [ 0.000000] OF: fdt:Machine model: Raspberry Pi 3 Model B Rev 1.2
[ KERNEL] [ 0.000000] cma: Reserved 8 MiB at 0x3ac00000
[ KERNEL] [ 0.000000] Memory policy: Data cache writealloc
[ KERNEL] [ 0.000000] On node 0 totalpages: 242688
[ KERNEL] [ 0.000000] free_area_init_node: node 0, pgdat 80c22b40, node_mem_map ba3a1000
[ KERNEL] [ 0.000000] Normal zone: 2133 pages used for memmap
[ KERNEL] [ 0.000000] Normal zone: 0 pages reserved
[ KERNEL] [ 0.000000] Normal zone: 242688 pages, LIFO batch:31
[ KERNEL] [ 0.000000] percpu: Embedded 11 pages/cpu @ba367000 s15948 r8192 d20916 u45056
[ KERNEL] [ 0.000000] pcpu-alloc: s15948 r8192 d20916 u45056 alloc=11*4096
[ KERNEL] [ 0.000000] pcpu-alloc: [0] 0 [0] 1 [0] 2 [0] 3
[ KERNEL] [ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 240555
[ KERNEL] [ 0.000000] Kernel command line: 8250.nr_uarts=0 bcm2708_fb.fbwidth=1920 bcm2708_fb.fbheight=1080 bcm2708_fb.fbdepth=32 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000 quiet wtboot=mmc
[ KERNEL] [ 0.000000] PID hash table entries: 4096 (order: 2, 16384 bytes)
[ KERNEL] [ 0.000000] Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
[ KERNEL] [ 0.000000] Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
[ KERNEL] [ 0.000000] Memory: 941160K/970752K available (5120K kernel code, 143K rwdata, 920K rodata, 5120K init, 365K bss, 21400K reserved, 8192K cma-reserved)
[ KERNEL] [ 0.000000] Virtual kernel memory layout:
[ KERNEL] [ 0.000000] vector : 0xffff0000 - 0xffff1000 ( 4 kB)
[ KERNEL] [ 0.000000] fixmap : 0xffc00000 - 0xfff00000 (3072 kB)
[ KERNEL] [ 0.000000] vmalloc : 0xbb800000 - 0xff800000 (1088 MB)
[ KERNEL] [ 0.000000] lowmem : 0x80000000 - 0xbb400000 ( 948 MB)
[ KERNEL] [ 0.000000] modules : 0x7f000000 - 0x80000000 ( 16 MB)
[ KERNEL] [ 0.000000] .text : 0x80008000 - 0x80600000 (6112 kB)
[ KERNEL] [ 0.000000] .init : 0x80700000 - 0x80c00000 (5120 kB)
[ KERNEL] [ 0.000000] .data : 0x80c00000 - 0x80c23df8 ( 144 kB)
[ KERNEL] [ 0.000000] .bss : 0x80c25000 - 0x80c805a0 ( 366 kB)
[ KERNEL] [ 0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[ KERNEL] [ 0.000000] Hierarchical RCU implementation.
[ KERNEL] [ 0.000000] Build-time adjustment of leaf fanout to 32.
[ KERNEL] [ 0.000000] NR_IRQS:16 nr_irqs:16 16
[ KERNEL] [ 0.000000] arm_arch_timer: Architected cp15 timer(s) running at 19.20MHz (phys).
[ KERNEL] [ 0.000000] clocksource: arch_sys_counter: mask: 0xffffffffffffff max_cycles: 0x46d987e47, max_idle_ns: 440795202767 ns
[ KERNEL] [ 0.000006] sched_clock: 56 bits at 19MHz, resolution 52ns, wraps every 4398046511078ns
[ KERNEL] [ 0.000017] Switching to timer-based delay loop, resolution 52ns
[ KERNEL] [ 0.000209] Console: colour dummy device 80x30
[ KERNEL] [ 0.000222] console [tty0] enabled
[ KERNEL] [ 0.000239] Calibrating delay loop (skipped), value calculated using timer frequency.. 38.40 BogoMIPS (lpj=192000)
[ KERNEL] [ 0.000252] pid_max: default: 32768 minimum: 301
[ KERNEL] [ 0.000383] Mount-cache hash table entries: 2048 (order: 1, 8192 bytes)
[ KERNEL] [ 0.000391] Mountpoint-cache hash table entries: 2048 (order: 1, 8192 bytes)
[ KERNEL] [ 0.001227] Disabling memory control group subsystem
[ KERNEL] [ 0.001280] CPU: Testing write buffer coherency: ok
[ KERNEL] [ 0.001614] CPU0: update cpu_capacity 1024
[ KERNEL] [ 0.001621] CPU0: thread -1, cpu 0, socket 0, mpidr 80000000
[ KERNEL] [ 0.001645] Setting up static identity map for 0x100000 - 0x100034
[ KERNEL] [ 0.003154] CPU1: update cpu_capacity 1024
[ KERNEL] [ 0.003160] CPU1: thread -1, cpu 1, socket 0, mpidr 80000001
[ KERNEL] [ 0.003711] CPU2: update cpu_capacity 1024
[ KERNEL] [ 0.003717] CPU2: thread -1, cpu 2, socket 0, mpidr 80000002
[ KERNEL] [ 0.004263] CPU3: update cpu_capacity 1024
[ KERNEL] [ 0.004269] CPU3: thread -1, cpu 3, socket 0, mpidr 80000003
[ KERNEL] [ 0.004347] Brought up 4 CPUs
[ KERNEL] [ 0.004356] SMP: Total of 4 processors activated (153.60 BogoMIPS).
[ KERNEL] [ 0.004360] CPU: All CPU(s) started in HYP mode.
[ KERNEL] [ 0.004363] CPU: Virtualization extensions available.
[ KERNEL] [ 0.004900] devtmpfs: initialized
[ KERNEL] [ 0.014564] VFP support v0.3: implementor 41 architecture 3 part 40 variant 3 rev 4
[ KERNEL] [ 0.014944] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[ KERNEL] [ 0.014960] futex hash table entries: 1024 (order: 4, 65536 bytes)
[ KERNEL] [ 0.015441] pinctrl core: initialized pinctrl subsystem
[ KERNEL] [ 0.015972] NET: Registered protocol family 16
[ KERNEL] [ 0.017801] DMA: preallocated 1024 KiB pool for atomic coherent allocations
[ KERNEL] [ 0.027980] bcm2835-mbox 3f00b880.mailbox: mailbox enabled
[ KERNEL] [ 0.111147] bcm2835-dma 3f007000.dma: DMA legacy API manager at bb80f000, dmachans=0x1
[ KERNEL] [ 0.113467] usbcore: registered new interface driver usbfs
[ KERNEL] [ 0.113589] usbcore: registered new interface driver hub
[ KERNEL] [ 0.113672] usbcore: registered new device driver usb
[ KERNEL] [ 0.120122] raspberrypi-firmware soc:firmware: Attached to firmware from 2017-11-17 15:19
[ KERNEL] [ 0.122366] clocksource: Switched to clocksource arch_sys_counter
[ KERNEL] [ 0.137462] NET: Registered protocol family 2
[ KERNEL] [ 0.138034] TCP established hash table entries: 8192 (order: 3, 32768 bytes)
[ KERNEL] [ 0.138142] TCP bind hash table entries: 8192 (order: 4, 65536 bytes)
[ KERNEL] [ 0.138326] TCP: Hash tables configured (established 8192 bind 8192)
[ KERNEL] [ 0.138412] UDP hash table entries: 512 (order: 2, 16384 bytes)
[ KERNEL] [ 0.138453] UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
[ KERNEL] [ 0.138626] NET: Registered protocol family 1
[ KERNEL] [ 2.245482] workingset: timestamp_bits=14 max_order=18 bucket_order=4
[ KERNEL] [ 2.282076] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
[ KERNEL] [ 2.282089] io scheduler noop registered
[ KERNEL] [ 2.282094] io scheduler deadline registered (default)
[ KERNEL] [ 2.290875] BCM2708FB: allocated DMA memory fad10000
[ KERNEL] [ 2.290928] BCM2708FB: allocated DMA channel 0 @ bb80f000
[ KERNEL] [ 2.349540] Console: switching to colour frame buffer device 240x67
[ hotplug] [ 3.038515] Block device 179:1. No action.
[ KERNEL] [ 2.387752] bcm2835-rng 3f104000.rng: hwrng registered
[ KERNEL] [ 2.387960] vc-mem: phys_addr:0x00000000 mem_base=0x3ec00000 mem_size:0x40000000(1024 MiB)
[ KERNEL] [ 2.389103] vc-sm: Videocore shared memory driver
[ KERNEL] [ 2.393278] zram: Added device: zram0
[ KERNEL] [ 2.393341] dwc_otg: version 3.00a 10-AUG-2012 (platform bus)
[ KERNEL] [ 2.621504] Core Release: 2.80a
[ KERNEL] [ 2.621514] Setting default values for core params
[ KERNEL] [ 2.621543] Finished setting default values for core params
[ KERNEL] [ 2.821903] Using Buffer DMA mode
[ KERNEL] [ 2.821909] Periodic Transfer Interrupt Enhancement - disabled
[ KERNEL] [ 2.821913] Multiprocessor Interrupt Enhancement - disabled
[ KERNEL] [ 2.821919] OTG VER PARAM: 0, OTG VER FLAG: 0
[ KERNEL] [ 2.821946] Dedicated Tx FIFOs mode
[ KERNEL] [ 2.822544] WARN::dwc_otg_hcd_init:1032: FIQ DMA bounce buffers: virt = 0xbad04000 dma = 0xfad04000 len=9024
[ KERNEL] [ 2.822569] FIQ FSM acceleration enabled for :
[ KERNEL] [ 2.822569] Non-periodic Split Transactions
[ KERNEL] [ 2.822569] Periodic Split Transactions
[ KERNEL] [ 2.822569] High-Speed Isochronous Endpoints
[ KERNEL] [ 2.822569] Interrupt/Control Split Transaction hack enabled
[ KERNEL] [ 2.822576] dwc_otg: Microframe scheduler enabled
[ KERNEL] [ 2.822621] WARN::hcd_init_fiq:459: FIQ on core 1 at 0x80397d28
[ KERNEL] [ 2.822630] WARN::hcd_init_fiq:460: FIQ ASM at 0x8039808c length 36
[ KERNEL] [ 2.822640] WARN::hcd_init_fiq:486: MPHI regs_base at 0xbb925000
[ KERNEL] [ 2.822697] dwc_otg 3f980000.usb: DWC OTG Controller
[ KERNEL] [ 2.822731] dwc_otg 3f980000.usb: new USB bus registered, assigned bus number 1
[ KERNEL] [ 2.822761] dwc_otg 3f980000.usb: irq 62, io mem 0x00000000
[ KERNEL] [ 2.822806] Init: Port Power? op_state=1
[ KERNEL] [ 2.822810] Init: Power Port (0)
[ KERNEL] [ 2.822997] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[ KERNEL] [ 2.823008] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ KERNEL] [ 2.823015] usb usb1: Product: DWC OTG Controller
[ KERNEL] [ 2.823022] usb usb1: Manufacturer: Linux 4.9.65 dwc_otg_hcd
[ KERNEL] [ 2.823029] usb usb1: SerialNumber: 3f980000.usb
[ KERNEL] [ 2.823772] hub 1-0:1.0: USB hub found
[ KERNEL] [ 2.823808] hub 1-0:1.0: 1 port detected
[ KERNEL] [ 2.824532] dwc_otg: FIQ enabled
[ KERNEL] [ 2.824537] dwc_otg: NAK holdoff enabled
[ KERNEL] [ 2.824540] dwc_otg: FIQ split-transaction FSM enabled
[ KERNEL] [ 2.824553] Module dwc_common_port init
[ KERNEL] [ 2.824943] usbcore: registered new interface driver usbtouchscreen
[ KERNEL] [ 2.826403] bcm2835-wdt 3f100000.watchdog: Broadcom BCM2835 watchdog timer
[ KERNEL] [ 2.826829] bcm2835-cpufreq: min=600000 max=1200000
[ KERNEL] [ 2.827917] sdhost-bcm2835 3f202000.sdhost: could not get clk, deferring probe
[ KERNEL] [ 2.830401] mmc-bcm2835 3f300000.mmc: could not get clk, deferring probe
[ KERNEL] [ 2.832892] ledtrig-cpu: registered to indicate activity on CPUs
[ KERNEL] [ 2.832994] hidraw: raw HID events driver (C) Jiri Kosina
[ KERNEL] [ 2.833782] usbcore: registered new interface driver usbhid
[ KERNEL] [ 2.833788] usbhid: USB HID core driver
[ KERNEL] [ 2.836035] vchiq: vchiq_init_state: slot_zero = 0xbad80000, is_master = 0
[ KERNEL] [ 2.841072] [vc_sm_connected_init]: start
[ KERNEL] [ 2.848898] [vc_sm_connected_init]: end - returning 0
[ KERNEL] [ 2.849160] NET: Registered protocol family 17
[ KERNEL] [ 2.849316] Registering SWP/SWPB emulation handler
[ KERNEL] [ 2.849859] registered taskstats version 1
[ KERNEL] [ 2.853998] sdhost: log_buf @ bad07000 (fad07000)
[ KERNEL] [ 2.932385] mmc0: sdhost-bcm2835 loaded - DMA enabled (>1)
[ KERNEL] [ 2.934503] mmc-bcm2835 3f300000.mmc: mmc_debug:0 mmc_debug2:0
[ KERNEL] [ 2.934507] mmc-bcm2835 3f300000.mmc: DMA channel allocated
[ KERNEL] [ 2.992419] of_cfs_init
[ KERNEL] [ 2.992481] of_cfs_init: OK
[ KERNEL] [ 3.004745] Freeing unused kernel memory: 5120K
[ KERNEL] [ 3.023658] mmc1: queuing unknown CIS tuple 0x80 (2 bytes)
[ KERNEL] [ 3.025164] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)
[ KERNEL] [ 3.027656] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)
[ KERNEL] [ 3.029676] mmc0: host does not support reading read-only switch, assuming write-enable
[ KERNEL] [ 3.031154] mmc1: queuing unknown CIS tuple 0x80 (7 bytes)
[ KERNEL] [ 3.032726] mmc0: new high speed SDHC card at address e624
[ KERNEL] [ 3.033282] mmcblk0: mmc0:e624 SU08G 7.40 GiB
[ KERNEL] [ 3.038651] mmcblk0: p1
[ KERNEL] [ 3.042467] Indeed it is in host mode hprt0 = 00021501
[ hotplug] [ 3.040788] Block device 179:0. No action.
[ KERNEL] [ 3.113621] random: fast init done
[ KERNEL] [ 3.179480] mmc1: new high speed SDIO card at address 0001
[ KERNEL] [ 3.242388] usb 1-1: new high-speed USB device number 2 using dwc_otg
[ KERNEL] [ 3.242479] Indeed it is in host mode hprt0 = 00001101
[ hotplug] [ 3.298905] Block device 254:0. No action.
[ pfac] [ 3.336463] Run /sbin/initrd.
[ pfac] [ 3.336636] Ok, PID 605.
[ initrd] [ 3.339066] WTware shell 5.6.22/RPi
[ initrd] [ 3.370092] HDD/MMC/SD boot.
[ KERNEL] [ 3.472524] usb 1-1: New USB device found, idVendor=0424, idProduct=9514
[ KERNEL] [ 3.472531] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ KERNEL] [ 3.472980] hub 1-1:1.0: USB hub found
[ KERNEL] [ 3.473051] hub 1-1:1.0: 5 ports detected
[ KERNEL] [ 4.542401] usb 1-1.1: new high-speed USB device number 3 using dwc_otg
[ KERNEL] [ 4.672639] usb 1-1.1: New USB device found, idVendor=0424, idProduct=ec00
[ KERNEL] [ 4.672651] usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ KERNEL] [ 4.772394] usb 1-1.2: new low-speed USB device number 4 using dwc_otg
[ KERNEL] [ 4.920261] usb 1-1.2: New USB device found, idVendor=045e, idProduct=078c
[ KERNEL] [ 4.920273] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ KERNEL] [ 4.920281] usb 1-1.2: Product: USB Keyboard
[ KERNEL] [ 4.920288] usb 1-1.2: Manufacturer: LITEON Technology
[ KERNEL] [ 4.940583] input: LITEON Technology USB Keyboard as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.0/0003:045E:078C.0001/input/input0
[ KERNEL] [ 5.003557] hid-generic 0003:045E:078C.0001: input,hidraw0: USB HID v1.10 Keyboard [LITEON Technology USB Keyboard] on usb-3f980000.usb-1.2/input0
[ KERNEL] [ 5.102401] usb 1-1.3: new full-speed USB device number 5 using dwc_otg
[ KERNEL] [ 5.244888] usb 1-1.3: New USB device found, idVendor=22d4, idProduct=1100
[ KERNEL] [ 5.244899] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ KERNEL] [ 5.244906] usb 1-1.3: Product: Naos 3200 Mouse
[ KERNEL] [ 5.244914] usb 1-1.3: Manufacturer: Mionix Co.
[ KERNEL] [ 5.253292] input: Mionix Co. Naos 3200 Mouse as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0/0003:22D4:1100.0002/input/input1
[ initrd] [ 5.292010] Success: media /dev/mmcblk0p1 mounted to /bootmedia.
/--- FILE "/bootmedia/config.txt" -----------------------
| # For more options and information see
| # http://www.raspberrypi.org/documentatio ... fig-txt.md
| # Some settings may impact device functionality. See link above for details
| # Uncomment if you get no picture on HDMI for a default "safe" mode.
| #hdmi_safe=1
| sound = on
| # Uncomment this if your display has a black border of unused pixels visible
| # and your display can output without overscan.
| disable_overscan=1
| # Uncomment if hdmi display is not detected and composite is being output.
| #hdmi_force_hotplug=1
| # Uncomment to force a specific HDMI mode (this will force VGA).
| #hdmi_group=1
| #hdmi_mode=1
| # Force the monitor to HDMI mode so that sound will be sent over HDMI cable.
| hdmi_drive=2
| # Uncomment to increase signal to HDMI, if you have interference, blanking, or
| # no display.
| #config_hdmi_boost=4
| # Uncomment to overclock the arm. 700 MHz is the default.
| #arm_freq=800
| disable_splash=1
| #hdmi_group=2
| # 800x600: hdmi_mode=9
| # 1024x768: hdmi_mode=16
| # 1280x1024: hdmi_mode=35
| # 1360x768: hdmi_mode=39
| # 1400x1050: hdmi_mode=42
| # 1440x900: hdmi_mode=47
| # 1600x1200: hdmi_mode=51
| # 1680x1050: hdmi_mode=58
| # 1366x768: hdmi_mode=81
| # 1920x1080: hdmi_mode=82
| # 1920x1200: hdmi_mode=69
| framebuffer_depth=32
| # Uncomment for 16-bit color. It is up to two
| # times faster than default 32-bit.
| #framebuffer_depth=16
| # Enable onboard audio (HDMI or jack).
| dtparam=audio=on
| # Removes the warning overlay.
| #avoid_warnings=1
| # Additionally allows turbo when low-voltage is present.
| #avoid_warnings=2
\----------------------------------------------------
[ initrd] [ 5.306254] WTpassword present: a7957cce39891c8668f5190c19872f0f.
[ KERNEL] [ 5.323188] hid-generic 0003:22D4:1100.0002: input,hiddev0,hidraw1: USB HID v1.11 Mouse [Mionix Co. Naos 3200 Mouse] on usb-3f980000.usb-1.3/input0
[ KERNEL] [ 5.331880] input: Mionix Co. Naos 3200 Mouse as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.1/0003:22D4:1100.0003/input/input2
[ KERNEL] [ 5.404347] hid-generic 0003:22D4:1100.0003: input,hiddev0,hidraw2: USB HID v1.11 Keyboard [Mionix Co. Naos 3200 Mouse] on usb-3f980000.usb-1.3/input1
[ KERNEL] [ 6.832777] random: crng init done
/--- FILE "/bootmedia/configs/initrd.wtc" -----------------------
| [BOM]
| clientIP=*
| config=local
| setupPassword=a7957cce39891c8668f5190c19872f0f
| netmedia=wifi
| wifi_ssid=MySSID
| wifi_channel=1
| wifi_security=wpa_psk
Skip 'wifi_key='.
\----------------------------------------------------
[ initrd] [ 7.319980] Load WiFi wireless network card driver.
[ initrd] [ 7.331841] Unpack /bootmedia/packages/pi2-dbus.
[ initrd] [ 7.607654] +--- Executing "/usr/bin/dbus-daemon --system"
[ initrd] [ 7.652627] +- Errorlevel: 0, output:
File is empty.
[ initrd] [ 7.652938] +------------------------
[ initrd] [ 7.653115] Unpack /bootmedia/packages/pi2-xnet.
[ initrd] [ 8.375746] Load driver for Pi 3 onboard WiFi.
[ initrd] [ 8.375832] modprobe brcmfmac.
[ KERNEL] [ 8.475787] brcmfmac: Firmware version = wl0: Aug 29 2016 20:48:16 version 7.45.41.26 (r640327) FWID 01-4527cfab
[ KERNEL] [ 8.476523] brcmfmac: brcmf_c_preinit_dcmds: CLM version = API: 12.2 Data: 7.11.15 Compiler: 1.24.2 ClmImport: 1.24.1 Creation: 2014-05-26 10:53:55 Inc Data: 9.6.3 Inc Compiler: 1.29.4 Inc ClmImport: 1.31.4 Creation: 2016-08-29 20:46:38
[ KERNEL] [ 8.587935] brcmfmac mmc1:0001:1 eth0: renamed from wlan0
/--- FILE "/etc/wpa.conf" -----------------------
| ctrl_interface=/var/run/wpa_supplicant
| network={
Skip 'psk='.
| ssid="MySSID"
| }
\----------------------------------------------------
[ KERNEL] [ 8.632627] brcmfmac: power management disabled
[ initrd] [ 8.635377] +--- Executing "/sbin/wpa_supplicant -B -c /etc/wpa.conf -i eth0 -f /tmp/wpa_supplicant.out"
[ WPA] [ 8.651119] Successfully initialized wpa_supplicant
[ KERNEL] [ 8.701370] brcmfmac: power management disabled
[ WPA] [ 8.870085] Could not read interface p2p-dev-eth0 flags: No such device
[ initrd] [ 8.886976] +- Errorlevel: 0, output:
File is empty.
[ initrd] [ 8.888013] +------------------------
[ initrd] [ 8.895076] State SCANNING before handshake, do nothing.
[ initrd] [ 9.201996] State SCANNING before handshake, do nothing.
[ WPA] [ 9.374301] eth0: Trying to associate with 80:2a:a8:8a:bd:34 (SSID='MySSID' freq=2412 MHz)
[ WPA] [ 9.498719] eth0: Associated with 80:2a:a8:8a:bd:34
[ WPA] [ 9.509674] eth0: WPA: Key negotiation completed with 80:2a:a8:8a:bd:34 [PTK=CCMP GTK=CCMP]
[ WPA] [ 9.509819] eth0: CTRL-EVENT-CONNECTED - Connection to 80:2a:a8:8a:bd:34 completed [id=0 id_str=]
[ initrd] [ 9.513086] wpa_state=COMPLETED
[ initrd] [ 9.513194] WTpassword present: a7957cce39891c8668f5190c19872f0f.
[ initrd] [ 10.572962] dhcp: 343 bytes from 10.85.4.1.
[ initrd] [ 10.573086] 00000000:0000014300000000001100000A550401FFFFFFFF004300440143000002010600 ...C........U.......C.D.C......
[ initrd] [ 10.573161] 00000020:67458B6B00000000000000000A55042E0000000000000000B827EB9CE0D60000 gE.k.........U...........'......
[ initrd] [ 10.573231] 00000040:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 10.573299] 00000060:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 10.573367] 00000080:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 10.573454] 000000a0:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 10.573535] 000000c0:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 10.573605] 000000e0:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 12.820167] dhcp: 343 bytes from 10.85.4.1.
[ initrd] [ 12.820348] 00000000:0000014300000000001100000A550401FFFFFFFF004300440143000002010600 ...C........U.......C.D.C......
[ initrd] [ 12.820496] 00000020:67458B6B00000000000000000A55042E0000000000000000B827EB9CE0D60000 gE.k.........U...........'......
[ initrd] [ 12.820639] 00000040:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 12.820763] 00000060:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 12.820890] 00000080:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 12.821014] 000000a0:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 12.821141] 000000c0:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 12.821266] 000000e0:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 12.860097] dhcp: server address 10.85.4.1.
[ initrd] [ 12.860212] dhcp: 10.85.4.46/255.255.255.0.
[ initrd] [ 12.860319] dhcp: default gateway 10.85.4.1.
[ initrd] [ 12.860444] dhcp: DNS 10.85.4.11.
[ initrd] [ 12.860561] dhcp: DNS 9.9.9.9.
[ initrd] [ 12.860668] dhcp: TFTP = DHCP 10.85.4.1.
[ initrd] [ 12.860773] dhcp: TFTP 10.85.4.1.
[ initrd] [ 12.860880] No boot file from DHCP.
[ initrd] [ 12.860985] TFTP binary "", configs prefix "", using "/" slash.
WTC listener is active.
WTC broadcast listener is active.
Send broadcast WTCU discover.
[ initrd] [ 12.875013] Run '/sbin/httpd', log '/tmp/httpd.out', env '', pid ''.
[ pfac] [ 12.875221] Run /sbin/httpd.
[ pfac] [ 12.875605] Ok, PID 683.
[ httpd] [ 12.880488] HTTP Server, WTware 5.6.22/RPi
[ initrd] [ 12.991160] USB: 22d4:1100 .
[ initrd] [ 12.991393] USB: 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter.
[ initrd] [ 12.991540] USB: 0424:9514 Standard Microsystems Corp. SMC9514 Hub.
[ initrd] [ 12.991667] USB: 045e:078c Microsoft Corp..
[ initrd] [ 12.992307] Copy /bootmedia/configs/config.wtc to /tmp/config.wtc.
[ initrd] [ 12.995537] Common local disk config:
/--- FILE "/tmp/config.wtc" -----------------------
| [BOM]
| server=10.85.4.13
\----------------------------------------------------
/--- FILE "/etc/config.compiled" -----------------------
| [BOM]
| server=10.85.4.13
| connection
\----------------------------------------------------
[ initrd] [ 12.996417] Hostname: "wtwB827EB9CE0D6".
Everyone can control terminal by RSH.
RSH: listener is active.
Send broadcast WTCU discover.
[ httpd] [ 13.236359] Reread settings.
[ httpd] [ 13.236521] Everyone can control terminal by HTTP.
[ gm] [ 13.241286] WTware session manager 5.6.22/RPi.
[ gm] [ 13.242195] Add keyboard event2: Mionix Co. Naos 3200 Mouse.
[ gm] [ 13.242278] Add keyboard event1: Mionix Co. Naos 3200 Mouse.
[ gm] [ 13.242354] Add keyboard event0: LITEON Technology USB Keyboard.
[ gm] [ 13.242461] Display mode: 1920x1080, 32 bit, landscape, 0 Hz, modeline "", DDC enabled, connector 0.
[ gm] [ 13.277960] Framebuffer device found.
[ gm] [ 13.278048] LINELENBYTES 7680
[ gm] [ 13.278123] VLEN 8294400
[ gm] [ 13.314464] Use /lib/ui32.so.
[ gm] [ 13.419200] Run '/sbin/resolver 0xd01ac0 dns [10.85.4.13]', log '', env '', pid ''.
[ gm] [ 13.419357] Nobody can control terminal by VNC.
[ pfac] [ 13.419742] Run /sbin/resolver 0xd01ac0 dns [10.85.4.13].
[ pfac] [ 13.420567] Ok, PID 684.
[ pfac] [ 13.425079] Process pid 684 terminated, status 00000000.
[ gm] [ 13.431367] 10.85.4.13 => 10.85.4.13.
[ gm] [ 13.440876] Free ram before fork terminal client /sbin/rdpclient (session 1): 920008 Kb.
[ gm] [ 13.441039] Run '/sbin/rdpclient 1', log '/tmp/rdpclient.out', env '', pid ''.
[ pfac] [ 13.441200] Run /sbin/rdpclient 1.
[ pfac] [ 13.441670] Ok, PID 685.
[ rdpclient 685] [ 13.448936] RDP Terminal Client, WTware 5.6.22/RPi, pipe 1, pid 685.
[ rdpclient 685] [ 13.449534] Use /lib/ui32.so.
[ rdpclient 685] [ 13.451004] Make RDP session with 10.85.4.13, port 3389.
[ rdpclient 685] [ 13.451216] No username.
[ rdpclient 685] [ 13.451298] No password.
[ rdpclient 685] [ 13.451544] No PIN.
[ rdpclient 685] [ 13.451653] No domain.
[ rdpclient 685] [ 13.451737] No shell.
[ rdpclient 685] [ 13.451816] No directory.
[ rdpclient 685] [ 13.451896] Window: 1920x1080@24.
[ rdpclient 685] [ 13.451975] PFlags 0x0000002F.
[ rdpclient 685] [ 13.452053] Keyboard 00000409:00000000.
[ rdpclient 685] [ 13.452133] My hostname "wtwB827EB9CE0D6".
[ rdpclient 685] [ 13.452211] TCP: connecting to 10.85.4.13:3389.
[ rdpclient 685] [ 16.550354] Got EHOSTUNREACH.
[ rdpclient 685] [ 19.670335] Got EHOSTUNREACH.
[ rdpclient 685] [ 22.790333] Got EHOSTUNREACH.
[ rdpclient 685] [ 25.910326] Got EHOSTUNREACH.
[ rdpclient 685] [ 29.030313] Got EHOSTUNREACH.
[ rdpclient 685] [ 32.150313] Got EHOSTUNREACH.
[ rdpclient 685] [ 35.270203] Got EHOSTUNREACH.
[ rdpclient 685] [ 38.390197] Got EHOSTUNREACH.
[ rdpclient 685] [ 41.510203] Got EHOSTUNREACH.
[ rdpclient 685] [ 44.630202] Got EHOSTUNREACH.
[ rdpclient 685] [ 52.314483] TCP: connection with 10.85.4.13:3389 established.
[ rdpclient 685] [ 52.314641] Turn keepalive on.
[ rdpclient 685] [ 52.315476] Free ram after buffers allocation: 919228 KB.
[ rdpclient 685] [ 52.380594] Reconnect with TLS/SSL enabled.
[ rdpclient 685] [ 52.380700] TCP: reconnecting to 10.85.4.13:3389.
[ rdpclient 685] [ 52.485049] TCP: connection with 10.85.4.13:3389 established.
[ rdpclient 685] [ 52.485176] Turn keepalive on.
[ rdpclient 685] [ 52.588433] Server supports GFX Pipeline.
[ rdpclient 685] [ 52.588557] TLS.
[ rdpclient 685] [ 52.588639] SSL/TLS.
[ rdpclient 685] [ 52.661767] Enable font smoothing and Desktop Composition.
[ rdpclient 685] [ 52.773158] GFX codec.
[ rdpclient 685] [ 68.602886] errorInfo 0x00000000.
[ rdpclient 685] [ 69.232607] SessionId 0x00000002: UTILITY\zadmin.
[ rdpclient 685] [ 69.525559] Run 4 tile threads.
[ gm] [ 78.657777] Unknown key 276 (0x00000114) from 'Mionix Co. Naos 3200 Mouse', '/dev/input/event1'.
[ gm] [ 78.673649] Unknown key 276 (0x00000114) from 'Mionix Co. Naos 3200 Mouse', '/dev/input/event1'.

akatik
SUPPORT
SUPPORT
Posts: 265
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Audio Device Not Detected

Post by akatik » Tue Dec 26, 2017 8:27 pm

How did you manage to add "sound=on" into config.txt?

Remove "sound=on" from config.txt and add "sound=on" into configs/config.wtc, after server=10.85.4.13

ICBB
Posts: 5
Joined: Sat Dec 16, 2017 8:42 am

Re: Audio Device Not Detected

Post by ICBB » Sat Dec 30, 2017 6:35 am

It appears I've been reading the wrong forums or just incorrectly. From what I recall the instructions I've read have told me to edit the config.txt file, but that appears to be the wrong location. I'm not entirely sure what configs/config.wtc is. Are you referring to the configurator? If so, please refer to the attached pictures. I have included sound=on prior to writing to the sd card. After it didn't seem to work, I edited the config.txt file. I will continue to research how to edit configs/config.wtc, but if someone has any pointers, please let me know. Thanks.
Attachments
Configurator 2.PNG
Configurator 2.PNG (22.72 KiB) Viewed 496 times
Configurator 1.PNG
Configurator 1.PNG (22.93 KiB) Viewed 496 times

akatik
SUPPORT
SUPPORT
Posts: 265
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Audio Device Not Detected

Post by akatik » Sun Dec 31, 2017 12:58 pm

In order to use configurator, you should configure WTware on Raspberry to load config file over network (tftp or http). Press Del in the beginning of boot and enter text menu.
Now terminal is configured to store config on local SD. You can edit config on local SD from setup menu (press Del while it boot) or over web browser (open terminal IP in browser).

ICBB
Posts: 5
Joined: Sat Dec 16, 2017 8:42 am

Re: Audio Device Not Detected

Post by ICBB » Wed Jan 03, 2018 6:35 am

Well, I'm happy to report that I now have working audio. Thank you very much for steering me in the right direction. After adding 'sound=on' in the configuratIon file (hitting DEL during startup), audio is passing through now. Now for the bad news. Unfortunately the audio, when coupled with a video (say Youtube) is less than stellar (it is better than other solutions I've tried though). If I'm playing audio by itself, it appears to work just fine. So I'm guessing it's a bandwidth issue? I am wifi connected which is how I would prefer to leave it (the less wires the better). I guess this leads me to ask, can a raspberry pi3 with wtware provide a seamless audio/video experience? To be clear, this isn't going to connect to a machine streaming netflix or a machine playing PC games. Nothing like that should ever be done, but I do need it to provide a quality audio/video experience in short streaming sessions. The end goal is to make this a 'learning station' for online preschool, which is bound to have online videos and activities.

Thank you again for your assistance it getting audio working. If anyone has any thoughts on what I'm trying to further accomplish, please share.

akatik
SUPPORT
SUPPORT
Posts: 265
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Audio Device Not Detected

Post by akatik » Wed Jan 03, 2018 8:06 pm

ICBB wrote:
Wed Jan 03, 2018 6:35 am
(the less wires the better).
No. Especially onboard Wifi.
ICBB wrote:
Wed Jan 03, 2018 6:35 am
I guess this leads me to ask, can a raspberry pi3 with wtware provide a seamless audio/video experience?
RDP will not provide a seamless audio/video experience. Install Raspbian and run local video player to get better video on raspberry.

ICBB
Posts: 5
Joined: Sat Dec 16, 2017 8:42 am

Re: Audio Device Not Detected

Post by ICBB » Wed Jan 03, 2018 11:34 pm

Alright, that's about what I thought. Thank you again for all your help.

Post Reply