Sound Card Support for Raspberry Pi

All about WTware on Raspberry. Wtware works with Raspberry Pi 3 Model B and Pi 2 Model B devices
http://www.winterminal.com
Post Reply
darkthunderbird

Sound Card Support for Raspberry Pi

Post by darkthunderbird » Wed Apr 12, 2017 10:53 am

Dear WTware,

thanks for this great software. We want to use a Headset in our RPD session and now I'am looking for a compatible usb sound card our usb headset to get the microphone working.
Can you give me and maybe some others in the forum some advice?

Thank you!

akatik
SUPPORT
SUPPORT
Posts: 134
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Sound Card Support for Raspberry Pi

Post by akatik » Wed Apr 12, 2017 12:07 pm

Most of them should work. Choose the most common one. Model that is available on market for years. Without buttons.

robertvg
Posts: 21
Joined: Mon Apr 24, 2017 2:34 pm

Re: Sound Card Support for Raspberry Pi

Post by robertvg » Mon Apr 24, 2017 2:40 pm

The USB headset redirection works great, with setting: sound=on, hw:1:0 in config.txt
Normal systems sounds are coming out the jack, Skype uses the headset.

With one exception it seems: when the user unplugs the headset it looks like the server is not directly aware of it.
When you check the sound settings on the server it still thinks there is a microphone, WTware then crashes with "I'm tired' or GFX errors.
Anyway to fix this ?

Thanks

akatik
SUPPORT
SUPPORT
Posts: 134
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Sound Card Support for Raspberry Pi

Post by akatik » Mon Apr 24, 2017 4:12 pm

Trivial fix: do not unplug the headset.
We should fix it...

robertvg
Posts: 21
Joined: Mon Apr 24, 2017 2:34 pm

Re: Sound Card Support for Raspberry Pi

Post by robertvg » Tue Apr 25, 2017 12:19 pm

I'll suggest that to the user ;-)
Let me know if you need any logfiles from us.

robertvg
Posts: 21
Joined: Mon Apr 24, 2017 2:34 pm

Re: Sound Card Support for Raspberry Pi

Post by robertvg » Tue Apr 25, 2017 6:11 pm

Another challenge :-)
Our displays all have a DisplayPort input. So I bought a DeLock active HDMI-A to DisplaypPort adapter (powered by USB of the RPI) to transfer video and audio from the RPI HDMI to the display. This setup works with our notebooks but with the display connected to WTware on the RPI we do not get any sound.

On the sound page it shows the standard:
Card name: bcm2835 ALSA
Line for config file: sound=on,hw:0:0
Card name: bcm2835 ALSA
Line for config file: sound=on,hw:0:1

I have set sound=on in the Config, and hdmi_drive=2 in config.txt to force audio over the hdmi output.

Can it be WTware does not detect the audio option through the hdmi-displayport converter ?

robertvg
Posts: 21
Joined: Mon Apr 24, 2017 2:34 pm

Re: Sound Card Support for Raspberry Pi

Post by robertvg » Tue Apr 25, 2017 6:37 pm

Never mind, it works :-)
(no idea - after some reboots now we have sound)

robertvg
Posts: 21
Joined: Mon Apr 24, 2017 2:34 pm

Re: Sound Card Support for Raspberry Pi

Post by robertvg » Tue May 09, 2017 9:46 am

akatik: are these GFX errors a known bug when using headsets ?
I had another workstation with these errors. 5.4.90
Not sure if it is because of the setting: sound=on, hw:1:0
or because of: microphone = on

akatik
SUPPORT
SUPPORT
Posts: 134
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Sound Card Support for Raspberry Pi

Post by akatik » Wed May 10, 2017 8:36 am

Known bug is to lost RDP session after sound card or headset is disconnected. If not sure, show me the log.

Post Reply