Keyboard Switching

All about WTware on Raspberry. Wtware works with Raspberry Pi 3 Model B and Pi 2 Model B devices
http://www.winterminal.com
Post Reply
abtest
Posts: 14
Joined: Tue Sep 13, 2016 3:56 pm

Keyboard Switching

Post by abtest » Fri Mar 03, 2017 2:24 pm

Hello

I am using a UK Keyboard but the symbols are incorrect, if i enable key-switch and press the buttons it changes the layout but doesn't save it as every time a restart the terminal the layout goes back to the original is there anyway to permanently make the keyboard stay switched ?


VXRDanny
Posts: 5
Joined: Wed Sep 27, 2017 3:11 pm

Re: Keyboard Switching

Post by VXRDanny » Wed Nov 22, 2017 4:46 pm

This doesn't seem to fix the issue for the login prompt.

I have also tried language=en-gb,default in the config file.

but this does not work either. Any ideas?

aka
SUPPORT
SUPPORT
Posts: 573
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Keyboard Switching

Post by aka » Wed Nov 22, 2017 7:21 pm

Windows login prompt or wtware login prompt? Send screen photo if you're unsure.

VXRDanny
Posts: 5
Joined: Wed Sep 27, 2017 3:11 pm

Re: Keyboard Switching

Post by VXRDanny » Thu Nov 23, 2017 3:20 pm

This is for the wtware login.

akatik
SUPPORT
SUPPORT
Posts: 141
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Keyboard Switching

Post by akatik » Thu Nov 23, 2017 6:16 pm

language= option configure keyboard in wtware (but not windows!) login interface.

Find your keyboard layout here: http://ascii-table.com/keyboards.php

Guest

Re: Keyboard Switching

Post by Guest » Thu Nov 23, 2017 6:52 pm

OK - here is my keyboard layout - http://ascii-table.com/keyboard.php/166

I have tried, in the configuration file specified "language=en-gb", "language=en-gb,default" and "language=166", none of which change the keyboard.

Can you tell me what I need to do to make this work for the login prompt within wtware please?

Thanks,

Danny.

VXRDanny
Posts: 5
Joined: Wed Sep 27, 2017 3:11 pm

Re: Keyboard Switching

Post by VXRDanny » Thu Nov 23, 2017 6:54 pm

This is my keyboard layout - http://ascii-table.com/keyboard.php/166

I have tried the following in my configuration file
language=en-gb,default
language=en-gb
language=166

None of these work for the wtware login prompt. Can you tell me what I need to put to make this work please?

Thanks,

Danny

aka
SUPPORT
SUPPORT
Posts: 573
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Keyboard Switching

Post by aka » Thu Nov 23, 2017 9:48 pm

Try this build: http://pxe.ru/files/testing/201711232246.zip

Code: Select all

language=en-gb,default

VXRDanny
Posts: 5
Joined: Wed Sep 27, 2017 3:11 pm

Re: Keyboard Switching

Post by VXRDanny » Fri Nov 24, 2017 4:57 pm

Great- re-installing that build worked for me.

Thanks.

henczy

Re: Keyboard Switching

Post by henczy » Thu Nov 30, 2017 6:14 pm

Hi,

Just tried this build by updating 5.6.20 to 5.6.21, but UK layout didn't work.
Then I reinstalled this 5.6.21 image to the SD card, but it still doesn't work.

Can you please advise?

Thanks in advance,

Zoltan

aka
SUPPORT
SUPPORT
Posts: 573
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Keyboard Switching

Post by aka » Thu Nov 30, 2017 8:00 pm


Post Reply