OpenVpn "Linux ip link set failed"

All about WTware on Raspberry. WTware works with Raspberry Pi 4, Raspberry Pi 3B+, Pi 3 and Pi 2 devices
http://www.winterminal.com
Post Reply
MadS
Posts: 3
Joined: Fri Feb 14, 2020 8:02 pm

OpenVpn "Linux ip link set failed"

Post by MadS »

Hello wtware-Fans!

We've just tried to set up a OpenVpn connection with wtware for the first time today.

Our openvpn.cfg with embedded certs look like this at the moment

Code: Select all

dev tun
resolv-retry infinite
nobind
persist-key
persist-tun
ns-cert-type server
comp-lzo
key-direction 1
verb 1
remote xxxxx 1194
proto udp
client
auth-nocache
script-security 2
daemon

<ca>
-----BEGIN CERTIFICATE-----
MIIF7DCCA9SgAwIBAgIBATANBgkqhkiG9w0BAQsFADBRMQswCQYDVQQGDAJERTEo
MCYGA1UECgwfS09EQS.....
During start up we receive the following error:

Code: Select all

TUN/TAP device tun0 opened
/sbin/ip link set dev tun0 up mtu 1500
Linux ip link set failed: could not execute external program
If I try to execute manually the "/sbin/ip link set dev tun0 up mtu 1500" I receive

Code: Select all

/sbin/ip: error while loading shared libraries: libelf.so.1: cannot open shared object file: no such file or directory
Tipp would be appreciated :-)

Thanks a lot

Mad S
aka
SUPPORT
SUPPORT
Posts: 837
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: OpenVpn "Linux ip link set failed"

Post by aka »

It's a wtware bug. Please try wtware 5.8.90.
MadS
Posts: 3
Joined: Fri Feb 14, 2020 8:02 pm

Re: OpenVpn "Linux ip link set failed"

Post by MadS »

Thank your very much... found time to give it a try today and it works perfect!

We are big fans of the WT-Ware idea... very very good stuff...
Post Reply