Main pipe closed errors

All about WTware on Raspberry. WTware works with Raspberry Pi 4, Raspberry Pi 3B+, Pi 3 and Pi 2 devices
http://www.winterminal.com
Post Reply
onatam
Posts: 4
Joined: Mon Apr 29, 2019 10:54 pm

Main pipe closed errors

Post by onatam » Tue Sep 10, 2019 12:43 am

We have been seeing a large influx of "Main Pipe Closed" errors in our WTWare environment in one of our sites.

Our environment is two locations which connect to a gateway and the terminal servers are spread across the two sites. We have seen the issue come up in a rare occurrence but now it is happening often throughout the day. Please advise.

See attached for logs.
terminallog.txt
(52.7 KiB) Downloaded 2 times

akatik
SUPPORT
SUPPORT
Posts: 379
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Main pipe closed errors

Post by akatik » Tue Sep 10, 2019 8:47 am

Remove "sound=on, hw:1:0" line. There is no hw:1 device.

onatam
Posts: 4
Joined: Mon Apr 29, 2019 10:54 pm

Re: Main pipe closed errors

Post by onatam » Tue Sep 10, 2019 5:19 pm

Can we keep simply sound=on so that it could potentially play through a usb headset?

Webjom
Posts: 5
Joined: Tue Sep 10, 2019 10:19 am

Re: Main pipe closed errors

Post by Webjom » Wed Sep 11, 2019 9:05 pm

yes it goes but you have to enter the jack 3.5 parameter and plug it into them " sound=on, amixet:cset numid=3 1

akatik
SUPPORT
SUPPORT
Posts: 379
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Main pipe closed errors

Post by akatik » Sat Sep 14, 2019 11:32 am

On Raspberry, "sound=on" is for onboard sound via HDMI.
For USB headset, "sound=on, hw:1:0". But you should connect USB headset. With ""sound=on, hw:1:0"" and without USB headset wtware will crush trying to play sound on nonexisting device.

Post Reply