i915 driver and DisplayPort

Problems with video cards. Screen frequency refresh. Terminal speed.
Post Reply
drouven
Posts: 2
Joined: Wed Jun 05, 2019 5:13 pm

i915 driver and DisplayPort

Post by drouven » Sun Jun 23, 2019 4:31 pm

I have a strange situation

I use a HP T5740 (ATOM N280 with intel GL40 graphics).
Connect through VGA I get the normal boot menu's and can setup de videocard in WinTerminal)
Using the same thinclient and Monitor (also HP) but connected through DisplayPort there is nothing to see or configure not even the HP boot logo.
The strange situation will be that switching the monitor from HP to a IIyama and use DisplayPort solves the problem. It boots, I can enter setup through DEL and configure the graphic interface which automatically detect i915 and I must define the used port (eg DisplayPort).

I already tried to force the HP monitor to only lissen to DisplayPort but with no luck.

Changing the Thinclient to a HP T610 which uses a AMD Radeon 6320 GPU the HP monitor works fine. It detects the GPU as i915.


Any tips or tricks will be appreciated!

akatik
SUPPORT
SUPPORT
Posts: 359
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: i915 driver and DisplayPort

Post by akatik » Mon Jun 24, 2019 9:20 am

drouven wrote:
Sun Jun 23, 2019 4:31 pm
Using the same thinclient and Monitor (also HP) but connected through DisplayPort there is nothing to see or configure not even the HP boot logo.
If there is no boot logo, it's some hardware problem and I don't think wtware can fix it.

drouven
Posts: 2
Joined: Wed Jun 05, 2019 5:13 pm

Re: i915 driver and DisplayPort

Post by drouven » Mon Jun 24, 2019 6:28 pm

Hi

I already was afraid for this. Anyway thank you for your quick reply!

Post Reply