x86 Client RDP crash

Topics that doesn't fall into the categories above
Post Reply
geefox
Posts: 32
Joined: Fri Sep 29, 2017 6:43 pm

x86 Client RDP crash

Post by geefox » Wed Dec 06, 2017 4:12 pm

Hello,

today on one client there was an error which caused an disconnect from the rds session.
wtware version 5.6.22 is installed on an x86 client on harddrive

I've attached the whole logfile

best regards,
thomas

Code: Select all

[rdpclient 1102] [53790.688600] Enable font smoothing and Desktop Composition.
[rdpclient 1102] [53790.834384] GFX codec.
[rdpclient 1102] [53791.780238] rdpclient-vchan-drdynvc.cpp (  480): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[rdpclient 1102] [53791.780738] rdpclient-vchan-drdynvc.cpp (  480): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[rdpclient 1102] [53791.781147] rdpclient-vchan-drdynvc.cpp (  480): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[rdpclient 1102] [53791.781596] rdpclient-vchan-drdynvc.cpp (  480): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[rdpclient 1102] [53791.781619]      ./streamInOps.h (  313): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[rdpclient 1102] [53791.781632]  ./streamInStealer.h (   29): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[rdpclient 1102] [53791.781644] [ERROR] totalLength 29783 large then packet 20 channelId 1003.
Attachments
log.txt
(205.49 KiB) Downloaded 2 times

aka
SUPPORT
SUPPORT
Posts: 573
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: x86 Client RDP crash

Post by aka » Wed Dec 06, 2017 6:55 pm

It is the same problem as in viewtopic.php?f=23&t=48234

Tell me all changes you made to encryption so that I could reproduce error on my stand, and I'll try to fix it.

Or, if it is possible, let me to connect to this server from internet.

geefox
Posts: 32
Joined: Fri Sep 29, 2017 6:43 pm

Re: x86 Client RDP crash

Post by geefox » Thu Dec 07, 2017 10:42 am

hello,
sure, its possible to connect to this server. do you have any kind of phone number or skype?
when do you have time?

aka
SUPPORT
SUPPORT
Posts: 573
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: x86 Client RDP crash

Post by aka » Thu Dec 07, 2017 4:05 pm

Skype: wtware, Andrey Kovalev

aka
SUPPORT
SUPPORT
Posts: 573
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: x86 Client RDP crash

Post by aka » Tue Dec 12, 2017 9:34 pm

I found the source of this error. You turn on FIPS encryption. FIPS is paranoid mode for old-style native RDP encryption. WTware didn't support it before and there is no reason to support it now, when RDP can work over SSL/TLS.

Find and turn FIPS off. It is default setting for all Windows Servers. Here should be DISABLED:
Untitled1.png
Untitled1.png (72.66 KiB) Viewed 12 times
And there should be no "FIPS" anywhere:
Untitled.png
Untitled.png (56.1 KiB) Viewed 12 times
Turn On SSL/TLS in "Require use of specific security layer" to disable old-style RDP encryption.

geefox
Posts: 32
Joined: Fri Sep 29, 2017 6:43 pm

Re: x86 Client RDP crash

Post by geefox » Wed Dec 13, 2017 12:45 pm

Hello,

just configured this settings you mentioned. keep you informed if anything changes/happens

thank you very much

geefox
Posts: 32
Joined: Fri Sep 29, 2017 6:43 pm

Re: x86 Client RDP crash

Post by geefox » Wed Dec 13, 2017 3:14 pm

hey, tried to find a difference in the log files - here it is. - hopefully this is the solution :D

old login with FIPS enabled:

Code: Select all

[rdpclient 3001] [676561.152498] TCP: connecting to 10.100.101.210:3389.
[rdpclient 3001] [676561.157147] TCP: connection with 10.100.101.210:3389 established.
[rdpclient 3001] [676561.157345] Turn keepalive on.
[rdpclient 3001] [676561.157438] Free ram after buffers allocation: 913252 KB.
[rdpclient 3001] [676561.167765] Server supports GFX Pipeline.
[rdpclient 3001] [676561.173413] Process RDP server certificate.
[rdpclient 3001] [676561.173505] RDP5 encryption (X.509).
[rdpclient 3001] [676561.198718] Timezone '(UTC+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna'.
[rdpclient 3001] [676561.198878] Enable font smoothing and Desktop Composition.
[rdpclient 3001] [676561.460304] GFX codec.
and then with FIPS disabled and forced to use SSL/TLS

Code: Select all

[rdpclient 3008] [676562.503729] TCP: connecting to 10.100.101.203:3389.
[rdpclient 3008] [676562.507117] TCP: connection with 10.100.101.203:3389 established.
[rdpclient 3008] [676562.507247] Turn keepalive on.
[rdpclient 3008] [676562.507326] Free ram after buffers allocation: 913808 KB.
[rdpclient 3008] [676562.507405] Empty Balance Info.
[rdpclient 3008] [676562.514422] Reconnect with TLS/SSL enabled.
[rdpclient 3008] [676562.514514] TCP: reconnecting to 10.100.101.203:3389.
[rdpclient 3008] [676562.517183] TCP: connection with 10.100.101.203:3389 established.
[rdpclient 3008] [676562.517270] Turn keepalive on.
[rdpclient 3008] [676562.517363] Empty Balance Info.
[rdpclient 3008] [676562.530119] Server supports GFX Pipeline.
[rdpclient 3008] [676562.530227] TLS.
[rdpclient 3008] [676562.530307] SSL/TLS.
[rdpclient 3008] [676562.559736] Redirected Session ID 0x00000000.
[rdpclient 3008] [676562.587074] Timezone '(UTC+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna'.
[rdpclient 3008] [676562.587189] Enable font smoothing and Desktop Composition.
[rdpclient 3008] [676562.591720] RDP5 encryption (X.509).
[rdpclient 3008] [676562.762692] GFX codec.

Post Reply