PXE Boot does not complete/ stuck after NBP file download

WTware network boot ways - bootable floppy, DOS, PXE-loaders, BootROM chips.
Post Reply
Jasperdg
Posts: 1
Joined: Fri Jan 28, 2022 1:12 pm

PXE Boot does not complete/ stuck after NBP file download

Post by Jasperdg »

We are using an Intel NUC as thin-client. The model is NUC7CJYHN. It has a Celeron J4005 processor running at 2MHz and 2 HDMI outputs. We added 8GB memory. But PXE booting does not work/ does not complete. Network is no problem: We can find the MAC address in our DHCP leases, and booting from a WTware USB stick works fine. Also: The other 25 thin clients have no problems booting PXE. So we can conclude the server, the DHCP and network are configured correctly.
We have updated the BIOS to the latest release (JYGLKCPX.86A.0067.2021.1111.1431), and set the boot order to UEFI: LAN: PXE IP4 followed by UEFI: LAN: PXE IP6.
Upon boot the media is present and PXE boot by IP4 succeeds. Then the system gets stuck in "Downloading NBP file..."
The screen keeps flashing, and you can see "NBP file downloaded successfully".
Please help.
akatik
SUPPORT
SUPPORT
Posts: 562
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: PXE Boot does not complete/ stuck after NBP file download

Post by akatik »

Which DHCP server do you use?

Correct value for UEFI for 067 DHCP option and "next-server" is:

Code: Select all

6.0.72/bootx64.efi
Check your DHCP confgiguration.

If other 25 thin clients boot in Legacy BIOS mode, they should use wtware.pxe file instead of bootx64.efi. Legacy BIOS only works with wtware.pxe. UEFI only works with bootx64.efi. WTware DHCP automatically chooses the correct one. Other DHCPs should be configured to set correct value for different clients.
Post Reply