OpenVPN with 2FA Fails...

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen:

BBCode is OFF
Smilies are ON

Topic review
   

Expand view Topic review: OpenVPN with 2FA Fails...

Re: OpenVPN with 2FA Fails...

by bnicholas » Tue Mar 17, 2020 3:17 pm

The screenshot was sent to the support email. The log command generates errors, so I took a literal picture of the screen per the directions on the webpage. This is on a Raspberry PI 4. The error message is in my original post. The only modification to the ubuntu config file was to add the "daemon" line. When I disable the 2FA WTWare will connect since it does not have to deal with the extra user prompt.

Re: OpenVPN with 2FA Fails...

by aka » Tue Mar 17, 2020 8:57 am

OpenVPN with 2FA Fails...

by bnicholas » Tue Mar 17, 2020 5:28 am

I have been able to get the OpenVPN client to work on a ubuntu machine with our VPN server and 2FA. The VPN server uses user-auth-pass. Once the username/password are verified it sends a prompt for the user to enter the 2FA code.

With WTWare I am getting an error that says "neither stdin nor stderr are a tty device and you have neither a controlling tty nor systemd - can't ask for 'CHALLENGE: <MESSAGE>...." Exiting due to fatal error.

I am able to get the VPN to connect without 2FA, but I need to get it to work with 2FA.

Top