RemoteFX

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen:

BBCode is OFF
Smilies are ON

Topic review
   

Expand view Topic review: RemoteFX

Re: RemoteFX

by aka » Fri Oct 06, 2017 9:51 am

CKoewing wrote:If I start a remote desktop connection from our IT-Notebook to the Terminalserver, the
video playback is running smoothly, so I think RemoteFX should be activated. Right?
No.
CKoewing wrote:Or is that only because of the better protocoll implementation of MS?
Yes, if you run both on same hardware.

Re: RemoteFX

by CKoewing » Thu Oct 05, 2017 5:46 pm

If I start a remote desktop connection from our IT-Notebook to the Terminalserver, the
video playback is running smoothly, so I think RemoteFX should be activated. Right?
The RDP-Connection from the WTware Thin Client is not as smooth as the Microsoft
RDP-Session. Or is that only because of the better protocoll implementation of MS?

Re: RemoteFX

by akatik » Tue Oct 03, 2017 7:40 am

How do you understand you get RemoteFX or not RemoteFX session on Windows PC?

Re: RemoteFX

by CKoewing » Mon Oct 02, 2017 7:48 pm

In our case (Server with 2x E5-2667 v4, 128GB DDR4 & NVIDIA GPU) the video playback is not running smoothly,
but with RemoteFX-Session from another Windows-PC it is. So far it does not seem to be better than RemoteFX.

Any idea?

Re: RemoteFX

by akatik » Sat Sep 30, 2017 5:54 pm

Forget about RemoteFX. It's outdated. You already have better graphic: viewtopic.php?f=2&t=47542

Re: RemoteFX

by JNienerza » Wed Sep 27, 2017 6:31 pm

Hi,

we have configured the terminal as descripted, but remotefx will not be activated:
WTware_RemoteFX.png
WTware_RemoteFX.png (8.69 KiB) Viewed 2736 times
What's wrong?

Best regards,
Jan

RemoteFX

by aka » Wed May 13, 2015 7:20 pm

Big manual is here: http://technet.microsoft.com/en-us/libr ... 10%29.aspx

But it can be easier. Download the latest 2008 R2 SP1 (or newer). Install only Remote Desktop Session Host.
remotefx-1.png
remotefx-1.png (31.18 KiB) Viewed 17502 times
Then select "Do not require Network Level Authentication". Terminal, that received IP from DHCP, boot by network and downloaded configs by TFTP, can say nothing about him. If you want security, use smartcards.

All other default values will do.

Install, reboot. Then specify Administrative Tools - Remote Desktop Services - Remote Desktop Session Host Configuration - ... Limit Maximum Color Depth 32 bit. Remote FX works with color not less than 32 bit. And in terminal configuration file specify bpp=32.
remotefx-2.png
remotefx-2.png (11.34 KiB) Viewed 17502 times

The last one. To enable RemoteFX compression:

1. Log on to RDSH-SRV as a member of the local Administrators group.
2. Click Start, click Run, type gpedit.msc and then click OK.
3. Navigate to Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment.
4. Double-click Configure RemoteFX, click Enabled, and then click OK.
Untitled.png
Untitled.png (245.66 KiB) Viewed 17502 times
Reboot server. Connect wtware terminal to server and view terminal log. If in last log lines you'll see "RemoteFX compression.", then it works:
Untitled2.png
Untitled2.png (68.61 KiB) Viewed 17502 times

Top