RemoteFX

Have got any interesting solutions and ideas for problems with terminal servers? Looking for any solution?
aka
SUPPORT
SUPPORT
Posts: 515
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

RemoteFX

Postby aka » Wed May 13, 2015 7:20 pm

Big manual is here: http://technet.microsoft.com/en-us/libr ... 10%29.aspx

But it can be easier. Download the latest 2008 R2 SP1 (or newer). Install only Remote Desktop Session Host.
remotefx-2.png
remotefx-2.png (11.34 KiB) Viewed 14750 times


Then select "Do not require Network Level Authentication". Terminal, that received IP from DHCP, boot by network and downloaded configs by TFTP, can say nothing about him. If you want security, use smartcards.

All other default values will do.

Install, reboot. Then specify Administrative Tools - Remote Desktop Services - Remote Desktop Session Host Configuration - ... Limit Maximum Color Depth 32 bit. Remote FX works with color not less than 32 bit. And in terminal configuration file specify bpp=32.

remotefx-1.png
remotefx-1.png (31.18 KiB) Viewed 14750 times



The last one. To enable RemoteFX compression:

1. Log on to RDSH-SRV as a member of the local Administrators group.
2. Click Start, click Run, type gpedit.msc and then click OK.
3. Navigate to Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment.
4. Double-click Configure RemoteFX, click Enabled, and then click OK.

Untitled.png
Untitled.png (245.66 KiB) Viewed 14750 times


Reboot server. Connect wtware terminal to server and view terminal log. If in last log lines you'll see "RemoteFX compression.", then it works:

Untitled2.png
Untitled2.png (68.61 KiB) Viewed 14750 times

Return to “Tips and tricks”

Who is online

Users browsing this forum: No registered users and 1 guest