alternative printserver "p910nd"

All about WTware on Raspberry. Wtware works with Raspberry Pi 3 Model B and Pi 2 Model B devices
http://www.winterminal.com
Gnome

alternative printserver "p910nd"

Postby Gnome » Tue Jul 18, 2017 3:53 pm

Is there a possibility to add the simple "p910nd" printserver to a wtware installation or - thinking ahead - wouldn't it be interesting to implement it additionally or instead of more complex CUPS, LPDP or whatever is used now?

The background of my question:

A while ago I tried to connect some old matrix-printers with USB-to-parallel-cables to Raspberry-pi3-wtware-RDP-clients using the printer=USB option. After fixing a little bug by the support it worked not too bad. But quite often the printers stopp and restart only by switching them offline and online again - leaving an ugly gap within the printed line. (By the way - it all worked fine with my laserprinter. If you're interrested in details have a look at viewtopic.php?f=23&t=47581&p=76215&hilit=printserver#p76215)

As my colleagues complained, I now installed a simple and lightweight RAW-printserver called "p910nd" on a raspberry pi and it works perfect and fast with the matrix printer and the USB-to-parallel-cable (and also with the laserprinter of course). It's easy to install and only needs two entries in an config file to share a RAW-printer. But I'd rather not install a second Pi for every printer...

akatik
SUPPORT
SUPPORT
Posts: 103
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: alternative printserver "p910nd"

Postby akatik » Fri Jul 21, 2017 1:06 pm

Do you use the same USB-to-parallel-cable for wtware and for p910nd? Try to replace cables. Will "cable that require restarts with wtware" work perfect with p910nd?

akatik
SUPPORT
SUPPORT
Posts: 103
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: alternative printserver "p910nd"

Postby akatik » Sun Jul 23, 2017 8:30 am

I read p910nd source and did not find any magic, that can help USB-to-parallel-cables. Need more testing.

Please, try this build:

http://pxe.ru/files/testing/201707222329.zip

In config:

Code: Select all

printer = usb(delay 500), debug


Run configurator at any Windows machine, find Pi in the list, open "Logs" tab. Press big button to start logging. DO NOT close Configurator, DO NOT reboot Pi (or restart logging if reboot).

And wait until printer stops.

Then save the log and send to support@wtware.com

Try to change "500" value. It's delay in milliseconds. Wtware will wait every time after it sends chunk of data to printer.

Did you use bi-direction mode in p910nd?


Return to “WTware on Raspberry Pi 3 / Raspberry Pi 2”

Who is online

Users browsing this forum: No registered users and 1 guest