Network boot on 5.4.94

All about WTware on Raspberry. Wtware works with Raspberry Pi 3 Model B and Pi 2 Model B devices
http://www.winterminal.com
sadaharu
Posts: 5
Joined: Tue Jun 06, 2017 3:25 am

Network boot on 5.4.94

Postby sadaharu » Tue Jun 06, 2017 4:01 am

Hi aka,

I have a few Pis using network boot from SD card WTWare 5.4.78, and everything works perfectly. Now I want to update them to 5.4.94, and I have installed it on the server. When I create SD card for boot using the 5.4.94 Configurator (using same method and settings as 5.4.78), the only files on the SD card are bootcode.bin and the configs folder with initrd.wtc file. When I try to boot from this SD card, it stops at the colorful rainbow screen. What am I doing wrong? Should I be using the boot without SD card method?

Thanks in advance.

aka
SUPPORT
SUPPORT
Posts: 530
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Network boot on 5.4.94

Postby aka » Tue Jun 06, 2017 4:12 pm

Network boot is changed. Here is a manual: viewtopic.php?f=23&t=47807

sadaharu
Posts: 5
Joined: Tue Jun 06, 2017 3:25 am

Re: Network boot on 5.4.94

Postby sadaharu » Thu Jun 15, 2017 4:23 am

Ok I think I found what I was doing wrong. I thought that because it says after 5.4.86 DHCP option 067 is not needed for network boot, I could have some terminals running 5.4.78 and some on 5.4.94. But when I looked at the TFTP logs, the 5.4.94 terminal was still trying to get 5.4.78 boot files from the TFTP server. I temporarily changed option 067 to from "5.4.78\kernel7.img" to "5.4.94\wtware.pxe" and the 5.4.94 terminal booted properly. :D

My question now is - is it possible to have terminals on both of these versions running at the same time? I think maybe not because network boot has changed between these versions.

aka
SUPPORT
SUPPORT
Posts: 530
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Network boot on 5.4.94

Postby aka » Thu Jun 15, 2017 11:32 am

1. Raspberry firmware in new network boot scheme (native raspberry firmware, not u-boot we used in 5.4.78) ignores 067 DHCP option.
2. Wtware on Raspberry (5.4.96 ignores for sure, and as far as I remember 5.4.94 too) ignores 067 DHCP option.
3. Wtware TFTP service reads version from C:/ProgramData/WTware/Terminals/MAC-address/version.

Which DHCP and TFTP are you using?

sadaharu
Posts: 5
Joined: Tue Jun 06, 2017 3:25 am

Re: Network boot on 5.4.94

Postby sadaharu » Mon Jun 19, 2017 5:57 am

We are using Windows Server 2008 R2 DHCP and WTWare TFTP.

akatik
SUPPORT
SUPPORT
Posts: 104
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Network boot on 5.4.94

Postby akatik » Thu Jun 22, 2017 1:09 pm

sadaharu wrote:We are using Windows Server 2008 R2 DHCP and WTWare TFTP.

Our WTware TFTP should send file of a right version to Raspberry. Choose recent (5.4.96 already, install it please) version in configurator and reboot Raspberry.
And show me TFTP service log after you reboot Raspberry. Icon with a wrench in top left, then "TFTP Service".

sadaharu
Posts: 5
Joined: Tue Jun 06, 2017 3:25 am

Re: Network boot on 5.4.94

Postby sadaharu » Wed Jun 28, 2017 12:24 am

During the process of updating to 5.4.96, I realised I don't remember changing the version of the terminals last times. I changed the version to 5.4.96 up the top right of the configurator, then did the same process as last time without touching DHCP (inserted the SD card with just bootcode.bin, copied the old config.txt to the terminal mac address folder of the TFTP server) and the terminal booted perfectly to 5.4.96 :roll: :roll: :roll: I am an idiot :lol: Thanks for your help Aka :D


Return to “WTware on Raspberry Pi 3 / Raspberry Pi 2”

Who is online

Users browsing this forum: No registered users and 1 guest