"display" parameter not working

All about WTware on Raspberry. Wtware works with Raspberry Pi 3 Model B and Pi 2 Model B devices
http://www.winterminal.com
estefano.peroza
Posts: 10
Joined: Sat Nov 19, 2016 5:11 pm

"display" parameter not working

Postby estefano.peroza » Mon Mar 20, 2017 11:46 pm

Hello !!

I have many users connecting to a W2008 Server. All of them have identical settings and i am using identical hardware (raspberry, hdmi/vga conversor) to all of them.
I am having some resolution problem with one (only one) of the users. The resolution for all of the users is set automatically (by wtware maybe) to 1366x768, but in this case i am having 1024x768 no matter what i do. I tried "display" parameter but it seems not to work.
This is the log: (I put bold letter for resolution)

WTware v.5.4.72/RPi supervisor.
WTC listener is active.
WTC broadcast listener is active.
[ KERNEL] [ 0.000000] Booting Linux on physical CPU 0x0
[ KERNEL] [ 0.000000] Initializing cgroup subsys cpuset
[ KERNEL] [ 0.000000] Initializing cgroup subsys cpu
[ KERNEL] [ 0.000000] Initializing cgroup subsys cpuacct
[ KERNEL] [ 0.000000] Linux version 4.4.39 (aka@c12) (gcc version 5.4.0 20160609 (Ubuntu/Linaro 5.4.0-6ubuntu1~16.04.4) ) #29 SMP Mon Feb 6 16:10:29 +04 2017
[ KERNEL] [ 0.000000] CPU: ARMv7 Processor [410fd034] revision 4 (ARMv7), cr=10c5383d
[ KERNEL] [ 0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[ KERNEL] [ 0.000000] Machine model: Raspberry Pi 3 Model B Rev 1.2
[ KERNEL] [ 0.000000] cma: Reserved 8 MiB at 0x3a800000
[ KERNEL] [ 0.000000] Memory policy: Data cache writealloc
[ KERNEL] [ 0.000000] On node 0 totalpages: 241664
[ KERNEL] [ 0.000000] free_area_init_node: node 0, pgdat 80915640, node_mem_map b9fa6000
[ KERNEL] [ 0.000000] Normal zone: 2124 pages used for memmap
[ KERNEL] [ 0.000000] Normal zone: 0 pages reserved
[ KERNEL] [ 0.000000] Normal zone: 241664 pages, LIFO batch:31
[ KERNEL] [ 0.000000] [bcm2709_smp_init_cpus] enter (94c0->f3003010)
[ KERNEL] [ 0.000000] [bcm2709_smp_init_cpus] ncores=4
[ KERNEL] [ 0.000000] PERCPU: Embedded 11 pages/cpu @b9f6a000 s13324 r8192 d23540 u45056
[ KERNEL] [ 0.000000] pcpu-alloc: s13324 r8192 d23540 u45056 alloc=11*4096
[ KERNEL] [ 0.000000] pcpu-alloc: [0] 0 [0] 1 [0] 2 [0] 3
[ KERNEL] [ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 239540
[ KERNEL] [ 0.000000] Kernel command line: 8250.nr_uarts=1 dma.dmachans=0x7f35 bcm2708_fb.fbwidth=1024 bcm2708_fb.fbheight=768 bcm2709.boardrev=0xa22082 bcm2709.serial=0xd6d0375e smsc95xx.macaddr=B8:27:EB:D0:37:5E bcm2708_fb.fbdepth=16 bcm2708_fb.fbswap=1 bcm2709.uart_clock=48000000 vc_mem.mem_base=0x3dc00000 vc_mem.mem_size=0x3f000000 console=ttyAMA0,115200 console=tty1 quiet wtboot=mmc
[ KERNEL] [ 0.000000] PID hash table entries: 4096 (order: 2, 16384 bytes)
[ KERNEL] [ 0.000000] Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
[ KERNEL] [ 0.000000] Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
[ KERNEL] [ 0.000000] Memory: 939208K/966656K available (3807K kernel code, 169K rwdata, 1184K rodata, 4112K init, 365K bss, 19256K reserved, 8192K cma-reserved)
[ KERNEL] [ 0.000000] Virtual kernel memory layout:
[ KERNEL] [ 0.000000] vector : 0xffff0000 - 0xffff1000 ( 4 kB)
[ KERNEL] [ 0.000000] fixmap : 0xffc00000 - 0xfff00000 (3072 kB)
[ KERNEL] [ 0.000000] vmalloc : 0xbb800000 - 0xff800000 (1088 MB)
[ KERNEL] [ 0.000000] lowmem : 0x80000000 - 0xbb000000 ( 944 MB)
[ KERNEL] [ 0.000000] modules : 0x7f000000 - 0x80000000 ( 16 MB)
[ KERNEL] [ 0.000000] .text : 0x80008000 - 0x804e7f94 (4992 kB)
[ KERNEL] [ 0.000000] .init : 0x804e8000 - 0x808ec000 (4112 kB)
[ KERNEL] [ 0.000000] .data : 0x808ec000 - 0x80916560 ( 170 kB)
[ KERNEL] [ 0.000000] .bss : 0x80919000 - 0x80974588 ( 366 kB)
[ KERNEL] [ 0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[ KERNEL] [ 0.000000] Hierarchical RCU implementation.
[ KERNEL] [ 0.000000] Build-time adjustment of leaf fanout to 32.
[ KERNEL] [ 0.000000] NR_IRQS:16 nr_irqs:16 16
[ KERNEL] [ 0.000000] Architected cp15 timer(s) running at 19.20MHz (phys).
[ KERNEL] [ 0.000000] clocksource: arch_sys_counter: mask: 0xffffffffffffff max_cycles: 0x46d987e47, max_idle_ns: 440795202767 ns
[ KERNEL] [ 0.000007] sched_clock: 56 bits at 19MHz, resolution 52ns, wraps every 4398046511078ns
[ KERNEL] [ 0.000022] Switching to timer-based delay loop, resolution 52ns
[ KERNEL] [ 0.000191] Console: colour dummy device 80x30
[ KERNEL] [ 0.000368] console [tty1] enabled
[ KERNEL] [ 0.000388] Calibrating delay loop (skipped), value calculated using timer frequency.. 38.40 BogoMIPS (lpj=192000)
[ KERNEL] [ 0.000406] pid_max: default: 32768 minimum: 301
[ KERNEL] [ 0.000522] Mount-cache hash table entries: 2048 (order: 1, 8192 bytes)
[ KERNEL] [ 0.000535] Mountpoint-cache hash table entries: 2048 (order: 1, 8192 bytes)
[ KERNEL] [ 0.001368] Disabling cpuset control group subsystem
[ KERNEL] [ 0.001395] Initializing cgroup subsys io
[ KERNEL] [ 0.001419] Initializing cgroup subsys memory
[ KERNEL] [ 0.001455] Initializing cgroup subsys devices
[ KERNEL] [ 0.001471] Initializing cgroup subsys freezer
[ KERNEL] [ 0.001509] CPU: Testing write buffer coherency: ok
[ KERNEL] [ 0.001958] CPU0: update cpu_capacity 1024
[ KERNEL] [ 0.001969] CPU0: thread -1, cpu 0, socket 0, mpidr 80000000
[ KERNEL] [ 0.001979] [bcm2709_smp_prepare_cpus] enter
[ KERNEL] [ 0.002054] Setting up static identity map for 0x8240 - 0x8274
[ KERNEL] [ 0.003377] [bcm2709_boot_secondary] cpu:1 started (0) 17
[ KERNEL] [ 0.003568] [bcm2709_secondary_init] enter cpu:1
[ KERNEL] [ 0.003604] CPU1: update cpu_capacity 1024
[ KERNEL] [ 0.003609] CPU1: thread -1, cpu 1, socket 0, mpidr 80000001
[ KERNEL] [ 0.003938] [bcm2709_boot_secondary] cpu:2 started (0) 16
[ KERNEL] [ 0.004079] [bcm2709_secondary_init] enter cpu:2
[ KERNEL] [ 0.004097] CPU2: update cpu_capacity 1024
[ KERNEL] [ 0.004103] CPU2: thread -1, cpu 2, socket 0, mpidr 80000002
[ KERNEL] [ 0.004401] [bcm2709_boot_secondary] cpu:3 started (0) 18
[ KERNEL] [ 0.004530] [bcm2709_secondary_init] enter cpu:3
[ KERNEL] [ 0.004548] CPU3: update cpu_capacity 1024
[ KERNEL] [ 0.004553] CPU3: thread -1, cpu 3, socket 0, mpidr 80000003
[ KERNEL] [ 0.004606] Brought up 4 CPUs
[ KERNEL] [ 0.004628] SMP: Total of 4 processors activated (153.60 BogoMIPS).
[ KERNEL] [ 0.004635] CPU: All CPU(s) started in HYP mode.
[ KERNEL] [ 0.004641] CPU: Virtualization extensions available.
[ KERNEL] [ 0.005010] devtmpfs: initialized
[ KERNEL] [ 0.014568] VFP support v0.3: implementor 41 architecture 3 part 40 variant 3 rev 4
[ KERNEL] [ 0.014902] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[ KERNEL] [ 0.015379] pinctrl core: initialized pinctrl subsystem
[ KERNEL] [ 0.015790] NET: Registered protocol family 16
[ KERNEL] [ 0.020752] DMA: preallocated 4096 KiB pool for atomic coherent allocations
[ KERNEL] [ 0.049936] cpuidle: using governor ladder
[ KERNEL] [ 0.079954] cpuidle: using governor menu
[ KERNEL] [ 0.085802] Serial: AMBA PL011 UART driver
[ KERNEL] [ 0.085984] uart-pl011 3f201000.uart: could not find pctldev for node /soc/gpio@7e200000/uart0_pins, deferring probe
[ KERNEL] [ 0.086181] bcm2835-mbox 3f00b880.mailbox: mailbox enabled
[ KERNEL] [ 0.152479] bcm2835-dma 3f007000.dma: DMA legacy API manager at f3007000, dmachans=0x1
[ KERNEL] [ 0.152988] usbcore: registered new interface driver usbfs
[ KERNEL] [ 0.153123] usbcore: registered new interface driver hub
[ KERNEL] [ 0.153214] usbcore: registered new device driver usb
[ KERNEL] [ 0.160130] raspberrypi-firmware soc:firmware: Attached to firmware from 2016-12-09 15:11
[ KERNEL] [ 0.188114] clocksource: Switched to clocksource arch_sys_counter
[ KERNEL] [ 0.200144] NET: Registered protocol family 2
[ KERNEL] [ 0.200705] TCP established hash table entries: 8192 (order: 3, 32768 bytes)
[ KERNEL] [ 0.200817] TCP bind hash table entries: 8192 (order: 4, 65536 bytes)
[ KERNEL] [ 0.201005] TCP: Hash tables configured (established 8192 bind 8192)
[ KERNEL] [ 0.201095] UDP hash table entries: 512 (order: 2, 16384 bytes)
[ KERNEL] [ 0.201140] UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
[ KERNEL] [ 0.201339] NET: Registered protocol family 1
[ KERNEL] [ 2.329068] futex hash table entries: 1024 (order: 4, 65536 bytes)
[ KERNEL] [ 2.371321] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[ KERNEL] [ 2.371350] io scheduler noop registered
[ KERNEL] [ 2.371368] io scheduler deadline registered (default)
[ KERNEL] [ 2.375364] BCM2708FB: allocated DMA memory fac10000
[ KERNEL] [ 2.375405] BCM2708FB: allocated DMA channel 0 @ f3007000
[ KERNEL] [ 2.388045] Console: switching to colour frame buffer device 128x48
[ KERNEL] [ 2.396610] bcm2835-rng 3f104000.rng: hwrng registered
[ KERNEL] [ 2.396761] vc-cma: Videocore CMA driver
[ KERNEL] [ 2.396775] vc-cma: vc_cma_base = 0x00000000
[ KERNEL] [ 2.396783] vc-cma: vc_cma_size = 0x00000000 (0 MiB)
[ KERNEL] [ 2.396791] vc-cma: vc_cma_initial = 0x00000000 (0 MiB)
[ KERNEL] [ 2.396988] vc-mem: phys_addr:0x00000000 mem_base=0x3dc00000 mem_size:0x3f000000(1008 MiB)
[ KERNEL] [ 2.400702] vchiq: vchiq_init_state: slot_zero = 0xbac80000, is_master = 0
[ KERNEL] [ 2.405085] dwc_otg: version 3.00a 10-AUG-2012 (platform bus)
[ KERNEL] [ 2.605405] Core Release: 2.80a
[ KERNEL] [ 2.605421] Setting default values for core params
[ KERNEL] [ 2.605451] Finished setting default values for core params
[ KERNEL] [ 2.805806] Using Buffer DMA mode
[ KERNEL] [ 2.805821] Periodic Transfer Interrupt Enhancement - disabled
[ KERNEL] [ 2.805828] Multiprocessor Interrupt Enhancement - disabled
[ KERNEL] [ 2.805836] OTG VER PARAM: 0, OTG VER FLAG: 0
[ KERNEL] [ 2.805868] Dedicated Tx FIFOs mode
[ KERNEL] [ 2.806292] WARN::dwc_otg_hcd_init:1047: FIQ DMA bounce buffers: virt = 0xbac04000 dma = 0xfac04000 len=9024
[ KERNEL] [ 2.806321] FIQ FSM acceleration enabled for :
[ KERNEL] [ 2.806321] Non-periodic Split Transactions
[ KERNEL] [ 2.806321] Periodic Split Transactions
[ KERNEL] [ 2.806321] High-Speed Isochronous Endpoints
[ KERNEL] [ 2.806321] Interrupt/Control Split Transaction hack enabled
[ KERNEL] [ 2.806344] dwc_otg: Microframe scheduler enabled
[ KERNEL] [ 2.806389] WARN::hcd_init_fiq:413: FIQ on core 1 at 0x8025aa08
[ KERNEL] [ 2.806402] WARN::hcd_init_fiq:414: FIQ ASM at 0x8025ad6c length 36
[ KERNEL] [ 2.806415] WARN::hcd_init_fiq:439: MPHI regs_base at 0xbb908000
[ KERNEL] [ 2.806471] dwc_otg 3f980000.usb: DWC OTG Controller
[ KERNEL] [ 2.806506] dwc_otg 3f980000.usb: new USB bus registered, assigned bus number 1
[ KERNEL] [ 2.806539] dwc_otg 3f980000.usb: irq 62, io mem 0x00000000
[ KERNEL] [ 2.806588] Init: Port Power? op_state=1
[ KERNEL] [ 2.806595] Init: Power Port (0)
[ KERNEL] [ 2.806766] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[ KERNEL] [ 2.806780] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ KERNEL] [ 2.806791] usb usb1: Product: DWC OTG Controller
[ KERNEL] [ 2.806802] usb usb1: Manufacturer: Linux 4.4.39 dwc_otg_hcd
[ KERNEL] [ 2.806813] usb usb1: SerialNumber: 3f980000.usb
[ KERNEL] [ 2.807454] hub 1-0:1.0: USB hub found
[ KERNEL] [ 2.807494] hub 1-0:1.0: 1 port detected
[ KERNEL] [ 2.807912] dwc_otg: FIQ enabled
[ KERNEL] [ 2.807921] dwc_otg: NAK holdoff enabled
[ KERNEL] [ 2.807928] dwc_otg: FIQ split-transaction FSM enabled
[ KERNEL] [ 2.807963] Module dwc_common_port init
[ KERNEL] [ 2.810073] usbcore: registered new interface driver usbtouchscreen
[ KERNEL] [ 2.810759] bcm2835-cpufreq: min=600000 max=1200000
[ KERNEL] [ 2.813019] sdhost: log_buf @ bac07000 (fac07000)
[ KERNEL] [ 2.868164] mmc0: sdhost-bcm2835 loaded - DMA enabled (>1)
[ KERNEL] [ 2.870335] mmc-bcm2835 3f300000.mmc: mmc_debug:0 mmc_debug2:0
[ KERNEL] [ 2.870345] mmc-bcm2835 3f300000.mmc: Forcing PIO mode
[ KERNEL] [ 2.918285] hidraw: raw HID events driver (C) Jiri Kosina
[ KERNEL] [ 2.918744] usbcore: registered new interface driver usbhid
[ KERNEL] [ 2.918752] usbhid: USB HID core driver
[ KERNEL] [ 2.919172] NET: Registered protocol family 17
[ KERNEL] [ 2.919426] Registering SWP/SWPB emulation handler
[ KERNEL] [ 2.919979] registered taskstats version 1
[ KERNEL] [ 2.920039] vc-sm: Videocore shared memory driver
[ KERNEL] [ 2.920048] [vc_sm_connected_init]: start
[ KERNEL] [ 2.922659] [vc_sm_connected_init]: end - returning 0
[ KERNEL] [ 2.924829] 3f201000.uart: ttyAMA0 at MMIO 0x3f201000 (irq = 87, base_baud = 0) is a PL011 rev2
[ KERNEL] [ 2.925229] console [ttyAMA0] enabled
[ KERNEL] [ 2.928444] mmc0: host does not support reading read-only switch, assuming write-enable
[ KERNEL] [ 2.930366] mmc0: new high speed SDHC card at address 0007
[ KERNEL] [ 2.930387] Freeing unused kernel memory: 4112K (804e8000 - 808ec000)
[ KERNEL] [ 2.930765] mmcblk0: mmc0:0007 SL16G 14.5 GiB
[ KERNEL] [ 2.932028] mmcblk0: p1
[ KERNEL] [ 2.949634] mmc1: queuing unknown CIS tuple 0x80 (2 bytes)
[ KERNEL] [ 2.951346] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)
[ KERNEL] [ 2.952983] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)
[ KERNEL] [ 2.955775] mmc1: queuing unknown CIS tuple 0x80 (7 bytes)
[ KERNEL] [ 2.998163] Indeed it is in host mode hprt0 = 00021501
[ KERNEL] [ 3.041837] mmc1: new high speed SDIO card at address 0001
[ KERNEL] [ 3.178126] usb 1-1: new high-speed USB device number 2 using dwc_otg
[ KERNEL] [ 3.178249] Indeed it is in host mode hprt0 = 00001101
[ hotplug] [ 3.225514] Block device 179:0. No action.
[ hotplug] [ 3.231682] Block device 179:1. No action.
[ pfac] [ 3.234057] Run /sbin/initrd.
[ pfac] [ 3.234373] Ok, PID 545.
[ initrd] [ 3.236012] WTware shell v.5.4.72/RPi
[ initrd] [ 3.244875] Local media boot.
[ KERNEL] [ 3.378383] usb 1-1: New USB device found, idVendor=0424, idProduct=9514
[ KERNEL] [ 3.378402] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ KERNEL] [ 3.379099] hub 1-1:1.0: USB hub found
[ KERNEL] [ 3.379207] hub 1-1:1.0: 5 ports detected
[ KERNEL] [ 3.658146] usb 1-1.1: new high-speed USB device number 3 using dwc_otg
[ KERNEL] [ 3.758353] usb 1-1.1: New USB device found, idVendor=0424, idProduct=ec00
[ KERNEL] [ 3.758368] usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ KERNEL] [ 3.838143] usb 1-1.4: new low-speed USB device number 4 using dwc_otg
[ KERNEL] [ 3.942949] usb 1-1.4: New USB device found, idVendor=093a, idProduct=2510
[ KERNEL] [ 3.942964] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ KERNEL] [ 3.942976] usb 1-1.4: Product: USB OPTICAL MOUSE
[ KERNEL] [ 3.942987] usb 1-1.4: Manufacturer: PIXART
[ KERNEL] [ 3.949343] input: PIXART USB OPTICAL MOUSE as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/0003:093A:2510.0001/input/input0
[ KERNEL] [ 3.949806] hid-generic 0003:093A:2510.0001: input,hidraw0: USB HID v1.11 Mouse [PIXART USB OPTICAL MOUSE] on usb-3f980000.usb-1.4/input0
[ KERNEL] [ 4.028144] usb 1-1.5: new low-speed USB device number 5 using dwc_otg
[ KERNEL] [ 4.151478] usb 1-1.5: New USB device found, idVendor=0566, idProduct=3107
[ KERNEL] [ 4.151494] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ KERNEL] [ 4.151506] usb 1-1.5: Product: USB Keyboard
[ KERNEL] [ 4.151517] usb 1-1.5: Manufacturer:
[ KERNEL] [ 4.165098] input: USB Keyboard as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/1-1.5:1.0/0003:0566:3107.0002/input/input1
[ KERNEL] [ 4.218975] hid-generic 0003:0566:3107.0002: input,hidraw1: USB HID v1.10 Keyboard [ USB Keyboard] on usb-3f980000.usb-1.5/input0
[ KERNEL] [ 4.231750] input: USB Keyboard as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/1-1.5:1.1/0003:0566:3107.0003/input/input2
[ KERNEL] [ 4.288495] hid-generic 0003:0566:3107.0003: input,hidraw2: USB HID v1.10 Device [ USB Keyboard] on usb-3f980000.usb-1.5/input1
[ initrd] [ 4.620918] WTpassword present: 01ad7dc359caccf3c8de80cb1b9f05a4.
/--- FILE "/bootmedia/configs/initrd.wtc" -----------------------
| [BOM]
| clientIP=*
| config=local
| netmedia=wifi
| setupPassword=01ad7dc359caccf3c8de80cb1b9f05a4
| wifi_ssid=Grupo_Imediato
| wifi_channel=11
| wifi_security=wpa_psk
Skip 'wifi_key='.
\----------------------------------------------------
[ initrd] [ 6.623906] Load WiFi wireless network card driver.
[ initrd] [ 6.628852] Unpack /bootmedia/packages/pi2-dbus.
[ initrd] [ 6.701110] +--- Executing "/usr/bin/dbus-daemon --system"
[ KERNEL] [ 6.719404] random: dbus-daemon: uninitialized urandom read (12 bytes read, 96 bits of entropy available)
[ initrd] [ 6.727815] +- Errorlevel: 0, output:
[ KERNEL] [ 6.732195] random: dbus-daemon: uninitialized urandom read (12 bytes read, 96 bits of entropy available)
File is empty.
[ initrd] [ 6.728174] +------------------------
[ initrd] [ 6.728302] Unpack /bootmedia/packages/pi2-xnet.
[ initrd] [ 7.006731] Load driver for Pi 3 onboard WiFi.
[ initrd] [ 7.006805] modprobe brcmfmac.
[ KERNEL] [ 7.034590] random: nonblocking pool is initialized
[ KERNEL] [ 7.114116] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Dec 15 2015 18:10:45 version 7.45.41.23 (r606571) FWID 01-cc4eda9c
[ KERNEL] [ 7.129903] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code
[ KERNEL] [ 7.223046] brcmfmac_sdio mmc1:0001:1 eth0: renamed from wlan0
[ initrd] [ 7.262110] Copy /bootmedia/configs/wpa_supplicant.conf to /etc/wpa.conf.
[ KERNEL] [ 7.268234] brcmfmac: power management disabled
/--- FILE "/etc/wpa.conf" -----------------------
| ctrl_interface=/var/run/wpa_supplicant
| network={
| ssid="ID_GRUPOIMEDIATO"
Skip 'psk='.
| }
\----------------------------------------------------
[ initrd] [ 7.263022] +--- Executing "/sbin/wpa_supplicant -B -c /etc/wpa.conf -i eth0 -f /tmp/wpa_supplicant.out"
[ WPA] [ 7.270185] Successfully initialized wpa_supplicant
[ KERNEL] [ 7.379619] brcmfmac: brcmf_add_if: ERROR: netdev:eth0 already exists
[ KERNEL] [ 7.379635] brcmfmac: brcmf_add_if: ignore IF event
[ KERNEL] [ 7.384687] brcmfmac: power management disabled
[ KERNEL] [ 7.521553] brcmfmac: brcmf_add_if: ERROR: netdev:eth0 already exists
[ KERNEL] [ 7.521572] brcmfmac: brcmf_add_if: ignore IF event
[ WPA] [ 7.590114] Could not read interface p2p-dev-eth0 flags: No such device
[ initrd] [ 7.613395] +- Errorlevel: 0, output:
File is empty.
[ initrd] [ 7.613806] +------------------------
[ initrd] [ 7.619928] State SCANNING before handshake, do nothing.
[ initrd] [ 7.925950] State SCANNING before handshake, do nothing.
[ WPA] [ 8.091004] eth0: Trying to associate with 14:cc:20:65:1c:ed (SSID='ID_GRUPOIMEDIATO' freq=2452 MHz)
[ WPA] [ 8.180557] eth0: Associated with 14:cc:20:65:1c:ed
[ WPA] [ 8.192068] eth0: WPA: Key negotiation completed with 14:cc:20:65:1c:ed [PTK=CCMP GTK=TKIP]
[ WPA] [ 8.192177] eth0: CTRL-EVENT-CONNECTED - Connection to 14:cc:20:65:1c:ed completed [id=0 id_str=]
[ initrd] [ 8.231925] wpa_state=COMPLETED
[ initrd] [ 8.232027] WTpassword present: 01ad7dc359caccf3c8de80cb1b9f05a4.
[ initrd] [ 9.274925] dhcp: 328 bytes from 172.28.20.1.
[ initrd] [ 9.275054] 00000000:000001340000000000110000AC1C1401AC1C141B004300440134000002010600 ...4.....?...??..???.C.D.4......
[ initrd] [ 9.275130] 00000020:67458B6B0000000000000000AC1C141B0000000000000000B827EB85620B0000 gE.k.........???.........'..b...
[ initrd] [ 9.275201] 00000040:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 9.275270] 00000060:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 9.275339] 00000080:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 9.275409] 000000a0:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 9.275477] 000000c0:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 9.275546] 000000e0:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 10.790161] dhcp: 328 bytes from 172.28.20.1.
[ initrd] [ 10.790290] 00000000:000001340000000000110000AC1C1401AC1C141B004300440134000002010600 ...4.....?...??..???.C.D.4......
[ initrd] [ 10.790366] 00000020:67458B6B0000000000000000AC1C141B0000000000000000B827EB85620B0000 gE.k.........???.........'..b...
[ initrd] [ 10.790438] 00000040:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 10.790507] 00000060:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 10.790576] 00000080:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 10.790644] 000000a0:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 10.790713] 000000c0:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 10.790781] 000000e0:0000000000000000000000000000000000000000000000000000000000000000 ................................
[ initrd] [ 10.820087] dhcp: server address 172.28.20.1.
[ initrd] [ 10.820163] dhcp: 172.28.20.27/255.255.255.0.
[ initrd] [ 10.820232] dhcp: default gateway 172.28.20.1.
[ initrd] [ 10.820300] dhcp: DNS 192.168.20.1.
[ initrd] [ 10.820367] dhcp: domain grupoimediato.local.
[ initrd] [ 10.820435] dhcp: TFTP = DHCP 172.28.20.1.
[ initrd] [ 10.820502] dhcp: TFTP 172.28.20.1.
[ initrd] [ 10.820569] No boot file from DHCP.
[ initrd] [ 10.820635] TFTP binary "", configs prefix "", using "/" slash.
Send broadcast WTCU discover.
[ pfac] [ 10.822263] Run /sbin/httpd.
[ initrd] [ 10.822338] Run '/sbin/httpd', log '/tmp/httpd.out', env '', pid ''.
[ pfac] [ 10.822451] Ok, PID 607.
[ httpd] [ 10.826097] HTTP Server, WTware v.5.4.72/RPi
[ initrd] [ 10.942269] USB: 0424:9514 Standard Microsystems Corp. SMC9514 Hub.
[ initrd] [ 10.942401] USB: 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter.
[ initrd] [ 10.942475] USB: 093a:2510 Pixart Imaging, Inc. Optical Mouse.
[ initrd] [ 10.942546] USB: 0566:3107 Monterey International Corp. Keyboard.
[ initrd] [ 10.942616] Copy /bootmedia/configs/config.wtc to /tmp/config.wtc.
[ initrd] [ 10.943420] Common local disk config:
/--- FILE "/tmp/config.wtc" -----------------------
| [BOM]
| server=ts-imediato
| skin=sample
| bpp=16
| turnoffmenu=always, msg: "Aguardando tecla..."
| disk=usb
| display = 1366x768
| keyboard=pt-br
| connection
\----------------------------------------------------
/--- FILE "/etc/config.compiled" -----------------------
| [BOM]
| server=ts-imediato
| skin=sample
| bpp=16
| turnoffmenu=always, msg: "Aguardando tecla..."
| disk=usb
| display=1366x768
| keyboard=pt-br
| connection
\----------------------------------------------------
[ initrd] [ 10.961279] Hostname: "wtwB827EB85620B".
Everyone can control terminal by RSH.
RSH: listener is active.
Send broadcast WTCU discover.
[ httpd] [ 11.174884] Reread settings.
[ httpd] [ 11.175018] Everyone can control terminal by HTTP.
[ gm] [ 11.177770] WTware session manager v.5.4.72/RPi.
[ gm] [ 11.178955] Add keyboard event2: USB Keyboard.
[ gm] [ 11.179036] Add keyboard event1: USB Keyboard.
[ gm] [ 11.179110] EV_REL flag found. Add mouse event0: PIXART USB OPTICAL MOUSE.
[ gm] [ 11.179184] Display mode: 1024x768, 16 bit, 0 Hz, modeline "", DDC enabled, connector 0.
[ gm] [ 11.188742] Framebuffer device found.
[ gm] [ 11.188821] LINELENBYTES 2048
[ gm] [ 11.188895] VLEN 1572864
[ gm] [ 11.199121] Use /lib/ui16.so.
[ gm] [ 11.210486] Copy /bootmedia/graphic/sample/menu.png to /tmp/menu.png.
[ gm] [ 11.212515] Copy /bootmedia/graphic/sample/saver.png to /tmp/saver.png.
[ gm] [ 11.214536] Copy /bootmedia/graphic/sample/wait.png to /tmp/wait.png.
[ gm] [ 11.293585] Load usb storage driver.
[ gm] [ 11.293704] modprobe scsi_mod.
[ gm] [ 11.306256] modprobe usb-storage.
[ KERNEL] [ 11.313323] SCSI subsystem initialized
[ gm] [ 11.317697] modprobe sd_mod.
[ KERNEL] [ 11.324828] usbcore: registered new interface driver usb-storage
[ gm] [ 11.326723] Load EXFAT filesystem driver.
[ gm] [ 11.326870] modprobe fuse.
[ gm] [ 11.338485] modprobe exfat.
[ KERNEL] [ 11.345132] fuse init (API version 7.23)
[ KERNEL] [ 11.355155] exFAT: Version 1.2.9
[ gm] [ 11.361028] Run '/sbin/resolver 0x1d3b38 dns [ts-imediato]', log '', env '', pid ''.
[ gm] [ 11.361176] Nobody can control terminal by VNC.
[ pfac] [ 11.361388] Run /sbin/resolver 0x1d3b38 dns [ts-imediato].
[ pfac] [ 11.362007] Ok, PID 633.
[ gm] [ 11.494154] ts-imediato => 10.203.4.18.
[ gm] [ 11.494313] ts-imediato => 10.203.4.17.
[ gm] [ 11.494403] ts-imediato => 10.203.4.15.
[ gm] [ 11.494479] ts-imediato => 10.203.4.16.
[ gm] [ 11.494552] Free ram before fork terminal client /sbin/rdpclient (session 1): 916368 Kb.
[ pfac] [ 11.494627] Process pid 633 terminated, status 00000000.
[ gm] [ 11.494670] Run '/sbin/rdpclient 1', log '/tmp/rdpclient.out', env '', pid ''.
[ pfac] [ 11.494742] Run /sbin/rdpclient 1.
[ pfac] [ 11.494894] Ok, PID 634.
[ rdpclient 634] [ 11.501713] RDP Terminal Client, WTware v.5.4.72/RPi, pipe 1, pid 634.
[ rdpclient 634] [ 11.502706] Use /lib/ui16.so.
[ rdpclient 634] [ 11.504215] Make RDP session with 10.203.4.18, 10.203.4.17, 10.203.4.15, 10.203.4.16, port 3389.
[ rdpclient 634] [ 11.504316] No username.
[ rdpclient 634] [ 11.504396] No password.
[ rdpclient 634] [ 11.504516] No PIN.
[ rdpclient 634] [ 11.504658] No domain.
[ rdpclient 634] [ 11.504760] No shell.
[ rdpclient 634] [ 11.504876] No directory.
[ rdpclient 634] [ 11.504974] Window: 1024x768@16.
[ rdpclient 634] [ 11.505071] PFlags 0x0000002F.
[ rdpclient 634] [ 11.505146] Keyboard 00000416:00000000.
[ rdpclient 634] [ 11.505250] My hostname "wtwB827EB85620B".
[ rdpclient 634] [ 11.566842] TCP: connection with 10.203.4.17:3389 established.
[ rdpclient 634] [ 11.566993] Turn keepalive on.
[ rdpclient 634] [ 11.567777] Free ram after buffers allocation: 916036 KB.
[ rdpclient 634] [ 11.652417] Process RDP server certificate.
[ rdpclient 634] [ 11.652553] RDP5 encryption (X.509).

Any ideas what can be wrong?
Thanks !!!

aka
SUPPORT
SUPPORT
Posts: 513
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: "display" parameter not working

Postby aka » Tue Mar 21, 2017 1:09 am

"display=" parameter does not working on Raspberry. It's from x86 world.

On Raspberry, screen configuration in config.txt on SD card. For 1366x768:

hdmi_group=2
hdmi_mode=81

radicspeter

Re: "display" parameter not working

Postby radicspeter » Tue Mar 21, 2017 11:43 am

I set up already in the raspberry config.txt to use Full HD (hdmi_group=2
hdmi_mode=82) resolution, but still having 1366x768 resolution on my tv.

How can i set FHD to my Pi2?

aka
SUPPORT
SUPPORT
Posts: 513
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: "display" parameter not working

Postby aka » Tue Mar 21, 2017 12:08 pm

Full HD 1920x1080 is default resolution for Raspberry Pi. It should work without hdmi_group= and hdmi_mode= with good cable and good monitor.
Try Rapbian, it uses the same config.txt.

radicspeter
Posts: 7
Joined: Tue Mar 21, 2017 4:22 pm

Re: "display" parameter not working

Postby radicspeter » Tue Mar 21, 2017 4:35 pm

aka wrote:Full HD 1920x1080 is default resolution for Raspberry Pi. It should work without hdmi_group= and hdmi_mode= with good cable and good monitor.
Try Rapbian, it uses the same config.txt.

Okay, i tested all day. And now with version 5.4.78 successfull set up my resolution with config.txt.

BUT i update my server to version 5.4.82 and seems that network boot method is changed a lot!!
So i rewrite all of my 20 raspberry pi 2 sd card to boot on network successfull(with card bec RP2 network boot doesnt support at all)
I only see 2 files on my sd cards. With version 5.4.78 i have a config.txt files on my network setup rp2... and if i try to make config.txt and write to it example
hdmi_group=2
hdmi_mode=81
and save then my RP2 can not boot, just flashes green lights 3 times loop....so serious resolution problem is appeared in the latest version!! :!:

Hope you can help me.

In the next versions, can i update rp2 wtware versions with network if i now using 5.4.82 with network boot setup?
Thanks aka master!

aka
SUPPORT
SUPPORT
Posts: 513
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: "display" parameter not working

Postby aka » Tue Mar 21, 2017 8:27 pm

I only see 2 files on my sd cards.


What are these files? I know one file: bootcode.bin

If you place config.txt on "network boot" SD, you receive non-boot SD.

If you really really really need to edit config.txt, follow these steps:
1. Open C:\Program Files (x86)\WTware\TFTPDROOT\5.4.82\pi2\localboot\ directory
2. Copy file config.txt into C:\ProgramData\WTware\Terminals\{Your RPi MAC-address}\ directory
3. Edit config.txt file in C:\ProgramData\WTware\Terminals\{Your RPi MAC-address}\

radicspeter
Posts: 7
Joined: Tue Mar 21, 2017 4:22 pm

Re: "display" parameter not working

Postby radicspeter » Tue Mar 21, 2017 11:51 pm

aka wrote:
I only see 2 files on my sd cards.


What are these files? I know one file: bootcode.bin

If you place config.txt on "network boot" SD, you receive non-boot SD.

If you really really really need to edit config.txt, follow these steps:
1. Open C:\Program Files (x86)\WTware\TFTPDROOT\5.4.82\pi2\localboot\ directory
2. Copy file config.txt into C:\ProgramData\WTware\Terminals\{Your RPi MAC-address}\ directory
3. Edit config.txt file in C:\ProgramData\WTware\Terminals\{Your RPi MAC-address}\


Yes bootcode.bin and config folder file :) Sorry i mean this two file... You are true.
:wink: Thank you so much!

1.)
When i made some log from TFTP files request when i boot up my RP2 with the latest version of wtware...
15-27-23-695| [TFTP] "config.txt": "C:\Program Files (x86)\WTware\TFTPDROOT\5.4.82\pi2\localboot\config.txt".
So every time when i boot up, my RP2 recieve config.txt from x.x.xx\pi2\localboot\config.txt".
So i write my resolution parameter to this place into config.txt and now it's working good. Question is that every RP2 use this resolution in default now?

2.)
In this TFTP log i found that some files are not found during boot up...
15-27-20-523| [TFTP] "autoboot.txt": file not found: "C:\Program Files (x86)\WTware\TFTPDROOT\autoboot.txt".
15-27-20-585| [TFTP] "recovery.elf": file not found: "C:\Program Files (x86)\WTware\TFTPDROOT\recovery.elf".
15-27-23-710| [TFTP] "dt-blob.bin[": file not found....
15-27-23-929| [TFTP] "bootcfg.txt": file not found: "C:\Program Files (x86)\WTware\TFTPDROOT\bootcfg.txt".
15-27-24-023| [TFTP] "recovery7.img": file not found: "C:\Program Files (x86)\WTware\TFTPDROOT\recovery7.img".
15-27-24-039| [TFTP] "recovery.img": file not found: "C:\Program Files (x86)\WTware\TFTPDROOT\recovery.img".
15-27-24-117| [TFTP] "armstub.bin": file not found: "C:\Program Files (x86)\WTware\TFTPDROOT\armstub.bin".

Boot up succesfull but is it normal if these files missing?
Thanks, your answer! :)

aka
SUPPORT
SUPPORT
Posts: 513
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: "display" parameter not working

Postby aka » Wed Mar 22, 2017 1:34 pm

So i write my resolution parameter to this place into config.txt and now it's working good. Question is that every RP2 use this resolution in default now?


Yes, file in Program Files will be default for all RPis. If you want to separate config.txt for one machine, put it to C:\ProgramData\WTware\Terminals\{Your RPi MAC-address}\

Boot up succesfull but is it normal if these files missing?


Yes.

radicspeter
Posts: 7
Joined: Tue Mar 21, 2017 4:22 pm

Re: "display" parameter not working

Postby radicspeter » Wed Mar 22, 2017 11:20 pm

aka wrote:
So i write my resolution parameter to this place into config.txt and now it's working good. Question is that every RP2 use this resolution in default now?


Yes, file in Program Files will be default for all RPis. If you want to separate config.txt for one machine, put it to C:\ProgramData\WTware\Terminals\{Your RPi MAC-address}\

Boot up succesfull but is it normal if these files missing?


Yes.


Thanks! I write my thesis this time, about WTware as the best alternative thin client solution for Raspberry Pi!

It is soo amazed me how fast with this device. Compared offical Raspbian OS with Remmina RDP gui the video playback soo much better in WTware!! Nice work aka!! I guess how you managed RP2 memory splitting? I see device web page, that we have almost 1Gb available allocated RAM. So GPU use similar as default in Raspbian 64 Mb.

+1 Interesting question! How can i compare Remmina and WTware RDP connection speed (i know WTware have a builtin test) ? Or how compare any other parameters...like i mentioned video playback (youtube) smoothness

As always, thanks aka your answers! You made my day!


Return to “WTware on Raspberry Pi 3 / Raspberry Pi 2”

Who is online

Users browsing this forum: No registered users and 2 guests