VNC session dropping

All about WTware on Raspberry. Wtware works with Raspberry Pi 3 Model B and Pi 2 Model B devices
http://www.winterminal.com
brunoadr
Posts: 19
Joined: Mon May 25, 2015 4:41 pm

VNC session dropping

Postby brunoadr » Fri Dec 16, 2016 4:45 pm

Hey guys, hey aka! Happy holidays!

I have a strange problem with 5.4.66 (that was happening with 5.4.62 too!). The VNC sessions ends abruptly and a blue screen appears with the message - "I'm tired"

If the user press ENTER, or hit OK, the session reconnects with no problem. This is happening every 20 minutes, more or less. I attached the logs of the WTware client.

Thanks!
Attachments
log5466.txt
(28 KiB) Downloaded 23 times

aka
SUPPORT
SUPPORT
Posts: 487
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: VNC session dropping

Postby aka » Sun Dec 18, 2016 2:09 am

Please, try this::

http://pxe.ru/files/testing/201612180308.zip

And send me same log after session dropping again.

brunoadr
Posts: 19
Joined: Mon May 25, 2015 4:41 pm

Re: VNC session dropping

Postby brunoadr » Mon Dec 19, 2016 4:11 pm

Will do this, and come back with the results... thanks aka

brunoadr
Posts: 19
Joined: Mon May 25, 2015 4:41 pm

Re: VNC session dropping

Postby brunoadr » Tue Dec 20, 2016 8:48 pm

here are the logs after some drops.

Just trying to help here, but it seems that whenever there's too much mouse usage, or some "effects" on screen, like a website with some sort of flash animation, this happens.

thanks aka.
Attachments
log5467.txt
(26.51 KiB) Downloaded 28 times

aka
SUPPORT
SUPPORT
Posts: 487
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: VNC session dropping

Postby aka » Tue Dec 20, 2016 10:32 pm

1. It's 5.4.66 version. Not 5.4.67 from my link.
2. It's another error. Not related to previous log.

Which VNC server you use? Name, version, host OS, configuration if something changed.

brunoadr
Posts: 19
Joined: Mon May 25, 2015 4:41 pm

Re: VNC session dropping

Postby brunoadr » Wed Dec 21, 2016 2:04 pm

Hi aka, sorry about my mistakes. I attached the logs with the error running 5.4.67.

The scenario didnt change, here's what I have configured here - Centos 7 server with TigerVNC (https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-vnc-remote-access-for-the-gnome-desktop-on-centos-7).

Do you think it could be my Linux VNC setup the problem?
Attachments
log5467-real.txt
(25.79 KiB) Downloaded 21 times

brunoadr
Posts: 19
Joined: Mon May 25, 2015 4:41 pm

Re: VNC session dropping

Postby brunoadr » Wed Dec 21, 2016 7:43 pm

Aka, I think my setup was indeed the failure point.

Turns out, if I load a VNC session with "depth 16" the problem does not happens! it only happens when I work with 32 bits sessions.

So, I configured the server to load 16 bits sessions, and edited config.txt to set framebuffer_depth=16.

When I did this, the problem stoped. I still wanna do some more tests, and will post here the results.

As always, thanks for the help aka!

aka
SUPPORT
SUPPORT
Posts: 487
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: VNC session dropping

Postby aka » Thu Dec 22, 2016 7:41 am

I installed tigervncserver_1.7.0-1ubuntu1_i386.deb on my Ubuntu, connected in 32-bit color and run youtube in chromium for an hour. No errors :( Please, try to find exactly, which "effect" brokes session.
All errors in logs are different. Data stream broke before wtware detect error. It looks like wtware problem, but I should reproduce it to fix.


Return to “WTware on Raspberry Pi 3 / Raspberry Pi 2”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest