Turning off wireless power management

All about WTware on Raspberry. Wtware works with Raspberry Pi 3 Model B and Pi 2 Model B devices
http://www.winterminal.com
vincny
Posts: 21
Joined: Tue Nov 01, 2016 9:58 am

Turning off wireless power management

Postby vincny » Thu Nov 17, 2016 6:00 am

Hi Aka,

Thanks again, the wireless authentication is now working, but I hit another issue that it will turn off by itself when the rpi session is idling
I have do some read out and this could the potential cause:
http://raspberrypi.stackexchange.com/qu ... nt-setting

1. Upgrade the wireless firmware
sudo BRANCH=next rpi-update

2. Turn off power management.
sudo iwconfig wlan0 power off

Can this be integrate to WTware?
Again your help is very much appreciated.

Additional link info:
It also mention on the be link that it will improve the wireless self turn off and performance issue.

https://www.raspberrypi.org/forums/view ... 7&p=924657

Thanks,
Ken
Attachments
iwconfig.jpg
iwconfig.jpg (200.25 KiB) Viewed 1833 times

aka
SUPPORT
SUPPORT
Posts: 488
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Turning off wireless power management

Postby aka » Fri Nov 18, 2016 12:49 pm

Please try: http://pxe.ru/files/testing/201611181321.zip
You can see iwconfig output on embedded web server.

vincny
Posts: 21
Joined: Tue Nov 01, 2016 9:58 am

Re: Turning off wireless power management

Postby vincny » Fri Nov 18, 2016 3:21 pm

Hi Aka,

I was wrong, I still get disconnected after the power management was turn off. :(

Thanks,
Ken

aka
SUPPORT
SUPPORT
Posts: 488
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Turning off wireless power management

Postby aka » Fri Nov 18, 2016 8:57 pm

Signal level is low. Try USB WiFi with external antenna.

Guest

Re: Turning off wireless power management

Postby Guest » Tue Nov 22, 2016 2:51 pm

Hi Aka,

Just want to keep you updated.

1. Turning off wireless power management does help to improve rpi 3 wireless connection please keep the setting.
2. After further checking I realize that the connection drop off due to timeout session configure from wireless lan controller.
3. I have further fine tune the wpa_supplication and the wireless connection seem to be more stable now.

ctrl_interface=/var/run/wpa_supplicant
network={
ssid="coyssid"
scan_ssid=1
proto=RSN
key_mgmt=WPA-EAP
pairwise=CCMP
eap=PEAP
identity="myusername"
password="mypassword"
phase2="auth=MSCHAPV2"
priority=1
}

Thanks,
Ken

vincny
Posts: 21
Joined: Tue Nov 01, 2016 9:58 am

Re: Turning off wireless power management

Postby vincny » Tue Nov 22, 2016 2:54 pm

Hi Aka,

Just to keep you updated:

1. Turn off wireless power management does improve rpi 3wireless connection, please keep the setting.
2. The disconnection was cause by wireless lan controller session timeout setting.
3. I am fine tuning the wpa_supplication config file seem to connect better now, still monitoring the outcome.

My wpa_supplication config

ctrl_interface=/var/run/wpa_supplicant
network={
ssid="coyssid"
scan_ssid=1
proto=RSN
key_mgmt=WPA-EAP
pairwise=CCMP
eap=PEAP
identity="myusername"
password="mypassword"
phase2="auth=MSCHAPV2"
priority=1
}

Thanks,
Ken

aka
SUPPORT
SUPPORT
Posts: 488
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Turning off wireless power management

Postby aka » Tue Nov 22, 2016 4:00 pm

vincny wrote:1. Turn off wireless power management does improve rpi 3wireless connection, please keep the setting.

Ok. It will be in 5.4.62 and the following versions.


Return to “WTware on Raspberry Pi 3 / Raspberry Pi 2”

Who is online

Users browsing this forum: No registered users and 2 guests