Display settings, power

All about WTware on Raspberry. Wtware works with Raspberry Pi 3 Model B and Pi 2 Model B devices
http://www.winterminal.com
PedroMC
Posts: 6
Joined: Fri Nov 04, 2016 12:54 pm

Display settings, power

Postby PedroMC » Fri Nov 04, 2016 1:07 pm

Hello, i'm new to testing Wtware, would like to ask some help from the experts..

What is happening is that, i can boot properly perfectly from a RPi3, but the first time i turn on the power, or everytime i plug off the power cable, i can't get an image, everything boots up and i see the NIC lights, and it goes to the server (i know because i can see it in the wtware server), but only when i use the option restart terminal server, the Rpi3 reboots and the display gets the correct definitions from the wtwareserver template.

What we have done to remediate, is to check in setup which are the defs geting from server and then force it on config.txt on sdcard.


Aditionally i would like to know how to boot RPi3 without the SDCard, it is possible? Only can be done by installing debian light ? Some lights would be cool

Thank you

PedroMC
Posts: 6
Joined: Fri Nov 04, 2016 12:54 pm

Re: Display settings, power

Postby PedroMC » Fri Nov 04, 2016 2:34 pm

I have another question .. When the terminal is on Login screen, it keeps going away for like 1 second and it comes back. why is this?
This stops happening as soon as i login in to the terminal.

Best regards.

aka
SUPPORT
SUPPORT
Posts: 484
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Display settings, power

Postby aka » Sat Nov 05, 2016 9:53 pm

viewtopic.php?f=23&t=47486
Please, read it: http://wtware.com/logs.html
For everything you want to get comments, please, get terminal log. Boot device, got the issue, save log, send to us to support@wtware.com.

PedroMC
Posts: 6
Joined: Fri Nov 04, 2016 12:54 pm

Re: Display settings, power

Postby PedroMC » Mon Nov 07, 2016 2:50 pm

[ rdpclient 605] [ 41.793709] errorInfo 0x00000000.
[ rdpclient 605] [ 41.794314] Receive Disconnect Provider Ultimatum.
[ gm] [ 41.794472] TSClient gracefully end.
[ rdpdr-scard] [ 41.796110] Close client connection 0 (id 1).
[ pfac] [ 41.796198] Process pid 605 terminated, status 00000009.
[ rdpdr-scard] [ 41.796242] Contexts left: 1, cards left: 0.
[ gm] [ 41.814916] Run '/sbin/resolver 0x1b37d68 dns [hdesserv132]', log '', env '', pid ''.
[ pfac] [ 41.815178] Run /sbin/resolver 0x1b37d68 dns [hdesserv132].
[ pfac] [ 41.815500] Ok, PID 613.
[ gm] [ 41.821014] hdesserv132 => 10.128.180.132.
[ pfac] [ 41.821232] Process pid 613 terminated, status 00000000.
[ gm] [ 41.821416] Free ram before fork terminal client /sbin/rdpclient (session 2): 924812 Kb.
[ gm] [ 41.821548] Run '/sbin/rdpclient 2', log '/tmp/rdpclient.out', env '', pid ''.
[ pfac] [ 41.821737] Run /sbin/rdpclient 2.
[ pfac] [ 41.821986] Ok, PID 614.
[ rdpclient 614] [ 41.828656] RDP Terminal Client, WTware v.5.4.52/RPi, pipe 2, pid 614.
[ rdpclient 614] [ 41.830843] Add smartcard redirection.
[ rdpdr-scard] [ 41.830957] New client connection, id 2.
[ rdpclient 614] [ 41.831002] Make RDP session with 10.128.180.132, port 3389.
[ rdpclient 614] [ 41.831084] No username.
[ rdpclient 614] [ 41.831161] No password.
[ rdpclient 614] [ 41.831238] No PIN.
[ rdpclient 614] [ 41.831315] Domain: "hdespd".
[ rdpclient 614] [ 41.831391] No shell.
[ rdpclient 614] [ 41.831467] No directory.
[ rdpclient 614] [ 41.831544] Window: 1440x900@16.
[ rdpclient 614] [ 41.831620] PFlags 0x0000002F.
[ rdpclient 614] [ 41.831696] Keyboard 00000816:00000000.
[ rdpclient 614] [ 41.831771] My hostname "ion".
[ rdpclient 614] [ 41.831847] TCP: connecting to 10.128.180.132:3389.
[ rdpclient 614] [ 41.852248] TCP: connection with 10.128.180.132:3389 established.
[ rdpclient 614] [ 41.852337] Turn keepalive on.
[ rdpclient 614] [ 41.853156] Free ram after buffers allocation: 924424 KB.
[ rdpclient 614] [ 41.940836] Process RDP server certificate.
[ rdpclient 614] [ 41.940952] RDP5 encryption (X.509).
[ rdpclient 614] [ 42.109246] Timezone '(UTC-01:00) Azores'.
[ rdpdr-scard] [ 42.591103] Reset client 2.
[ rdpdr-scard] [ 42.591223] Contexts left: 1, cards left: 0.
[ rdpclient 614] [ 73.751523] errorInfo 0x00000000.
[ rdpclient 614] [ 73.752243] Receive Disconnect Provider Ultimatum.
[ gm] [ 73.752333] TSClient gracefully end.
[ rdpdr-scard] [ 73.754127] Close client connection 0 (id 2).
[ rdpdr-scard] [ 73.754205] Contexts left: 1, cards left: 0.
[ pfac] [ 73.754331] Process pid 614 terminated, status 00000009.
[ gm] [ 73.772571] Run '/sbin/resolver 0x1b37d68 dns [hdesserv132]', log '', env '', pid ''.
[ pfac] [ 73.772711] Run /sbin/resolver 0x1b37d68 dns [hdesserv132].
[ pfac] [ 73.773075] Ok, PID 617.
[ gm] [ 73.778706] hdesserv132 => 10.128.180.132.
[ gm] [ 73.778852] Free ram before fork terminal client /sbin/rdpclient (session 3): 924756 Kb.
[ pfac] [ 73.778936] Run /sbin/rdpclient 3.
[ gm] [ 73.778980] Run '/sbin/rdpclient 3', log '/tmp/rdpclient.out', env '', pid ''.
[ pfac] [ 73.779207] Ok, PID 618.
[ pfac] [ 73.779773] Process pid 617 terminated, status 00000000.
[ rdpclient 618] [ 73.786228] RDP Terminal Client, WTware v.5.4.52/RPi, pipe 3, pid 618.
[ rdpclient 618] [ 73.787520] Add smartcard redirection.
[ rdpclient 618] [ 73.787619] Make RDP session with 10.128.180.132, port 3389.
[ rdpclient 618] [ 73.787709] No username.
[ rdpclient 618] [ 73.787796] No password.
[ rdpclient 618] [ 73.787873] No PIN.
[ rdpclient 618] [ 73.787951] Domain: "hdespd".
[ rdpdr-scard] [ 73.788026] New client connection, id 3.
[ rdpclient 618] [ 73.788068] No shell.
[ rdpclient 618] [ 73.788144] No directory.
[ rdpclient 618] [ 73.788220] Window: 1440x900@16.
[ rdpclient 618] [ 73.788297] PFlags 0x0000002F.
[ rdpclient 618] [ 73.788373] Keyboard 00000816:00000000.
[ rdpclient 618] [ 73.788450] My hostname "ion".
[ rdpclient 618] [ 73.788526] TCP: connecting to 10.128.180.132:3389.
[ rdpclient 618] [ 73.809160] TCP: connection with 10.128.180.132:3389 established.
[ rdpclient 618] [ 73.809255] Turn keepalive on.
[ rdpclient 618] [ 73.810115] Free ram after buffers allocation: 924484 KB.
[ rdpclient 618] [ 73.897987] Process RDP server certificate.
[ rdpclient 618] [ 73.898098] RDP5 encryption (X.509).
[ rdpclient 618] [ 74.066979] Timezone '(UTC-01:00) Azores'.
[ rdpdr-scard] [ 74.549811] Reset client 3.
[ rdpdr-scard] [ 74.549943] Contexts left: 1, cards left: 0.
[ rdpclient 618] [ 105.711391] errorInfo 0x00000000.
[ rdpclient 618] [ 105.712026] Receive Disconnect Provider Ultimatum.
[ gm] [ 105.712117] TSClient gracefully end.
[ rdpdr-scard] [ 105.713487] Close client connection 0 (id 3).
[ rdpdr-scard] [ 105.713565] Contexts left: 1, cards left: 0.
[ pfac] [ 105.713692] Process pid 618 terminated, status 00000009.
[ gm] [ 105.732329] Run '/sbin/resolver 0x1b37d68 dns [hdesserv132]', log '', env '', pid ''.
[ pfac] [ 105.732462] Run /sbin/resolver 0x1b37d68 dns [hdesserv132].
[ pfac] [ 105.732850] Ok, PID 637.
[ gm] [ 105.738196] hdesserv132 => 10.128.180.132.
[ pfac] [ 105.738440] Process pid 637 terminated, status 00000000.
[ gm] [ 105.738617] Free ram before fork terminal client /sbin/rdpclient (session 4): 924368 Kb.
[ gm] [ 105.738748] Run '/sbin/rdpclient 4', log '/tmp/rdpclient.out', env '', pid ''.
[ pfac] [ 105.738936] Run /sbin/rdpclient 4.
[ pfac] [ 105.739213] Ok, PID 638.
[ rdpclient 638] [ 105.746016] RDP Terminal Client, WTware v.5.4.52/RPi, pipe 4, pid 638.
[ rdpclient 638] [ 105.748162] Add smartcard redirection.
[ rdpdr-scard] [ 105.748268] New client connection, id 4.
[ rdpclient 638] [ 105.748348] Make RDP session with 10.128.180.132, port 3389.
[ rdpclient 638] [ 105.748427] No username.
[ rdpclient 638] [ 105.748507] No password.
[ rdpclient 638] [ 105.748583] No PIN.
[ rdpclient 638] [ 105.748660] Domain: "hdespd".
[ rdpclient 638] [ 105.748736] No shell.
[ rdpclient 638] [ 105.748812] No directory.
[ rdpclient 638] [ 105.748889] Window: 1440x900@16.
[ rdpclient 638] [ 105.748964] PFlags 0x0000002F.
[ rdpclient 638] [ 105.749042] Keyboard 00000816:00000000.
[ rdpclient 638] [ 105.749118] My hostname "ion".
[ rdpclient 638] [ 105.749195] TCP: connecting to 10.128.180.132:3389.
[ rdpclient 638] [ 105.769608] TCP: connection with 10.128.180.132:3389 established.
[ rdpclient 638] [ 105.769698] Turn keepalive on.
[ rdpclient 638] [ 105.770521] Free ram after buffers allocation: 924088 KB.
[ rdpclient 638] [ 105.858665] Process RDP server certificate.
[ rdpclient 638] [ 105.858771] RDP5 encryption (X.509).
[ rdpclient 638] [ 106.027923] Timezone '(UTC-01:00) Azores'.
[ rdpdr-scard] [ 106.508320] Reset client 4.
[ rdpdr-scard] [ 106.508451] Contexts left: 1, cards left: 0.

3 Blinks LOGFILE

aka
SUPPORT
SUPPORT
Posts: 484
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Display settings, power

Postby aka » Mon Nov 07, 2016 8:56 pm

It's a usual server behaviour. You will got the same if you'll try to connect old enough mstsc.exe, that displays the same login screen. As far as I know, this timeout is not configurable. You may use user= wtware option to select username from menu and ask_password= wtware option to ask password in wtware interface.

PedroMC
Posts: 6
Joined: Fri Nov 04, 2016 12:54 pm

Re: Display settings, power

Postby PedroMC » Mon Nov 07, 2016 10:29 pm

Ok, what we have done to bypass this, is to create 2 connections,

one that says Terminal Server and other connection that says other which is actually empty.. This way we dont have that blinking state but instead a pre menu.

Best regards


Return to “WTware on Raspberry Pi 3 / Raspberry Pi 2”

Who is online

Users browsing this forum: No registered users and 2 guests