menu.gif and keyboard issues

All about WTware on Raspberry. Wtware works with Raspberry Pi 3 Model B and Pi 2 Model B devices
http://www.winterminal.com
Soulphy
Posts: 7
Joined: Mon Jul 11, 2016 4:44 pm

menu.gif and keyboard issues

Postby Soulphy » Mon Jul 11, 2016 5:41 pm

Hello :),
i've got two problems. At first: I would change the connection and the user-login background. I made a picture menu.gif with 1024x768 and BPP=8 and put it in the directory /graphics on the sd-card. If i boot the pi i cant see only the standard blue background. :( Should i write something in the config e.g. where the picture is or somethin else?

The second problem: I've changed the keyboard and the language with: language=de,default and keyboard=de,default, now i can use äöü but the signs (;.-@ and more) are similiar to the english keyboard allocation.

Thank you :)

aka
SUPPORT
SUPPORT
Posts: 509
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: menu.gif and keyboard issues

Postby aka » Mon Jul 11, 2016 9:38 pm

Soulphy wrote:Hello :),
i've got two problems. At first: I would change the connection and the user-login background. I made a picture menu.gif with 1024x768 and BPP=8 and put it in the directory /graphics on the sd-card. If i boot the pi i cant see only the standard blue background. :( Should i write something in the config e.g. where the picture is or somethin else?


In graphic directory create new folder, e.g. "..\Graphic\sample\"
In config file specify

Code: Select all

skin=sample


If won't help, please send me terminal log file and all SD contents. To create terminal log enter terminal IP in web-browser from another computer in network.

Soulphy wrote:The second problem: I've changed the keyboard and the language with: language=de,default and keyboard=de,default, now i can use äöü but the signs (;.-@ and more) are similiar to the english keyboard allocation.
Thank you :)


Are you using the latest WTware version?

Soulphy
Posts: 7
Joined: Mon Jul 11, 2016 4:44 pm

Re: menu.gif and keyboard issues

Postby Soulphy » Thu Jul 14, 2016 12:49 pm

Hey thank you for your fast reply! :)
- Keyboard thing is solved (you are right, I've missed an update)
- menu.gif works on server selection screen but not on the user/password screen, should I use another .gif with a different name? Or is it possible to change the whole User-Login theme?

aka
SUPPORT
SUPPORT
Posts: 509
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: menu.gif and keyboard issues

Postby aka » Thu Jul 14, 2016 5:29 pm

Soulphy wrote:- menu.gif works on server selection screen but not on the user/password screen, should I use another .gif with a different name? Or is it possible to change the whole User-Login theme?


No, menu.gif should be used for both server selection screen and user selection screen. We'll check this. Please, show me the screenshot of the image you see instead of menu.gif.

Soulphy
Posts: 7
Joined: Mon Jul 11, 2016 4:44 pm

Re: menu.gif and keyboard issues

Postby Soulphy » Mon Jul 18, 2016 5:30 pm

Image

Image

I wanna see the same background from the first pic (server) in the second one.

aka
SUPPORT
SUPPORT
Posts: 509
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: menu.gif and keyboard issues

Postby aka » Mon Jul 18, 2016 9:38 pm

You didn't attached any images.

chris1182

Re: menu.gif and keyboard issues

Postby chris1182 » Wed Aug 17, 2016 4:41 pm

I'm also having issues getting the custom background to display on the login screen (I don't have a server selection screen)

I have created a menu.png file (1024 x768 8bit colour depth) and copied it to a separate folder within the Graphic directory. i.e. Graphic\sample

I then edited the config file to include the line i.e. skin=sample

However when I boot up the Pi I just see a blue screen and login prompt but no logo.

Any suggestions?

Thanks

aka
SUPPORT
SUPPORT
Posts: 509
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: menu.gif and keyboard issues

Postby aka » Wed Aug 17, 2016 10:50 pm

Do you want to see your image on this screen?
Untitled.png
Untitled.png (4.37 KiB) Viewed 1819 times


P.S. Here is what Dropbox shows me when I try to open your image:
Untitled.png
Untitled.png (224.76 KiB) Viewed 1819 times

Chris1182

Re: menu.gif and keyboard issues

Postby Chris1182 » Thu Aug 18, 2016 6:30 pm

Hi,

Thanks for the reply. Yes I want to put a custom background on that screen to show the company logo if possible.

Thanks

aka
SUPPORT
SUPPORT
Posts: 509
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: menu.gif and keyboard issues

Postby aka » Fri Aug 19, 2016 1:11 pm

Ok, will be in the next version.

aka
SUPPORT
SUPPORT
Posts: 509
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: menu.gif and keyboard issues

Postby aka » Tue Aug 23, 2016 12:03 am

Please, try 5.4.44 wtware version.

Chris1182

Re: menu.gif and keyboard issues

Postby Chris1182 » Wed Aug 24, 2016 6:50 pm

Hi aka,

My Raspberry Pi 3 will not boot with the new version. I have written the files to the SD card multiple times with no modification to the config files and I only get one brief flash on the activity light and then nothing on the screen etc..

Can you confirm that testing of the new version has been completed on a Raspberry Pi 3?

Thanks

Chris1182

Re: menu.gif and keyboard issues

Postby Chris1182 » Wed Aug 24, 2016 7:11 pm

Hi,

Please ignore the last post it was a problem with the VGA to HDMI adapter.

Thanks

Chris1182

Re: menu.gif and keyboard issues

Postby Chris1182 » Thu Aug 25, 2016 11:09 am

Logo is working and looking great on the login screen now thanks for the update :)

aka
SUPPORT
SUPPORT
Posts: 509
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: menu.gif and keyboard issues

Postby aka » Mon Aug 29, 2016 1:05 pm

Great :)


Return to “WTware on Raspberry Pi 3 / Raspberry Pi 2”

Who is online

Users browsing this forum: No registered users and 1 guest