Sound Broken in 5.4.30 for Pi3

All about WTware on Raspberry. Wtware works with Raspberry Pi 3 Model B and Pi 2 Model B devices
http://www.winterminal.com
J1mbo
Posts: 56
Joined: Mon Mar 14, 2016 6:24 pm

Sound Broken in 5.4.30 for Pi3

Postby J1mbo » Fri May 13, 2016 3:50 pm

We noticed that RDP audio isn't working with 5.4.30 (was working with Pi3 beta, 5.4.18 based I think). Logs show this:

Code: Select all

usbcore: registered new interface driver snd-usb-audio
     hardware.cpp ( 1095): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
     globalConfig.cpp ( 1631): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
 ERROR: Sound card not found. Disable sound.

J1mbo
Posts: 56
Joined: Mon Mar 14, 2016 6:24 pm

Re: Sound Broken in 5.4.30 for Pi3

Postby J1mbo » Fri May 13, 2016 4:59 pm

Here is the (working) log from 5.4.18:

Code: Select all

Unpack /bootmedia/packages/pi2-alsa.
[            gm] [   12.454845] modprobe snd-bcm2835.
[            gm] [   12.466010] modprobe snd-usb-audio.
/--- FILE "/proc/asound/devices" -----------------------
|   0: [ 0]   : control
|  16: [ 0- 0]: digital audio playback
|  17: [ 0- 1]: digital audio playback
|  33:        : timer
\----------------------------------------------------
[        KERNEL] [   12.478037] usbcore: registered new interface driver snd-usb-audio
[            gm] [   12.478336] /dev/snd/pcmC0D1p character device.
[            gm] [   12.478393] /dev/snd/pcmC0D0p character device.
[          pfac] [   12.478449] Run /sbin/rdpsnd sndvol 100 100 50.
[            gm] [   12.478473] /dev/snd/controlC0 character device.
[            gm] [   12.478516] /dev/snd/timer character device.
[          pfac] [   12.478580] Ok, PID 594.
[            gm] [   12.478611] Preconfigure ALSA.
[          pfac] [   12.478676] Run /sbin/rdpsnd 1 0 100 0 -1.
[            gm] [   12.478712] Run '/sbin/rdpsnd sndvol 100 100 50', log '', env '', pid ''.
[          pfac] [   12.478777] Ok, PID 595.
[            gm] [   12.478800] Run sound daemon.
[            gm] [   12.478840] Run '/sbin/rdpsnd 1 0 100 0 -1', log '', env '', pid ''.
[        rdpsnd] [   12.480915] RDP Sound Redirector, WTware v.5.4.18/Pi2.
[        rdpsnd] [   12.484249] Card 'ALSA'/'bcm2835 ALSA'.
[        rdpsnd] [   12.484378] Mixer name: 'Broadcom Mixer'.
[        sndvol] [   12.484447] Card 'ALSA'/'bcm2835 ALSA'.
[        rdpsnd] [   12.484472] Components: ''.
[        sndvol] [   12.484513] Mixer name: 'Broadcom Mixer'.
[        sndvol] [   12.484554] Components: ''.
[        sndvol] [   12.484594] Controls: 6.
[        sndvol] [   12.484634] ALSA: control 'PCM Playback Volume'.
[        sndvol] [   12.484675] ALSA: control 'PCM Playback Switch'.
[        sndvol] [   12.484715] ALSA: control 'PCM Playback Route'.
[        sndvol] [   12.484756] ALSA: control 'IEC958 Playback Default'.
[        sndvol] [   12.484796] ALSA: control 'IEC958 Playback Con Mask'.
[        sndvol] [   12.484837] ALSA: control 'IEC958 Playback PCM Stream'.
[        sndvol] [   12.484877] Inactive control IEC958 Playback PCM Stream'.
[        rdpsnd] [   12.484945] Controls: 6.
[        rdpsnd] [   12.485046] ALSA: control 'PCM Playback Volume'.
[        rdpsnd] [   12.485093] ALSA: control 'PCM Playback Switch'.
[        rdpsnd] [   12.485136] ALSA: control 'PCM Playback Route'.
[        rdpsnd] [   12.485177] ALSA: control 'IEC958 Playback Default'.
[        rdpsnd] [   12.485218] ALSA: control 'IEC958 Playback Con Mask'.
[        rdpsnd] [   12.485258] ALSA: control 'IEC958 Playback PCM Stream'.
[        rdpsnd] [   12.485298] Inactive control IEC958 Playback PCM Stream'.

aka
SUPPORT
SUPPORT
Posts: 496
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Sound Broken in 5.4.30 for Pi3

Postby aka » Sun May 15, 2016 2:19 pm

Onboard sound at RPi should be enabled in config.txt at SD card now.

J1mbo
Posts: 56
Joined: Mon Mar 14, 2016 6:24 pm

Re: Sound Broken in 5.4.30 for Pi3

Postby J1mbo » Tue May 17, 2016 12:46 pm

Thanks, so it is:

# Enable onboard audio (HDMI or jack).
dtparam=audio=on

kmen
Posts: 2
Joined: Thu May 26, 2016 10:30 am

Re: Sound Broken in 5.4.30 for Pi3

Postby kmen » Thu May 26, 2016 11:29 am

and the sound option should be on?
sound=on

J1mbo
Posts: 56
Joined: Mon Mar 14, 2016 6:24 pm

Re: Sound Broken in 5.4.30 for Pi3

Postby J1mbo » Thu May 26, 2016 11:46 am

Yes. To edit config.txt, you can use a browser, http://[terminal-ip]/

mstorck
Posts: 1
Joined: Mon Aug 15, 2016 1:35 am

Re: Sound Broken in 5.4.30 for Pi3

Postby mstorck » Mon Aug 15, 2016 1:43 am

I have set

Code: Select all

sound=on

in configuration file. I also set

Code: Select all

dtparam=audio=on

in config.txt and finally I also set

Code: Select all

hdmi_drive=2

in config.txt. But I still have these log entries:

Code: Select all

[            gm] [   77.376233] Unpack /bootmedia/packages/pi2-alsa.
[            gm] [   77.426514] modprobe snd-bcm2835.
[            gm] [   77.435422] modprobe snd-usb-audio.
[        KERNEL] [   77.453718] usbcore: registered new interface driver snd-usb-audio
[            gm] [   92.457032]         hardware.cpp ( 1095): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[            gm] [   92.457184]     globalConfig.cpp ( 1624): -- ERROR -- INTERNAL ERROR. Please, contact WTware tech support.
[            gm] [   92.457267] ERROR: Sound card not found. Disable sound.

and of course no audio/sound within an RDP session.
I'm running

Code: Select all

WTware v.5.4.40/RPi supervisor.
on RPi3.
Another ThinClient OS for RPi has working sound on the same hardware.

Any ideas to get this working with WTware?

aka
SUPPORT
SUPPORT
Posts: 496
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Sound Broken in 5.4.30 for Pi3

Postby aka » Mon Aug 15, 2016 11:34 pm

Please, send me whole log and all files on SD in zip to aka@pxe.ru

nhelder
Posts: 1
Joined: Thu Oct 20, 2016 3:09 am

Re: Sound Broken in 5.4.30 for Pi3

Postby nhelder » Tue Oct 25, 2016 6:41 am

Hi, all~

I came across this thread as I was having issues getting audio out of the audio jack for my Pi3 when running WTware.

The eventual combination of settings that did the trick for me, in the config.txt file, were:

Code: Select all

# hdmi_drive  result
# 1           Normal DVI mode (No sound)
# 2           Normal HDMI mode (Sound will be sent if supported and enabled)
hdmi_drive=1

# Setting this to 1 pretends that all audio formats are unsupported by the display.
# This means ALSA will default to the analogue audio (headphone) jack.
hdmi_ignore_edid_audio=1

# Enable onboard audio (HDMI or jack).
dtparam=audio=on

# Enable improved audio driver
# https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=136445
audio_pwm_mode=2

...just thought I would share for others that might run in to a similar issue.

- Nathan

P.S. For completeness, my config file looks simply like:

Code: Select all

server=--new--
graphic=adf
sound=on
sound_rate=44100
sleep=20
connect_timeout=5
connection


Return to “WTware on Raspberry Pi 3 / Raspberry Pi 2”

Who is online

Users browsing this forum: No registered users and 2 guests