Google Chrome

How it works in WTware without terminal server
aka
SUPPORT
SUPPORT
Posts: 528
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Google Chrome

Postby aka » Thu Oct 17, 2013 3:18 pm

In WTware there's built-in Google Chrome now.

It starts by this line in configuration file:

Code: Select all

application=chrome


Adobe Flash works (hello thinstation :wink:). PDF viewer works.

Parameters language and keyswitchnow also set the language and key switch sequence for Google Chrome.

To work through proxy-server there are settings chrome_proxy and chrome_pac in configuration file. It can be configured in profile - chrome_profile parameter.


Items that don't work and will be fixed:
1. End of Chrome work is not traced. If user closed chrome window, only terminal reset will help him.
2. Sound doesn't work. Will be fixed while creating local skype/sip.
3. Printing from Chrome is not supported. I don't realize how to perform local printing in Linux, so that were supported at least half of printers, that work now in WTware from Windows. Will be fixed some day later.
4. Clipboard doesn't work.

Google Chrome works only with video=...(U). There's no way to run Chrome if video=...(F) or (X). If on your computer with at least 512MB RAM no (U) driver starts, please, send us a letter, we'll fix it.

Google Chrome needs a lot of memory. On terminals with 256 MB RAM you can start it only if there's swap in disk. On 512MB Chrome starts, but it can crush from lack of memory if several big flash movies work at once.

WTware installation on hard disk: Google Chrome and other additional packages are installed automatically on hard disk if only disk volume is not less that 250MB. If installer finds disk with volume 500MB or more, it creates two partitions on this disk. The first one about 240MB with FAT file system as usual for WTware files and configurations.The second one - all the remaining disk space for swap. This can cause problems with installation of WTware on different flash-disks. Not on USB-flash, but on used as hard drives stationary flash. I.e. CF on ebox froont panel. Swap partition will be created on it, if there's enough free space. But writing to this swap can be too slow, and it will slow down all work. Or won't? If tests will confirm this problem - we'll fix it.

Added special parameters for Chrome configuration - chrome_url, chrome_mode, chrome_profile. About Chrome confguration by profile read special article: viewtopic.php?f=17&t=46977#p75013

There's no our banner on Chrome. WTware with Google Chrome works without license, all works for free. Cheers us :)

Carl

Re: Google Chrome

Postby Carl » Thu Mar 03, 2016 5:53 pm

I'm trying to use Google Chrome on a Raspberry Pi (2) and get the message:

To run Chrome or VLS specify Video=...(U)

I honestly have no idea where to start to troubleshoot. I chosed every option on video with a (U) and none worked.

Is Google Chrome built into the kernel, or should I have something in my TFTP folder for Chrome?

Is there any howto information? say something with "you need these basic options" to get chrome to work

application = chrome
chrome_url=http://www.google.com
chrome_mode=kiosk
chrome_language=en
video=openchrome(U)


Any help would be appreciated!

Thanks,
Carl

aka
SUPPORT
SUPPORT
Posts: 528
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Google Chrome

Postby aka » Fri Mar 04, 2016 10:32 am

There are no VLC and Chrome for Pi yet.

Rah

Re: Google Chrome

Postby Rah » Fri Jun 17, 2016 4:31 pm

Aka,

Can you give us an idea if Chrome is going to be available on Pi anytime soon? 2016 Q3 /2017 Q2?

Thanks!

aka
SUPPORT
SUPPORT
Posts: 528
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Google Chrome

Postby aka » Sun Jun 19, 2016 7:13 pm

We don't want to add Chrome support right now, for it's too heavy and distributive will become too large for downloading by Pi.

JNienerza
Posts: 4
Joined: Wed Sep 27, 2017 6:20 pm

Re: Google Chrome

Postby JNienerza » Mon Oct 02, 2017 4:17 pm

Hi aka,

Is Chrome going to be available on Pi anytime soon? 2017 Q4 or 2018 Q1. Why is Chrome in the parameters then? Do you plan an other web browser for connecting with the client?

Thank you

CKoewing
Posts: 8
Joined: Mon Oct 02, 2017 7:22 pm

Re: Google Chrome

Postby CKoewing » Mon Oct 02, 2017 7:54 pm

We need Chrome, otherwise WTware is not a Solution for us and we have to choose NoTouch or ThinLinx. :-(

aka
SUPPORT
SUPPORT
Posts: 528
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Google Chrome

Postby aka » Tue Oct 03, 2017 7:01 am

JNienerza wrote:Is Chrome going to be available on Pi anytime soon? 2017 Q4 or 2018 Q1.

2017 Q4.

JNienerza wrote:Why is Chrome in the parameters then?

It works on x86 wtware.

JNienerza wrote:Do you plan an other web browser for connecting with the client?

No.

JNienerza
Posts: 4
Joined: Wed Sep 27, 2017 6:20 pm

Re: Google Chrome

Postby JNienerza » Wed Oct 04, 2017 5:08 pm

Hi aka,

does the connection via chrome works in version 5.6.16. What are the settings we need to change in the configuration file. (We tried it, and it doesn't work.) Or is there a later version where you try to fullfill this? If yes, can we have a beta-version?

best regards

Jan

akatik
SUPPORT
SUPPORT
Posts: 103
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Google Chrome

Postby akatik » Thu Oct 05, 2017 9:39 am

If chrome (really, if something at all) doesn't work - show us log: https://wtware.com/logs.html

CKoewing
Posts: 8
Joined: Mon Oct 02, 2017 7:22 pm

Re: Google Chrome

Postby CKoewing » Thu Oct 05, 2017 5:38 pm

We always get the following error message:

To run Chrome or VLC specify video=...(U) in configuration file.


Our Settings:

WTware Settings - 01 - Terminal.jpg
WTware Settings - 01 - Terminal.jpg (23.03 KiB) Viewed 90 times

WTware Settings - 02 - Connection.jpg
WTware Settings - 02 - Connection.jpg (16.93 KiB) Viewed 90 times


What is wrong?

Best regards,
Chris

JNienerza
Posts: 4
Joined: Wed Sep 27, 2017 6:20 pm

Re: Google Chrome

Postby JNienerza » Thu Oct 05, 2017 7:04 pm

log file
WTware Center_2017-10-05_15_24_23.png
WTware Center_2017-10-05_15_24_23.png (6.53 KiB) Viewed 85 times


error message on RasPi-Client is "To run Chrome or VLC specify video=...(U) in configuration file."

Why do I have to specify Video? What does Video has to do with chrome? How do I specify the settings(video or others) to connect chrome?

akatik
SUPPORT
SUPPORT
Posts: 103
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Google Chrome

Postby akatik » Fri Oct 06, 2017 8:50 am

Google Chrome doesn't work on Pi for now.

CKoewing
Posts: 8
Joined: Mon Oct 02, 2017 7:22 pm

Re: Google Chrome

Postby CKoewing » Fri Oct 06, 2017 12:05 pm

Beta/Test-Version available/possible?

akatik
SUPPORT
SUPPORT
Posts: 103
Joined: Mon Jan 17, 2005 6:30 pm
Contact:

Re: Google Chrome

Postby akatik » Fri Oct 06, 2017 1:54 pm

No. It will be in public version when it will be supported.


Return to “Google Chrome”

Who is online

Users browsing this forum: No registered users and 1 guest