Local resources not seen on a terminal

Topics that doesn't fall into the categories above
fielettro
Posts: 3
Joined: Sat Dec 03, 2016 1:07 pm

Local resources not seen on a terminal

Postby fielettro » Sat Dec 03, 2016 1:24 pm

Hello,
I have successfully installed wtware 5.4.62 (demo)on a win Xp machine.
The client boots from pxe and all seems ok.
At the moment i have only one thin client (hp 7600).
From the thin client im' trying to access to the local sata disk (not used for boot) but i cannot see it.
Also i try to connect to the client an usb microchip programmer but i cannot see it.
The only local resources i can see are : usb memory stick, cd/dvd.
But from the client i can see the resources of the server.

Have any suggestions?
Regards
Carl

aka
SUPPORT
SUPPORT
Posts: 515
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Local resources not seen on a terminal

Postby aka » Sun Dec 04, 2016 12:42 pm

There is no magic wand to share local resources. Different kind of resources are shared with different methods and different chance to success.

There is no redirection for local hard disk in WTware. Because it's not a good idea to store data on thin client.

To redirect usb memory stick, add "disk=usb" into terminal config. Or "disk=usb,cdrom" for usb memory stick and cdrom.

Here are all config file options: http://wtware.com/docs5/config.html

fielettro
Posts: 3
Joined: Sat Dec 03, 2016 1:07 pm

Re: Local resources not seen on a terminal

Postby fielettro » Sun Dec 04, 2016 11:52 pm

Thanks for your reply!
Yes I see easily usb memory strick, but i have problems to use locally on the client an usb microchip programmer (PicKit3 from Microchip).
Any help is very appreciate.
Rgds
Carl

aka
SUPPORT
SUPPORT
Posts: 515
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Local resources not seen on a terminal

Postby aka » Mon Dec 05, 2016 1:40 pm

There is no redirection method for "usb microchip programmer" devices. Need more device details. If it's a com-port, serial device with usb-serial chip, "serial=com5(usb)" may work.
http://wtware.com/docs5/config.html#serial
There is general USB redirection method for 2012R2: viewforum.php?f=25
Run wtware with device attached and show me terminal log: http://wtware.com/docs5/logs.html

fielettro
Posts: 3
Joined: Sat Dec 03, 2016 1:07 pm

Re: Local resources not seen on a terminal

Postby fielettro » Mon Dec 05, 2016 9:56 pm

Hi,
below are attached Log file and USB file.
The usb devices:
USB ID: 04d8:900a, bus ID: 5-1, class: 0x00, subclass: 0x00, Microchip Technology, Inc. PICkit3
and
USB ID: 090c:037c, bus ID: 1-4, class: 0xef, subclass: 0x02, Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) 300k Pixel Camera.

I think they are recognized by the client but i cannot see them as resources and so i cannot use them.

Thanks
Carl
Attachments
USB_ID.txt
(771 Bytes) Downloaded 54 times
LOG.txt
(75.83 KiB) Downloaded 54 times

aka
SUPPORT
SUPPORT
Posts: 515
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: Local resources not seen on a terminal

Postby aka » Tue Dec 06, 2016 7:34 am

PICkit3 does not look like serial device. So only USB bus redirection can help. Please, read here: viewforum.php?f=25
The same about camera.
USB redirection requires some magic even in mstsc.exe. And it will not work in wtware if it does not work in mstsc.


Return to “Other”

Who is online

Users browsing this forum: No registered users and 1 guest