keyboard language Problem

Topics that doesn't fall into the categories above
gourdon
Posts: 7
Joined: Sat Dec 07, 2013 3:41 pm

keyboard language Problem

Postby gourdon » Tue Mar 04, 2014 9:12 pm

Hello,

We have a problem to login in terminal server session. I have configured the Windows TS and the WTware correctly, but it seem that the keyboard configuration does not work fine.
When user enters his password, the keyboard is QWERTY, and of course there is an login error, then user enters his password a second time (keyboard is detected in french).
these keyboards are configured in french, but they does not work correctly.
I have send you the terminal log to your support address.
Thank you per advance.
Regards.
JMG

aka
SUPPORT
SUPPORT
Posts: 527
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: keyboard language Problem

Postby aka » Wed Mar 05, 2014 11:26 am

gourdon wrote:When user enters his password, the keyboard is QWERTY

Right. You put "ask_password=on", so wtware makes first request with it's internal keyboard handling. We should add french keybourd set to wtware. Do you really need "ask_password=on" mode? This mode is for multiple servers farm with network load balancing only. You may remove "ask_password=on" line, then first password request will not appear.

gourdon wrote:then user enters his password a second time (keyboard is detected in french).
these keyboards are configured in french, but they does not work correctly.

Please, tell me more details. What did not work correctly?

gourdon
Posts: 7
Joined: Sat Dec 07, 2013 3:41 pm

Re: keyboard language Problem

Postby gourdon » Wed Mar 05, 2014 12:36 pm

Hello,

Thank you, for the answered.

Sorry, I mean what is not working properly is writing password
Well, yes i need ask_password=on, because this is a servers farm Windows Server 2008R2.
I could asked the users that they change these password, but i prefer wait that you found a linux solution.

Another problem : The terminal session does not close at the end of the configured time ?
Our GPO is configure to close the session at 3 hour without activity, but it not work.
The session is open all the time !

Thank you by advance for your answered.

Regards.
JMG

aka
SUPPORT
SUPPORT
Posts: 527
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: keyboard language Problem

Postby aka » Wed Mar 05, 2014 1:44 pm

gourdon wrote:I could asked the users that they change these password, but i prefer wait that you found a linux solution.


Is it right french keyboard layout?

ftp://ftp.software.ibm.com/software/glo ... KBD189.pdf

gourdon wrote:Another problem : The terminal session does not close at the end of the configured time ?
Our GPO is configure to close the session at 3 hour without activity, but it not work.
The session is open all the time !


I heard about this problem, but noone investigated it. We are unable to reproduce it at our testing stands.

Timeouts less than a hour will work, right?

gourdon
Posts: 7
Joined: Sat Dec 07, 2013 3:41 pm

Re: keyboard language Problem

Postby gourdon » Wed Mar 05, 2014 8:37 pm

Aka wrote:Is it right french keyboard layout?


Yes, our keyboards are like this : http://tinyurl.com/clavier-azerty

Aka wrote:Timeouts less than a hour will work, right?


I will test that, this evening. But that not really help us, because we prefer 3 hours.

Regards.

aka
SUPPORT
SUPPORT
Posts: 527
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: keyboard language Problem

Postby aka » Thu Mar 06, 2014 9:42 am

Please, download and run this:
http://pxe.ru/files/testing/201403060359.zip
Specify in config file:

Code: Select all

user=--new--
ask_password=on
language=fr,default

Boot wtware. Move mouse to the right bottom corner to be sure that 5.1.59 version really booted.
wtware should display two fields for user and password.
Try to type letters in user line and look what it displays.
Does it looks like french layout?
This build will print lines in log for every key you press.
Tell me please, which letters for user/password keys displayed incorrectly and show me log lines for those keys.

gourdon
Posts: 7
Joined: Sat Dec 07, 2013 3:41 pm

Re: keyboard language Problem

Postby gourdon » Thu Mar 06, 2014 9:41 pm

Good evening,

I have setup the latest version.
I have enters this letters in this order : "a q z w m" so on the screen, they appears like this : "q a w z ;"

There is the log line :

[gm] evdev.cpp ( 493), key: Key 16 pressed.
[gm] evdev.cpp ( 559), key: Translate scan 16 to local 69.
[gm] layer-input.cpp ( 182), _input_keyPress: Translate 69 to 113.
[gm] evdev.cpp ( 488), key: Key 16 released.
[gm] evdev.cpp ( 559), key: Translate scan 16 to local 69.
[gm] evdev.cpp ( 493), key: Key 30 pressed.
[gm] evdev.cpp ( 559), key: Translate scan 30 to local 90.
[gm] layer-input.cpp ( 182), _input_keyPress: Translate 90 to 97.
[gm] evdev.cpp ( 488), key: Key 30 released.
[gm] evdev.cpp ( 559), key: Translate scan 30 to local 90.
[gm] evdev.cpp ( 493), key: Key 17 pressed.
[gm] evdev.cpp ( 559), key: Translate scan 17 to local 70.
[gm] layer-input.cpp ( 182), _input_keyPress: Translate 70 to 119.
[gm] evdev.cpp ( 488), key: Key 17 released.
[gm] evdev.cpp ( 559), key: Translate scan 17 to local 70.
[gm] evdev.cpp ( 493), key: Key 44 pressed.
[gm] evdev.cpp ( 559), key: Translate scan 44 to local 106.
[gm] layer-input.cpp ( 182), _input_keyPress: Translate 106 to 122.
[gm] evdev.cpp ( 488), key: Key 44 released.
[gm] evdev.cpp ( 559), key: Translate scan 44 to local 106.
[gm] evdev.cpp ( 493), key: Key 39 pressed.
[gm] evdev.cpp ( 559), key: Translate scan 39 to local 99.
[gm] layer-input.cpp ( 182), _input_keyPress: Translate 99 to 59.
[gm] evdev.cpp ( 488), key: Key 39 released.
[gm] evdev.cpp ( 559), key: Translate scan 39 to local 99.


Thank you by advance for your answered.

Regards.
JMG

aka
SUPPORT
SUPPORT
Posts: 527
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: keyboard language Problem

Postby aka » Fri Mar 07, 2014 12:00 am

Ups. I found one bug.

Please, put the line

Code: Select all

language=fr,default


in the very beginning of the config file.

You should get blue square with FR letters in right bottom corner.

gourdon
Posts: 7
Joined: Sat Dec 07, 2013 3:41 pm

Re: keyboard language Problem

Postby gourdon » Fri Mar 07, 2014 12:02 pm

Hello,

Ho yes, sorry, i confused between language=fr and keyboard=fr

Now it works fine, but there is no FR letters in the blue square in right bottom corner.

Thank you very much for your reactivity

Regards.
JMG

aka
SUPPORT
SUPPORT
Posts: 527
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: keyboard language Problem

Postby aka » Fri Mar 07, 2014 1:49 pm

Hi,

FR letters:

fr.png
fr.png (14.6 KiB) Viewed 6172 times


You did not see it, but keyboard works as AZERTY instead of QWERTY? Funny. Please, boot up the terminal, press left top key (q in qwerty, a in azerty) and send me whole log to aka@pxe.ru

Thank you.

Ralf Holighaus

Re: keyboard language Problem

Postby Ralf Holighaus » Thu Jun 02, 2016 3:39 pm

Hi,

I'm having the same issue with a German keyboard - the sequence is QWERTUIOPÜ.


The setting "keyboard = de" does the trick once in the RDP session - it's before the RDP session gets established that we run into problems. Users will be unable to input their passwords if they contain any characters with keyboard positions different to the underlying US English keyboard.

The setting is "language=de,default" and a "DE" shows at the right lower corner.
Typing the letter Z in the username still shows a Y.

Please help!

Regards,
Ralf.

aka
SUPPORT
SUPPORT
Posts: 527
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: keyboard language Problem

Postby aka » Thu Jun 30, 2016 7:23 pm


sanipeter
Posts: 2
Joined: Thu Nov 03, 2016 6:51 pm

Re: keyboard language Problem

Postby sanipeter » Thu Nov 03, 2016 6:58 pm

Hi,

we have a similar problem with our german keyboards.
The Y and Z keys are mapped correct for password input.

But the # key inputs a \ and the ' key inputs a |
All other special cahrs work quite well (@, ö, ä, ü, !,...).

The first two lines of our config files are:
keyboard = de
language = de,default

What can I do?

Best regards,
Peter

aka
SUPPORT
SUPPORT
Posts: 527
Joined: Fri Dec 03, 2004 2:05 pm
Contact:

Re: keyboard language Problem

Postby aka » Wed Nov 09, 2016 2:23 am

Please, try wtware 5.4.54. Use same config.

sanipeter
Posts: 2
Joined: Thu Nov 03, 2016 6:51 pm

Re: keyboard language Problem

Postby sanipeter » Fri Nov 11, 2016 10:53 am

Thank you!
The keyboard layout in wtware 5.4.54 is correct now. :-)


Return to “Other”

Who is online

Users browsing this forum: No registered users and 1 guest